Difference: CREAMReleaseUMD4_5_0 (9 vs. 10)

Revision 102017-06-20 - PaoloAndreetto

Line: 1 to 1
 
META TOPICPARENT name="ReleaseNotes"

Release for UMD 4.5.0

Configuration

The YAIM configurator is not supported anymore, a puppet module is available for the installation, for further details refer to the module page

Changed:
<
<
If HTCondor is use, the HTCondor services on the computing element must be restarted after the installation of the CREAM service.
>
>
If HTCondor is the batch system adopted, the HTCondor services on the computing element must be restarted after the installation of the CREAM service.
 

Notes

  • This is the initial release of the CREAM CE on CentOS 7
  • This release delivers a draft support to Accelerator Devices (GPU, MIC), see the experimental features
  • The supported batch systems are:
Batch System Version
TORQUE 4.2.10
SLURM 16.05.10
HTCondor 8.6.3
LSF 7.0

Fixed issues

Known issues

  • The puppet module can be used only in "stand alone mode", puppet agent may report parsing problems.
  • The CREAM UI requires classads libraries up to version 8.4.11, it does not work with versions 8.6.*

Packages

The packages available for the CREAM service are the following:

Package Name Version
Changed:
<
<
BLAH 1.22.0
BLAH-debuginfo 1.22.0
>
>
BLAH 1.22.2
BLAH-debuginfo 1.22.2
 
canl-java-tomcat 0.2.1
Added:
>
>
condor-classads-blah-patch 0.0.1
 
dynsched-generic 2.5.5
glite-ce-common-java 1.16.5
glite-ce-common-java-doc 1.16.5
glite-ce-cream 1.16.5
glite-ce-cream-api-java 1.16.6
glite-ce-cream-core 1.16.5
glite-ce-cream-utils 1.3.6
glite-ce-wsdl 1.15.1
glite-jdl-api-java 3.3.2
glite-jdl-api-java-doc 3.3.2
info-dynamic-scheduler-lsf 2.3.8
info-dynamic-scheduler-lsf-btools 2.3.8
info-dynamic-scheduler-slurm 1.0.4
lcg-info-dynamic-scheduler-condor 1.1
lcg-info-dynamic-scheduler-pbs 2.4.6

The packages available for the CREAM UI are the following:

Package Name Version
glite-ce-cream-cli 1.15.4
glite-ce-cream-client-api-c 1.15.5
glite-ce-cream-client-devel 1.15.5
glite-jdl-api-cpp 3.4.4
glite-jdl-api-cpp-devel 3.4.4
glite-jdl-api-cpp-doc 3.4.4
glite-wms-utils-classad 3.4.3
glite-wms-utils-classad-devel 3.4.3
glite-wms-utils-exception 3.4.3
glite-wms-utils-exception-devel 3.4.3

The main repositories are:

Deleted:
<
<
The third party repository required for the deployment of the service is:
  The PGP key can be downloaded from this link
Added:
>
>
The epel-release package is required
 For HTCondor classads libraries refer to
  • the latest stable release for the CREAM service
  • the release 8.4 for the CREAM UI
The PGP key can be downloaded from the official link

-- PaoloAndreetto - 2017-05-29

 
This site is powered by the TWiki collaboration platformCopyright © 2008-2020 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback