PATCH 4001

Upgrade from production

  • Upgrade steps: due to a conflict between VOMS API packages the following workaround is required
    rpm -e glite-security-voms-api-noglobus glite-UI
    
    in order to migrate from VOMS 1.8 into VOMS 1.9; then the upgrade of the CREAM UI takes these steps:
    wget http://etics-repository.cern.ch/repository/pm/registered/repomd/id/574297b6-e239-44d9-bb1d-7e3298adb026/slc4_ia32_gcc346/etics-registered-build-by-id.repo -O /etc/yum.repos.d/glite-CREAMCLI.repo
    yum update
    

  • view the log of YUM for the client upgrade

Automatic tests

  • Run the following tests from the testsuite: output for TORQUE CE.
    • CREAM-cli-delegation.sh: OK
    • CREAM-cli-delegation-renew.sh: OK
    • CREAM-cli-job-submit: OK
    • CREAM-cli-job-status-simple.sh: OK
    • CREAM-cli-job-status-filtered.sh: OK
    • CREAM-cli-job-cancel.sh: OK
    • CREAM-cli-job-suspend.sh: Failed because suspend command is not supported
    • CREAM-cli-job-resume.sh: Failed because resume command is not supported
    • CREAM-cli-job-purge.sh: OK
    • CREAM-cli-job-list.sh: OK
    • CREAM-cli-submission-management.sh: OK
    • CREAM-cli-event-query.sh: OK
    • CREAM-cli-service-info.sh: OK

Topic attachments
I Attachment Action Size Date Who Comment
Unknown file formatgz CREAM-cli-test.log.gz manage 9.6 K 2010-04-23 - 09:19 PaoloAndreetto CREAM CLI tests
Unknown file formatgz yum_update_log.txt.gz manage 1.0 K 2010-04-23 - 07:37 PaoloAndreetto YUM log for upgrade
Edit | Attach | PDF | History: r4 < r3 < r2 < r1 | Backlinks | Raw View | More topic actions
Topic revision: r4 - 2011-02-24 - AlessioGianelle
 
This site is powered by the TWiki collaboration platformCopyright © 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback