EMI Test Report

- Component: WMS 3.3.0

- Savannah task: #18568

- ETICS Configuration Name: emi-wms_B_3_3

- VCS Tag: Not available

- EMI Major Release: EMI 1

- Platform: sl5

- Author: Alessio Gianelle

- Date: 2011-03-01

Summary

1. Deployment log:

  1. Clean Installation - FAIL
  2. Upgrade Installation - NA

2. Static Code Analysis - NP

3. Unit Test coverage - NP

4. Component tests:

  1. Basic Functionality tests - NP
  2. Regression tests - NP
  3. Performance/Scalability tests - NP
  4. Standard Compliance/Conformance tests - NP

REMARKS:

Detailed Testing Report

Deployment log

Clean Installation

  • YUM Testing Repo file contents:
[EMI-1-RC0]
name=EMI 1 RC0 Repository
baseurl=http://emisoft.web.cern.ch/emisoft/dist/EMI/1/RC0/sl5/$basearch/
protect=1
enabled=1
  • YUM Install command: yum install glite-WMS
  • YUM log:
Loaded plugins: kernel-module, protectbase
EGI-trustanchors                                                                                                    | 1.9 kB     00:00     
EGI-trustanchors/primary_db                                                                                         |  40 kB     00:00     
EMI-1-RC0                                                                                                           |  951 B     00:00     
EMI-1-RC0/primary                                                                                                   |  87 kB     00:00     
EMI-1-RC0                                                                                                                          390/390
epel                                                                                                                | 3.7 kB     00:00     
epel/primary_db                                                                                                     | 3.6 MB     00:01     
sl-base                                                                                                             | 2.1 kB     00:00     
sl-base/primary_db                                                                                                  | 2.0 MB     00:02     
sl-security                                                                                                         | 1.9 kB     00:00     
sl-security/primary_db                                                                                              | 821 kB     00:00     
159 packages excluded due to repository protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package glite-WMS.x86_64 0:3.3.99-0.sl5 set to be updated
--> Processing Dependency: fetch-crl for package: glite-WMS
--> Processing Dependency: glite-info-provider-service for package: glite-WMS
--> Processing Dependency: glite-version for package: glite-WMS
--> Processing Dependency: lcg-expiregridmapdir for package: glite-WMS
--> Processing Dependency: glite-wms-jobsubmission for package: glite-WMS
--> Processing Dependency: fcgi for package: glite-WMS
--> Processing Dependency: glue-schema for package: glite-WMS
--> Processing Dependency: glite-yaim-wms for package: glite-WMS
--> Processing Dependency: glite-wms-wmproxy for package: glite-WMS
--> Processing Dependency: glite-wms-manager for package: glite-WMS
--> Processing Dependency: glite-wms-ice for package: glite-WMS
--> Processing Dependency: lcmaps-plugins-voms for package: glite-WMS
--> Processing Dependency: bdii for package: glite-WMS
--> Processing Dependency: glite-LB for package: glite-WMS
--> Processing Dependency: glite-info-provider-release for package: glite-WMS
--> Processing Dependency: lcas-plugins-basic for package: glite-WMS
--> Processing Dependency: lcas-plugins-voms for package: glite-WMS
--> Processing Dependency: glite-info-templates for package: glite-WMS
--> Processing Dependency: lcas-lcmaps-gt4-interface for package: glite-WMS
--> Running transaction check
---> Package bdii.noarch 0:5.1.22-1 set to be updated
---> Package fcgi.x86_64 0:2.4.0-12.el5 set to be updated
---> Package fetch-crl.noarch 0:2.7.0-1 set to be updated
---> Package glite-LB.x86_64 0:3.2.12-5emi.sl5 set to be updated
--> Processing Dependency: glite-lb-server for package: glite-LB
--> Processing Dependency: glite-lb-doc for package: glite-LB
--> Processing Dependency: glite-lb-harvester for package: glite-LB
--> Processing Dependency: glite-lb-logger for package: glite-LB
--> Processing Dependency: glite-lb-yaim for package: glite-LB
--> Processing Dependency: glite-lb-ws-test for package: glite-LB
--> Processing Dependency: glite-lb-utils for package: glite-LB
---> Package glite-WMS.x86_64 0:3.3.99-0.sl5 set to be updated
--> Processing Dependency: glite-wms-jobsubmission for package: glite-WMS
--> Processing Dependency: glite-wms-manager for package: glite-WMS
--> Processing Dependency: lcas-lcmaps-gt4-interface for package: glite-WMS
---> Package glite-info-provider-release.noarch 0:1.0.2-1 set to be updated
---> Package glite-info-provider-service.noarch 0:1.4.4-1 set to be updated
---> Package glite-info-templates.noarch 0:1.0.0-12 set to be updated
---> Package glite-version.noarch 0:3.2.3-1 set to be updated
---> Package glite-wms-ice.x86_64 0:3.3.99-0.sl5 set to be updated
--> Processing Dependency: glite-px-proxyrenewal for package: glite-wms-ice
--> Processing Dependency: log4cpp for package: glite-wms-ice
--> Processing Dependency: glite-wms-configuration for package: glite-wms-ice
--> Processing Dependency: glite-wms-purger for package: glite-wms-ice
--> Processing Dependency: glite-ce-monitor-client-api-c for package: glite-wms-ice
--> Processing Dependency: glite-ce-cream-client-api-c for package: glite-wms-ice
--> Processing Dependency: classads for package: glite-wms-ice
--> Processing Dependency: boost for package: glite-wms-ice
--> Processing Dependency: glite-wms-common for package: glite-wms-ice
--> Processing Dependency: libglobus_ftp_control.so.1()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglobus_ftp_client.so.2()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglite_ce_cream_client_soap.so.0()(64bit) for package: glite-wms-ice
--> Processing Dependency: libmyproxy.so.5()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglite_security_proxyrenewal.so.1()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglite_lb_common.so.9()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglobus_proxy_ssl.so.1()(64bit) for package: glite-wms-ice
--> Processing Dependency: liblog4cpp.so.4()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglobus_gsi_callback.so.0()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglite_lb_clientpp.so.4()(64bit) for package: glite-wms-ice
--> Processing Dependency: libgridsite_globus.so.1.7()(64bit) for package: glite-wms-ice
--> Processing Dependency: libcares.so.2()(64bit) for package: glite-wms-ice
--> Processing Dependency: libboost_thread.so.2()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglobus_gssapi_error.so.2()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglobus_usage.so.0()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglobus_gsi_cert_utils.so.0()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglite_wms_conf.so.0()(64bit) for package: glite-wms-ice
--> Processing Dependency: libclassad_ns.so.1()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglobus_xio.so.0()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglobus_oldgaa.so.0()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglite_wmsutils_classads.so.0()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglobus_gssapi_gsi.so.4()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglite_lb_client.so.4()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglobus_callout.so.0()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglite_security_gsoap_plugin_276b.so.1()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglobus_io.so.3()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglobus_gsi_credential.so.1()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglite_wms_purger.so.0()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglobus_gsi_sysconfig.so.1()(64bit) for package: glite-wms-ice
--> Processing Dependency: libboost_regex.so.2()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglobus_openssl.so.0()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglite_wmsutils_exception.so.0()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglite_wms_logger.so.0()(64bit) for package: glite-wms-ice
--> Processing Dependency: libboost_filesystem.so.2()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglite_ce_monitor_consumer.so.0()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglite_ce_monitor_client.so.0()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-wms-ice
--> Processing Dependency: libclassad.so.1()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglite_jobid.so.2()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglite_lbu_trio.so.2()(64bit) for package: glite-wms-ice
--> Processing Dependency: libboost_program_options.so.2()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglite_wms_util.so.0()(64bit) for package: glite-wms-ice
--> Processing Dependency: libboost_serialization.so.2()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglobus_gsi_proxy_core.so.0()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglobus_openssl_error.so.0()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglite_security_proxyrenewal_core.so.1()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglite_ce_cream_client_util.so.0()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglobus_common.so.0()(64bit) for package: glite-wms-ice
--> Processing Dependency: libboost_date_time.so.2()(64bit) for package: glite-wms-ice
--> Processing Dependency: libvomsapi.so.1()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglobus_gss_assist.so.3()(64bit) for package: glite-wms-ice
---> Package glite-wms-wmproxy.x86_64 0:3.3.99-0.sl5 set to be updated
--> Processing Dependency: glite-service-discovery-api-c for package: glite-wms-wmproxy
--> Processing Dependency: glite-wms-configuration for package: glite-wms-wmproxy
--> Processing Dependency: lcmaps-without-gsi for package: glite-wms-wmproxy
--> Processing Dependency: lcmaps-plugins-basic for package: glite-wms-wmproxy
--> Processing Dependency: libtar for package: glite-wms-wmproxy
--> Processing Dependency: glite-jdl-api-cpp for package: glite-wms-wmproxy
--> Processing Dependency: glite-jobid-api-cpp for package: glite-wms-wmproxy
--> Processing Dependency: gridsite-apache for package: glite-wms-wmproxy
--> Processing Dependency: httpd for package: glite-wms-wmproxy
--> Processing Dependency: mod_fastcgi for package: glite-wms-wmproxy
--> Processing Dependency: mod_ssl for package: glite-wms-wmproxy
--> Processing Dependency: libtar.so.1()(64bit) for package: glite-wms-wmproxy
--> Processing Dependency: liblcmaps_return_poolindex_without_gsi.so.0()(64bit) for package: glite-wms-wmproxy
--> Processing Dependency: libglite_jdl_api_cpp.so.0()(64bit) for package: glite-wms-wmproxy
--> Processing Dependency: libglite-sd-c.so.2()(64bit) for package: glite-wms-wmproxy
--> Processing Dependency: liblcmaps_without_gsi.so.0()(64bit) for package: glite-wms-wmproxy
---> Package glite-yaim-wms.noarch 0:4.1.99-0 set to be updated
--> Processing Dependency: glite-yaim-core for package: glite-yaim-wms
---> Package glue-schema.noarch 0:2.0.6-1 set to be updated
---> Package lcas-plugins-basic.x86_64 0:1.3.4-0.sl5 set to be updated
--> Processing Dependency: lcas for package: lcas-plugins-basic
---> Package lcas-plugins-voms.x86_64 0:1.3.4-3.sl5 set to be updated
--> Processing Dependency: libgridsite.so.1.5()(64bit) for package: lcas-plugins-voms
---> Package lcg-expiregridmapdir.noarch 0:2.1.0-1 set to be updated
---> Package lcmaps-plugins-voms.x86_64 0:1.3.7-2.sl5 set to be updated
--> Processing Dependency: lcmaps for package: lcmaps-plugins-voms
--> Running transaction check
---> Package boost.x86_64 0:1.33.1-10.el5 set to be updated
--> Processing Dependency: libicuuc.so.36()(64bit) for package: boost
--> Processing Dependency: libicui18n.so.36()(64bit) for package: boost
---> Package c-ares.x86_64 0:1.6.0-2.el5 set to be updated
---> Package classads.x86_64 0:1.0.8-1.el5 set to be updated
---> Package glite-LB.x86_64 0:3.2.12-5emi.sl5 set to be updated
--> Processing Dependency: glite-lb-server for package: glite-LB
--> Processing Dependency: glite-lb-ws-test for package: glite-LB
---> Package glite-WMS.x86_64 0:3.3.99-0.sl5 set to be updated
--> Processing Dependency: glite-wms-jobsubmission for package: glite-WMS
--> Processing Dependency: glite-wms-manager for package: glite-WMS
--> Processing Dependency: lcas-lcmaps-gt4-interface for package: glite-WMS
---> Package glite-ce-cream-client-api-c.x86_64 0:1.13.99-0.sl5 set to be updated
---> Package glite-ce-monitor-client-api-c.x86_64 0:1.13.99-0.sl5 set to be updated
--> Processing Dependency: libglite_security_gss.so.9()(64bit) for package: glite-ce-monitor-client-api-c
---> Package glite-jdl-api-cpp.x86_64 0:3.2.99-0.sl5 set to be updated
---> Package glite-jobid-api-c.x86_64 0:2.0.0-2.sl5 set to be updated
---> Package glite-jobid-api-cpp.x86_64 0:1.1.0-2.sl5 set to be updated
---> Package glite-lb-client.x86_64 0:4.1.2-2emi.sl5 set to be updated
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lb-client
---> Package glite-lb-common.x86_64 0:7.1.6-2emi.sl5 set to be updated
---> Package glite-lb-doc.x86_64 0:1.1.10-2emi.sl5 set to be updated
---> Package glite-lb-harvester.x86_64 0:1.0.9-2emi.sl5 set to be updated
--> Processing Dependency: glite-lbjp-common-log for package: glite-lb-harvester
--> Processing Dependency: glite-lbjp-common-db for package: glite-lb-harvester
--> Processing Dependency: libglite_lbu_log.so.1()(64bit) for package: glite-lb-harvester
--> Processing Dependency: liblog4c.so.3()(64bit) for package: glite-lb-harvester
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lb-harvester
--> Processing Dependency: libglite_lbu_db.so.2()(64bit) for package: glite-lb-harvester
---> Package glite-lb-logger.x86_64 0:2.1.10-2emi.sl5 set to be updated
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lb-logger
---> Package glite-lb-utils.x86_64 0:2.0.7-2emi.sl5 set to be updated
--> Processing Dependency: glite-lbjp-common-maildir for package: glite-lb-utils
--> Processing Dependency: glite-lb-state-machine for package: glite-lb-utils
--> Processing Dependency: glite-lbjp-common-jp-interface for package: glite-lb-utils
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lb-utils
--> Processing Dependency: libglite_lbu_db.so.2()(64bit) for package: glite-lb-utils
--> Processing Dependency: libglite_jp_common.so.2()(64bit) for package: glite-lb-utils
--> Processing Dependency: libglite_lbu_maildir.so.2()(64bit) for package: glite-lb-utils
---> Package glite-lb-yaim.x86_64 0:4.2.13-2emi.sl5 set to be updated
---> Package glite-lbjp-common-gsoap-plugin.x86_64 0:2.1.2-2emi.sl5 set to be updated
--> Processing Dependency: gsoap for package: glite-lbjp-common-gsoap-plugin
--> Processing Dependency: libgsoap.so.0()(64bit) for package: glite-lbjp-common-gsoap-plugin
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lbjp-common-gsoap-plugin
---> Package glite-lbjp-common-gss.x86_64 0:2.1.4-1emi.sl5 set to be updated
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-wms-purger
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lb-utils
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-wms-wmproxy
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lbjp-common-gsoap-plugin
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lb-client
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lb-harvester
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lb-logger
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-wms-ice
---> Package glite-lbjp-common-trio.x86_64 0:2.1.0-2.sl5 set to be updated
---> Package glite-px-proxyrenewal.x86_64 0:1.3.13-1.sl5 set to be updated
---> Package glite-service-discovery-api-c.x86_64 0:2.2.99-0.sl5 set to be updated
---> Package glite-wms-common.x86_64 0:3.3.99-0.sl5 set to be updated
---> Package glite-wms-ice.x86_64 0:3.3.99-0.sl5 set to be updated
--> Processing Dependency: glite-wms-configuration for package: glite-wms-ice
--> Processing Dependency: libgridsite_globus.so.1.7()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-wms-ice
---> Package glite-wms-purger.x86_64 0:3.3.99-0.sl5 set to be updated
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-wms-purger
---> Package glite-wms-utils-classad.x86_64 0:3.2.99-0.sl5 set to be updated
---> Package glite-wms-utils-exception.x86_64 0:3.2.99-0.sl5 set to be updated
---> Package glite-wms-wmproxy.x86_64 0:3.3.99-0.sl5 set to be updated
--> Processing Dependency: glite-wms-configuration for package: glite-wms-wmproxy
--> Processing Dependency: mod_fastcgi for package: glite-wms-wmproxy
--> Processing Dependency: libgridsite_globus.so.1.7()(64bit) for package: glite-wms-wmproxy
--> Processing Dependency: libgridsite.so.1.7()(64bit) for package: glite-wms-wmproxy
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-wms-wmproxy
---> Package glite-yaim-core.noarch 0:4.0.14-1 set to be updated
---> Package globus-callout.x86_64 0:0.7-6.el5 set to be updated
--> Processing Dependency: globus-libtool >= 1 for package: globus-callout
---> Package globus-common.x86_64 0:11.5-3.el5 set to be updated
---> Package globus-ftp-client.x86_64 0:5.3-2.el5 set to be updated
--> Processing Dependency: globus-xio-popen-driver for package: globus-ftp-client
---> Package globus-ftp-control.x86_64 0:2.11-1.el5 set to be updated
---> Package globus-gsi-callback.x86_64 0:2.7-1.el5 set to be updated
--> Processing Dependency: globus-openssl >= 1 for package: globus-gsi-callback
---> Package globus-gsi-cert-utils.x86_64 0:6.6-1.el5 set to be updated
---> Package globus-gsi-credential.x86_64 0:3.5-1.el5 set to be updated
---> Package globus-gsi-openssl-error.x86_64 0:0.14-6.el5 set to be updated
---> Package globus-gsi-proxy-core.x86_64 0:4.5-1.el5 set to be updated
---> Package globus-gsi-proxy-ssl.x86_64 0:2.3-1.el5 set to be updated
---> Package globus-gsi-sysconfig.x86_64 0:3.1-1.el5 set to be updated
---> Package globus-gss-assist.x86_64 0:5.9-2.el5 set to be updated
---> Package globus-gssapi-error.x86_64 0:2.5-5.el5 set to be updated
---> Package globus-gssapi-gsi.x86_64 0:7.5-1.el5 set to be updated
---> Package globus-io.x86_64 0:6.3-4.el5 set to be updated
--> Processing Dependency: globus-xio-gsi-driver for package: globus-io
---> Package globus-openssl-module.x86_64 0:1.3-1.el5 set to be updated
---> Package globus-usage.x86_64 0:1.3-1.el5 set to be updated
---> Package globus-xio.x86_64 0:2.8-2.el5 set to be updated
---> Package gridsite-apache.x86_64 0:1.7.10-4.sl5 set to be updated
---> Package gridsite-shared.x86_64 0:1.7.10-3emi.sl5 set to be updated
--> Processing Dependency: libgridsite.so.1.7()(64bit) for package: glite-wms-wmproxy
--> Processing Dependency: libgridsite_globus.so.1.7()(64bit) for package: glite-wms-wmproxy
--> Processing Dependency: libgridsite_globus.so.1.7()(64bit) for package: glite-wms-ice
---> Package gridsite-shared.x86_64 0:1.7.10-4.sl5 set to be updated
---> Package httpd.x86_64 0:2.2.3-43.sl5.3 set to be updated
EGI-trustanchors/filelists_db                                                                                       |  13 kB     00:00     
EMI-1-RC0/filelists                                                                                                 |  93 kB     00:00     
epel/filelists_db                                                                                                   | 5.0 MB     00:01     
sl-base/filelists_db                                                                                                | 3.6 MB     00:03     
sl-security/filelists_db                                                                                            | 3.2 MB     00:02     
--> Processing Dependency: libaprutil-1.so.0()(64bit) for package: httpd
--> Processing Dependency: libapr-1.so.0()(64bit) for package: httpd
---> Package lcas.x86_64 0:1.3.12-0.sl5 set to be updated
---> Package lcmaps.x86_64 0:1.4.27-1.sl5 set to be updated
---> Package lcmaps-plugins-basic.x86_64 0:1.3.7-2.sl5 set to be updated
---> Package lcmaps-without-gsi.x86_64 0:1.4.27-1.sl5 set to be updated
---> Package libtar.x86_64 0:1.2.11-13.el5 set to be updated
---> Package log4cpp.x86_64 0:1.0-9.el5 set to be updated
---> Package mod_ssl.x86_64 1:2.2.3-43.sl5.3 set to be updated
--> Processing Dependency: libdistcache.so.1()(64bit) for package: mod_ssl
--> Processing Dependency: libnal.so.1()(64bit) for package: mod_ssl
---> Package myproxy-libs.x86_64 0:5.3-1.el5 set to be updated
--> Processing Dependency: libvomsc.so.0()(64bit) for package: myproxy-libs
---> Package voms.x86_64 0:2.0.0-1.sl5 set to be updated
--> Running transaction check
---> Package apr.x86_64 0:1.2.7-11.el5_3.1 set to be updated
---> Package apr-util.x86_64 0:1.2.7-11.el5_5.2 set to be updated
--> Processing Dependency: libpq.so.4()(64bit) for package: apr-util
---> Package distcache.x86_64 0:1.4.5-14.1 set to be updated
---> Package glite-LB.x86_64 0:3.2.12-5emi.sl5 set to be updated
--> Processing Dependency: glite-lb-server for package: glite-LB
--> Processing Dependency: glite-lb-ws-test for package: glite-LB
---> Package glite-WMS.x86_64 0:3.3.99-0.sl5 set to be updated
--> Processing Dependency: glite-wms-jobsubmission for package: glite-WMS
--> Processing Dependency: glite-wms-manager for package: glite-WMS
--> Processing Dependency: lcas-lcmaps-gt4-interface for package: glite-WMS
---> Package glite-lb-client.x86_64 0:4.1.2-2emi.sl5 set to be updated
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lb-client
---> Package glite-lb-harvester.x86_64 0:1.0.9-2emi.sl5 set to be updated
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lb-harvester
--> Processing Dependency: libglite_lbu_db.so.2()(64bit) for package: glite-lb-harvester
---> Package glite-lb-logger.x86_64 0:2.1.10-2emi.sl5 set to be updated
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lb-logger
---> Package glite-lb-state-machine.x86_64 0:1.1.3-2emi.sl5 set to be updated
---> Package glite-lb-utils.x86_64 0:2.0.7-2emi.sl5 set to be updated
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lb-utils
--> Processing Dependency: libglite_lbu_db.so.2()(64bit) for package: glite-lb-utils
---> Package glite-lbjp-common-db.x86_64 0:3.0.0-2.sl5 set to be updated
---> Package glite-lbjp-common-gsoap-plugin.x86_64 0:2.1.2-2emi.sl5 set to be updated
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lbjp-common-gsoap-plugin
---> Package glite-lbjp-common-gss.x86_64 0:2.1.4-1emi.sl5 set to be updated
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-wms-purger
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lb-utils
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-wms-wmproxy
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lbjp-common-gsoap-plugin
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lb-client
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lb-harvester
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lb-logger
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-wms-ice
---> Package glite-lbjp-common-gss.x86_64 0:3.0.0-2.sl5 set to be updated
---> Package glite-lbjp-common-jp-interface.x86_64 0:2.1.0-2.sl5 set to be updated
---> Package glite-lbjp-common-log.x86_64 0:1.1.0-2.sl5 set to be updated
---> Package glite-lbjp-common-maildir.x86_64 0:2.1.0-2.sl5 set to be updated
---> Package glite-wms-ice.x86_64 0:3.3.99-0.sl5 set to be updated
--> Processing Dependency: glite-wms-configuration for package: glite-wms-ice
--> Processing Dependency: libgridsite_globus.so.1.7()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-wms-ice
---> Package glite-wms-purger.x86_64 0:3.3.99-0.sl5 set to be updated
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-wms-purger
---> Package glite-wms-wmproxy.x86_64 0:3.3.99-0.sl5 set to be updated
--> Processing Dependency: glite-wms-configuration for package: glite-wms-wmproxy
--> Processing Dependency: mod_fastcgi for package: glite-wms-wmproxy
--> Processing Dependency: libgridsite_globus.so.1.7()(64bit) for package: glite-wms-wmproxy
--> Processing Dependency: libgridsite.so.1.7()(64bit) for package: glite-wms-wmproxy
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-wms-wmproxy
---> Package globus-libtool.x86_64 0:1.2-4.el5 set to be updated
---> Package globus-openssl.x86_64 0:5.1-2.el5 set to be updated
---> Package globus-xio-gsi-driver.x86_64 0:0.6-5.el5 set to be updated
---> Package globus-xio-popen-driver.x86_64 0:0.9-1.el5 set to be updated
---> Package gridsite-shared.x86_64 0:1.7.10-3emi.sl5 set to be updated
--> Processing Dependency: libgridsite.so.1.7()(64bit) for package: glite-wms-wmproxy
--> Processing Dependency: libgridsite_globus.so.1.7()(64bit) for package: glite-wms-wmproxy
--> Processing Dependency: libgridsite_globus.so.1.7()(64bit) for package: glite-wms-ice
---> Package gsoap.x86_64 0:2.7.13-3.el5 set to be updated
---> Package libicu.x86_64 0:3.6-5.11.4 set to be updated
---> Package log4c.x86_64 0:1.2.1-7.el5 set to be updated
---> Package myproxy-libs.x86_64 0:5.3-1.el5 set to be updated
--> Processing Dependency: libvomsc.so.0()(64bit) for package: myproxy-libs
--> Running transaction check
---> Package glite-LB.x86_64 0:3.2.12-5emi.sl5 set to be updated
--> Processing Dependency: glite-lb-server for package: glite-LB
--> Processing Dependency: glite-lb-ws-test for package: glite-LB
---> Package glite-WMS.x86_64 0:3.3.99-0.sl5 set to be updated
--> Processing Dependency: glite-wms-jobsubmission for package: glite-WMS
--> Processing Dependency: glite-wms-manager for package: glite-WMS
--> Processing Dependency: lcas-lcmaps-gt4-interface for package: glite-WMS
---> Package glite-lb-client.x86_64 0:4.1.2-2emi.sl5 set to be updated
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lb-client
---> Package glite-lb-harvester.x86_64 0:1.0.9-2emi.sl5 set to be updated
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lb-harvester
--> Processing Dependency: libglite_lbu_db.so.2()(64bit) for package: glite-lb-harvester
---> Package glite-lb-logger.x86_64 0:2.1.10-2emi.sl5 set to be updated
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lb-logger
---> Package glite-lb-utils.x86_64 0:2.0.7-2emi.sl5 set to be updated
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lb-utils
--> Processing Dependency: libglite_lbu_db.so.2()(64bit) for package: glite-lb-utils
---> Package glite-lbjp-common-gsoap-plugin.x86_64 0:2.1.2-2emi.sl5 set to be updated
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lbjp-common-gsoap-plugin
---> Package glite-lbjp-common-gss.x86_64 0:2.1.4-1emi.sl5 set to be updated
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-wms-purger
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lb-utils
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-wms-wmproxy
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lbjp-common-gsoap-plugin
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lb-client
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lb-harvester
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-lb-logger
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-wms-ice
---> Package glite-wms-ice.x86_64 0:3.3.99-0.sl5 set to be updated
--> Processing Dependency: glite-wms-configuration for package: glite-wms-ice
--> Processing Dependency: libgridsite_globus.so.1.7()(64bit) for package: glite-wms-ice
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-wms-ice
---> Package glite-wms-purger.x86_64 0:3.3.99-0.sl5 set to be updated
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-wms-purger
---> Package glite-wms-wmproxy.x86_64 0:3.3.99-0.sl5 set to be updated
--> Processing Dependency: glite-wms-configuration for package: glite-wms-wmproxy
--> Processing Dependency: mod_fastcgi for package: glite-wms-wmproxy
--> Processing Dependency: libgridsite_globus.so.1.7()(64bit) for package: glite-wms-wmproxy
--> Processing Dependency: libgridsite.so.1.7()(64bit) for package: glite-wms-wmproxy
--> Processing Dependency: libglite_security_gss.so.1()(64bit) for package: glite-wms-wmproxy
---> Package gridsite-shared.x86_64 0:1.7.10-3emi.sl5 set to be updated
--> Processing Dependency: libgridsite.so.1.7()(64bit) for package: glite-wms-wmproxy
--> Processing Dependency: libgridsite_globus.so.1.7()(64bit) for package: glite-wms-wmproxy
--> Processing Dependency: libgridsite_globus.so.1.7()(64bit) for package: glite-wms-ice
---> Package myproxy-libs.x86_64 0:5.3-1.el5 set to be updated
--> Processing Dependency: libvomsc.so.0()(64bit) for package: myproxy-libs
---> Package postgresql-libs.x86_64 0:8.1.23-1.el5_6.1 set to be updated
--> Finished Dependency Resolution
myproxy-libs-5.3-1.el5.x86_64 from epel has depsolving problems
  --> Missing Dependency: libvomsc.so.0()(64bit) is needed by package myproxy-libs-5.3-1.el5.x86_64 (epel)
glite-wms-wmproxy-3.3.99-0.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: libgridsite.so.1.7()(64bit) is needed by package glite-wms-wmproxy-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
glite-lb-harvester-1.0.9-2emi.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: libglite_security_gss.so.1()(64bit) is needed by package glite-lb-harvester-1.0.9-2emi.sl5.x86_64 (EMI-1-RC0)
glite-lbjp-common-gsoap-plugin-2.1.2-2emi.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: libglite_security_gss.so.1()(64bit) is needed by package glite-lbjp-common-gsoap-plugin-2.1.2-2emi.sl5.x86_64 (EMI-1-RC0)
glite-LB-3.2.12-5emi.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: glite-lb-server is needed by package glite-LB-3.2.12-5emi.sl5.x86_64 (EMI-1-RC0)
glite-lb-logger-2.1.10-2emi.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: libglite_security_gss.so.1()(64bit) is needed by package glite-lb-logger-2.1.10-2emi.sl5.x86_64 (EMI-1-RC0)
glite-WMS-3.3.99-0.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: glite-wms-jobsubmission is needed by package glite-WMS-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
glite-lb-harvester-1.0.9-2emi.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: libglite_security_gss.so.1()(64bit) is needed by package glite-lb-harvester-1.0.9-2emi.sl5.x86_64 (EMI-1-RC0)
glite-WMS-3.3.99-0.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: glite-wms-manager is needed by package glite-WMS-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
glite-lb-logger-2.1.10-2emi.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: libglite_security_gss.so.1()(64bit) is needed by package glite-lb-logger-2.1.10-2emi.sl5.x86_64 (EMI-1-RC0)
glite-wms-wmproxy-3.3.99-0.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: libgridsite.so.1.7()(64bit) is needed by package glite-wms-wmproxy-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
glite-wms-wmproxy-3.3.99-0.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: libgridsite_globus.so.1.7()(64bit) is needed by package glite-wms-wmproxy-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
glite-wms-wmproxy-3.3.99-0.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: mod_fastcgi is needed by package glite-wms-wmproxy-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
glite-wms-ice-3.3.99-0.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: glite-wms-configuration is needed by package glite-wms-ice-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
glite-wms-purger-3.3.99-0.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: libglite_security_gss.so.1()(64bit) is needed by package glite-wms-purger-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
glite-wms-wmproxy-3.3.99-0.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: libglite_security_gss.so.1()(64bit) is needed by package glite-wms-wmproxy-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
glite-wms-wmproxy-3.3.99-0.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: libgridsite_globus.so.1.7()(64bit) is needed by package glite-wms-wmproxy-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
glite-LB-3.2.12-5emi.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: glite-lb-ws-test is needed by package glite-LB-3.2.12-5emi.sl5.x86_64 (EMI-1-RC0)
glite-lb-client-4.1.2-2emi.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: libglite_security_gss.so.1()(64bit) is needed by package glite-lb-client-4.1.2-2emi.sl5.x86_64 (EMI-1-RC0)
glite-wms-ice-3.3.99-0.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: libglite_security_gss.so.1()(64bit) is needed by package glite-wms-ice-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
glite-wms-ice-3.3.99-0.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: libgridsite_globus.so.1.7()(64bit) is needed by package glite-wms-ice-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
glite-wms-wmproxy-3.3.99-0.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: libglite_security_gss.so.1()(64bit) is needed by package glite-wms-wmproxy-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
glite-lb-utils-2.0.7-2emi.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: libglite_lbu_db.so.2()(64bit) is needed by package glite-lb-utils-2.0.7-2emi.sl5.x86_64 (EMI-1-RC0)
glite-wms-ice-3.3.99-0.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: libglite_security_gss.so.1()(64bit) is needed by package glite-wms-ice-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
glite-WMS-3.3.99-0.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: lcas-lcmaps-gt4-interface is needed by package glite-WMS-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
glite-lb-utils-2.0.7-2emi.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: libglite_security_gss.so.1()(64bit) is needed by package glite-lb-utils-2.0.7-2emi.sl5.x86_64 (EMI-1-RC0)
glite-wms-ice-3.3.99-0.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: libgridsite_globus.so.1.7()(64bit) is needed by package glite-wms-ice-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
glite-wms-wmproxy-3.3.99-0.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: glite-wms-configuration is needed by package glite-wms-wmproxy-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
glite-lb-harvester-1.0.9-2emi.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: libglite_lbu_db.so.2()(64bit) is needed by package glite-lb-harvester-1.0.9-2emi.sl5.x86_64 (EMI-1-RC0)
glite-lb-utils-2.0.7-2emi.sl5.x86_64 from EMI-1-RC0 has depsolving problems
  --> Missing Dependency: libglite_security_gss.so.1()(64bit) is needed by package glite-lb-utils-2.0.7-2emi.sl5.x86_64 (EMI-1-RC0)
Beginning Kernel Module Plugin
Finished Kernel Module Plugin
Error: Missing Dependency: libglite_security_gss.so.1()(64bit) is needed by package glite-lb-harvester-1.0.9-2emi.sl5.x86_64 (EMI-1-RC0)
Error: Missing Dependency: libgridsite_globus.so.1.7()(64bit) is needed by package glite-wms-wmproxy-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
Error: Missing Dependency: libglite_lbu_db.so.2()(64bit) is needed by package glite-lb-utils-2.0.7-2emi.sl5.x86_64 (EMI-1-RC0)
Error: Missing Dependency: glite-wms-jobsubmission is needed by package glite-WMS-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
Error: Missing Dependency: libglite_security_gss.so.1()(64bit) is needed by package glite-lb-logger-2.1.10-2emi.sl5.x86_64 (EMI-1-RC0)
Error: Missing Dependency: lcas-lcmaps-gt4-interface is needed by package glite-WMS-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
Error: Missing Dependency: libgridsite_globus.so.1.7()(64bit) is needed by package glite-wms-ice-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
Error: Missing Dependency: glite-wms-manager is needed by package glite-WMS-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
Error: Missing Dependency: libglite_security_gss.so.1()(64bit) is needed by package glite-lb-client-4.1.2-2emi.sl5.x86_64 (EMI-1-RC0)
Error: Missing Dependency: mod_fastcgi is needed by package glite-wms-wmproxy-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
Error: Missing Dependency: glite-wms-configuration is needed by package glite-wms-wmproxy-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
Error: Missing Dependency: glite-lb-ws-test is needed by package glite-LB-3.2.12-5emi.sl5.x86_64 (EMI-1-RC0)
Error: Missing Dependency: glite-lb-server is needed by package glite-LB-3.2.12-5emi.sl5.x86_64 (EMI-1-RC0)
Error: Missing Dependency: libvomsc.so.0()(64bit) is needed by package myproxy-libs-5.3-1.el5.x86_64 (epel)
Error: Missing Dependency: libglite_lbu_db.so.2()(64bit) is needed by package glite-lb-harvester-1.0.9-2emi.sl5.x86_64 (EMI-1-RC0)
Error: Missing Dependency: libglite_security_gss.so.1()(64bit) is needed by package glite-wms-wmproxy-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
Error: Missing Dependency: libglite_security_gss.so.1()(64bit) is needed by package glite-lb-utils-2.0.7-2emi.sl5.x86_64 (EMI-1-RC0)
Error: Missing Dependency: libglite_security_gss.so.1()(64bit) is needed by package glite-lbjp-common-gsoap-plugin-2.1.2-2emi.sl5.x86_64 (EMI-1-RC0)
Error: Missing Dependency: libgridsite.so.1.7()(64bit) is needed by package glite-wms-wmproxy-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
Error: Missing Dependency: glite-wms-configuration is needed by package glite-wms-ice-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
Error: Missing Dependency: libglite_security_gss.so.1()(64bit) is needed by package glite-wms-purger-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
Error: Missing Dependency: libglite_security_gss.so.1()(64bit) is needed by package glite-wms-ice-3.3.99-0.sl5.x86_64 (EMI-1-RC0)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
  • Configuration log:

Upgrade Installation

  • YUM Production Repo file contents:
  • YUM Install command:
  • YUM Testing Repo file contents:
  • YUM Upgrade command:
  • YUM log:
  • Configuration log:

Static Code Analysis

Not Possible

Unit Tests Coverage

Not Possible

System tests

Functionality tests

Not Possible

Regression tests

Not Possible

Performance and Scalability tests

Not Possible

Standard Compliance/Conformance tests

Not Possible

-- AlessioGianelle - 2011-03-01

Topic revision: r2 - 2011-03-02 - AlessioGianelle
 
This site is powered by the TWiki collaboration platformCopyright © 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback