Devel07 Work Log

2011-05-06 (Ale)

  • Update kernel: 2.6.18-238.9.1.el5

2011-03-25 (Ale)

  • Installed puppet
  • Update Kernel
  • Update LB
     glite-LB                                x86_64          3.2.12-8.sl5                          LB-Update               3.5 k
     glite-info-templates                    noarch          1.0.0-12                              LB-Update               8.8 k
     glite-lb-client                         x86_64          4.1.7-2.sl5                           LB-Update               1.9 M
     glite-lb-common                         x86_64          7.1.8-2.sl5                           LB-Update               733 k
     glite-lb-doc                            x86_64          1.1.11-2.sl5                          LB-Update               3.0 M
     glite-lb-harvester                      x86_64          1.0.10-4.sl5                          LB-Update                75 k
     glite-lb-logger                         x86_64          2.1.12-2.sl5                          LB-Update                87 k
     glite-lb-server                         x86_64          2.1.14-2.sl5                          LB-Update               899 k
     glite-lb-state-machine                  x86_64          1.1.4-4.sl5                           LB-Update               153 k
     glite-lb-utils                          x86_64          2.0.8-3.sl5                           LB-Update                64 k
     glite-lb-ws-interface                   x86_64          3.1.2-6.sl5                           LB-Update                19 k
     glite-lb-ws-test                        x86_64          1.1.5-4.sl5                           LB-Update               1.0 M
     glite-lb-yaim                           x86_64          4.2.14-3.sl5                          LB-Update               9.2 k
     glite-lbjp-common-db                    x86_64          2.0.5-2.sl5                           LB-Update                66 k
     glite-lbjp-common-jp-interface          x86_64          2.0.3-3.sl5                           LB-Update                41 k
     glite-lbjp-common-maildir               x86_64          2.0.2-3.sl5                           LB-Update                14 k
     glite-lbjp-common-server-bones          x86_64          2.0.3-2.sl5                           LB-Update                25 k
     glite-lbjp-common-trio                  x86_64          2.0.3-3.sl5                           LB-Update                71 k
     glite-security-util-java                noarch          2.9.2-1.GL32                          LB-Update               338 k
     glite-security-voms-api-cpp             x86_64          1.9.19-2.sl5                          LB-Update               4.5 M
     glite-yaim-core                         noarch          4.0.14-1                              LB-Update               125 k
     glue-schema                             noarch          2.0.6-1                               LB-Update                33 k
     gpt                                     x86_64          3.2_4.0.8p1_x86_64_rhap_5-1           LB-External             1.3 M
     gridsite-shared                         x86_64          1.7.9-3.sl5                           LB-Update               129 k
    

2010-11-10 (Ale)

  • update glite 3.2 20:
    Installing:
     glite-lb-yaim                              x86_64             4.2.13-2.sl5                    LB-Release              9.2 k
         replacing  glite-yaim-lb.noarch 4.2.1-1
    
    Updating:
     c-ares                                     x86_64             1.6.0-1.el5                     LB-External              47 k
     glite-LB                                   x86_64             3.2.12-5.sl5                    LB-Update               3.5 k
     glite-info-provider-service                noarch             1.4.3-0                         LB-Update                48 k
     glite-jobid-api-c                          x86_64             1.0.6-1.sl5                     LB-Update                19 k
     glite-lb-client                            x86_64             4.1.5-2.sl5                     LB-Update               1.9 M
     glite-lb-common                            x86_64             7.1.6-2.sl5                     LB-Update               732 k
     glite-lb-doc                               x86_64             1.1.10-2.sl5                    LB-Update               3.0 M
     glite-lb-logger                            x86_64             2.1.10-2.sl5                    LB-Update                85 k
     glite-lb-server                            x86_64             2.1.12-2.sl5                    LB-Update               898 k
     glite-lb-state-machine                     x86_64             1.1.3-2.sl5                     LB-Update               153 k
     glite-lb-utils                             x86_64             2.0.7-2.sl5                     LB-Update                61 k
     glite-lb-ws-interface                      x86_64             3.1.2-3.sl5                     LB-Update                19 k
     glite-lb-ws-test                           x86_64             1.1.4-2.sl5                     LB-Update               1.0 M
     glite-lbjp-common-db                       x86_64             2.0.4-2.sl5                     LB-Update                66 k
     glite-lbjp-common-jp-interface             x86_64             2.0.2-2.sl5                     LB-Update                41 k
     glite-lbjp-common-maildir                  x86_64             2.0.1-2.sl5                     LB-Update                14 k
     glite-lbjp-common-server-bones             x86_64             2.0.1-2.sl5                     LB-Update                24 k
     glite-lbjp-common-trio                     x86_64             2.0.2-2.sl5                     LB-Update                71 k
     glite-security-gsoap-plugin                x86_64             2.1.2-2.sl5                     LB-Update               3.5 M
     glite-security-gss                         x86_64             2.1.4-1.sl5                     LB-Update                74 k
     glite-security-voms-api-cpp                x86_64             1.9.18-1.sl5                    LB-Update               4.5 M
     glite-yaim-core                            noarch             4.0.13-2                        LB-Update               124 k
    Installing for dependencies:
     alsa-lib                                   x86_64             1.0.17-1.el5                    sl-base                 414 k
     antlr                                      x86_64             2.7.6-4jpp.2                    sl-base                 1.1 M
     bouncycastle-glite                         noarch             1.42-3.jdk5                     LB-External             1.3 M
     gjdoc                                      x86_64             0.7.7-12.el5                    sl-base                 885 k
     glite-jobid-api-java                       x86_64             1.0.3-2.sl5                     LB-Release              5.7 k
     glite-lb-harvester                         x86_64             1.0.9-2.sl5                     LB-Release               73 k
     glite-security-trustmanager                noarch             2.5.5-1                         LB-Update               5.8 M
     glite-security-util-java                   noarch             2.8.6-1.GL32                    LB-Update               328 k
     jakarta-commons-codec                      x86_64             1.3-7jpp.2                      sl-base                 109 k
     jakarta-commons-lang                       x86_64             2.1-5jpp.1                      sl-base                 508 k
     java-1.4.2-gcj-compat                      x86_64             1.4.2.0-40jpp.115               sl-base                  29 k
     jdk                                        x86_64             2000:1.6.0_22-fcs               sl-security              67 M
     jpackage-utils                             noarch             1.7.3-1jpp.2.el5                sl-base                  61 k
     libXtst                                    x86_64             1.0.1-3.1                       sl-base                  16 k
     libart_lgpl                                x86_64             2.3.17-4                        sl-base                  75 k
     libgcj                                     x86_64             4.1.2-46.el5_4.2                sl-security              18 M
     log4c                                      x86_64             1.2.1-2.sl5                     LB-External             173 k
     log4j                                      x86_64             1.2.13-3jpp.2                   sl-base                 729 k
     org.glite.lb.client-java                   x86_64             1.0.5-2.sl5                     LB-Release              551 k
     org.glite.lbjp-common.log                  x86_64             1.0.3-2.sl5                     LB-Release               15 k

2010-06-10 (Ale)

  • Installed a new LB server 2 using these repositories:
    # ETICS Automatic Repomd (Yum) Repository
    #
    # Global Registered repository
    # Platform: sl5_x86_64_gcc412
    # Project Name: org.glite
    
    [LB-Release]
    name=LB Release
    baseurl=http://glitesoft.cern.ch/EGEE/gLite/R3.2/glite-LB/sl5/x86_64/RPMS.release/
    enabled=1
    
    [LB-External]
    name=LB External
    baseurl=http://glitesoft.cern.ch/EGEE/gLite/R3.2/glite-LB/sl5/x86_64/RPMS.externals/   
    enabled=1
    
    [LB-Update]
    name=LB Update
    baseurl=http://glitesoft.cern.ch/EGEE/gLite/R3.2/glite-LB/sl5/x86_64/RPMS.updates/
    enabled=1
    
    [Patch4006]
    name=Patch 4006
    baseurl=http://etics-repository.cern.ch/repository/pm/registered/repomd/global/org.glite/sl5_x86_64_gcc412
    protect=1
    enabled=1
    gpgcheck=0
  • Downgrade this rpm glite-lbjp-common-db to version 1.0.1-4.sl5
  • Run /opt/glite/yaim/bin/yaim -c -s ./site-info.def -n glite-LB
  • Add devel18.cnaf.infn.it to LB-super-users file

2010-01-21 (Elisabetta)

  • Starting form a fresh re-installation of the machine with SL5

2009-08-25 (Ale)

  • Cleaning databases and Sandbox directories
  • Restart services

2009-04-03 (Ale)

  • Update:
    • lcg-CA 1.28.1
    • lcg-vomscerts 5.4.0-1

2008-06-23 (Ale)

  • Update:
    glite-security-voms-api-c i386 1.8.3-3.slc4 WMS-pps
    glite-security-voms-api-cpp i386 1.8.3-3.slc4 WMS-pps
    glite-yaim-core noarch 4.0.4-2 WMS-pps
    glite-yaim-wms noarch 4.0.1-9 WMS-pps
    lcg-CA noarch 1.22-1 CA
    lcg-vomscerts noarch 5.0.0-1 WMS-pps

2008-04-22 (Ale)

  • Update:
    glite-jdl-api-cpp i386 3.1.14-1.slc4 WMS-pps
    glite-lb-client i386 3.1.5-1.slc4 WMS-pps
    glite-lb-logger i386 1.4.9-2.slc4 WMS-pps
    glite-lb-proxy i386 1.5.2-2.slc4 WMS-pps
    glite-security-voms-api-cpp i386 1.7.24-1.slc4 WMS-pps
    glite-wms-common i386 3.1.19-3.slc4 WMS-pps
    glite-wms-thirdparty-bypass i386 3.1.3-3.slc4 WMS-pps
    glite-yaim-core noarch 4.0.4-1 WMS-pps
    lcg-vomscerts noarch 4.9.0-1 WMS-pps
    vdt_globus_essentials i386 VDT1.6.1x86_rhas_4-6 WMS-pps

2008-04-02 (Ale)

  • Update:
    bdii noarch 3.9.1-5 WMS1726
    glite-initscript-globus-gridftp noarch 1.0.2-1 WMS1726
    glite-jdl-api-cpp i386 3.1.12-1.slc4 WMS1726
    glite-lb-client i386 3.1.2-2.slc4 WMS1726
    glite-lb-common i386 6.1.1-2.slc4 WMS1726
    glite-wms-helper i386 3.1.17-7.slc4 WMS1726
    glite-yaim-core noarch 4.0.3-13 WMS1726
    glite-yaim-wms noarch 4.0.1-6 WMS1726
    vdt_globus_data_server i386 VDT1.6.1x86_rhas_4-5 WMS1726
    vdt_globus_essentials i386 VDT1.6.1x86_rhas_4-5 WMS1726

2008-03-19 (Ale)

  • Update lcg-CA: 1.20-1

2007-12-18 (Ale)

  • Update these rpms:
    • glite-lb-client-3.1.1-1.slc4.i386.rpm
    • glite-lb-client-interface-3.1.1-1.slc4.i386.rpm
    • glite-lb-common-6.1.1-1.slc4.i386.rpm
    • glite-lb-logger-1.4.6-1.slc4.i386.rpm
    • glite-lb-proxy-1.5.1-2.slc4.i386.rpm
    • glite-lb-ws-interface-2.4.0-3.slc4.i386.rpm

error: Failed dependencies: MySQL-server >= 4.1.20 is needed by glite-lb-proxy-1.5.1-3.slc4.i386

(add --nodeps)

2007-12-07 (Ale)

Starting installation of the WMS

  • Define new yum repository:
[main]
[glite-wms]
name=gLite 3.1 wms
baseurl=http://grid-deployment.web.cern.ch/grid-deployment/glite/cert/3.1/glite-WMSLB/sl4/i386/
enabled=1
[CA]
name=CAs
baseurl=http://linuxsoft.cern.ch/LCG-CAs/current
enabled=1

  • yum install cert-glite-WMSLB

  • yum install lcg-CA Probably this need to be added as dependency

  • Copy hostcert.pem hostkey.pem under /etc/grid-security/

  • Configure site-info.def

  • /opt/glite/yaim/bin/yaim -c -s site-info.def -n WMS

Issues:

/opt/glite/yaim/bin/../libexec/configure_node: line 410: /opt/glite/etc/init.d/glite-wms-ice: No such file or directory
Your identity: /C=IT/O=INFN/OU=Host/L=CNAF/CN=devel07.cnaf.infn.it
Creating proxy .................................... Done
Your proxy is valid until: Fri Dec  7 16:26:16 2007
   ABORT: Service glite-wms-ice failed to start!
   ERROR: Error during the execution of function: config_glite_wms
   ERROR: Error during the configuration.Exiting.                              [FAILED]

  • Remove glite-wms-ice from line 400 of file /opt/glite/yaim/functions/config_glite_wms

  • Remove /etc/cron.d/glite-wms-check-daemons.cron and stop lbserver

Configure jobdir
  • Set jobdir ad input method for workload-manager instead of filelist
    • Set these variables in the glite_wms.conf file (WorkloadManager section)
      • DispatcherType = "jobdir";
      • Input = "${GLITE_LOCATION_VAR}/workload_manager/jobdir";
    • Create these directories and then give the ownership to glite.glite
      • /var/glite/workload_manager/jobdir/new/
      • /var/glite/workload_manager/jobdir/old/
      • /var/glite/workload_manager/jobdir/tmp/
    • Restart the services

  • Found this problem (need to be investigate)
Status info for the Job : https://devel08.cnaf.infn.it:9000/4IRHjlJMkxlpJRKFjEaQ8w
Current Status:     Waiting
Status Reason:      LBProxy is enabled
Unable to query LB and LBProxy
edg_wll_QueryEvents[Proxy]
Exit code: 4
LB[Proxy] Error: Interrupted system call
(edg_wll_gss_connect())
Submitted:          Fri Dec  7 15:49:15 2007 CET


Enable recovery (experimental)
  • Install glite-wms-manager-3.1.31-1.slc4_recovery.i386.rpm
  • Enable recovery by adding
    EnableRecovery = true;
    in the configuration file
  • Restart the WM

06/25/2008

  • Increased II_timeout to 180, to fix the problem of ISM emptying

-- AlessioGianelle - 07 Dec 2007

Edit | Attach | PDF | History: r16 < r15 < r14 < r13 < r12 | Backlinks | Raw View | More topic actions
Topic revision: r16 - 2011-05-06 - AlessioGianelle
 
This site is powered by the TWiki collaboration platformCopyright © 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback