Tags:
, view all tags

Devel15 Work Log

2008-04-15 (Ale)

  • Updating:
glite-lb-client i386 3.1.5-1.slc4 WMS-pps
glite-yaim-core noarch 4.0.4-1 WMS-pps
glite-yaim-lb noarch 4.0.1-3 WMS-pps
lcg-vomscerts noarch 4.9.0-1 WMS-pps
vdt_globus_essentials i386 VDT1.6.1x86_rhas_4-6 WMS-pps

2008-02-26 (Ale)

  • Update these rpms:
    glite-lb-client i386 3.1.2-2.slc4 devel17
    glite-lb-common i386 6.1.1-2.slc4 devel17
    glite-lb-server i386 1.8.3-1.slc4 devel17
    lcg-vomscerts noarch 4.8.0-1 devel17
  • Downgrade this rpm:
    • glite-security-voms-api-cpp-1.7.24-1.slc4

2008-02-06 (Ale)

  • Update these rpms:
    glite-security-voms-api-c i386 1.8.2-1.slc4 devel17
    glite-security-voms-api-cpp i386 1.8.2-1.slc4 devel17
    lcg-CA noarch 1.19-1 CA

2008-01-15 (Ale)

  • Update these rpms using repository on devel17:
    • glite-lb-client (3.1.2-1.slc4)
    • glite-lb-server (1.8.2-1.slc4)
    • glite-security-voms-api-c (1.8.1-1.slc4)
    • glite-security-voms-api-cpp (1.8.1-1.slc4)

2007-10-23 (Ale)

  • LB server need to be restarted periodically due to this problem:
> gianelle@lxde02:$ glite-job-status https://devel15.cnaf.infn.it:9000/rWCq71fcyV_rArKZC-m1MQ
> **** Error: API_NATIVE_ERROR ****
> Error while calling the "Status:getStatus" native api
> Unable to retrieve the status for: https://devel15.cnaf.infn.it:9000/rWCq71fcyV_rArKZC-m1MQ
> edg_wll_JobStatus: Connection refused: edg_wll_gss_connect(): server closed the connection, probably due to overload

*** Answer of Salvet:
This appears to be result of different problem, bug #30647
aka "SIGPIPE on LB server". Do you use other WMS machine or a lot of CEs
which have glite-security-gsoap-plugin_R_1_5_1_1 installed ?

2007-10-19 (Ale)

  • Update these rpms:
    • glite-security-gsoap-plugin-1.5.2-1.slc4.i386.rpm
    • lcg-CA-1.17-1 (and all the CA_*)

2007-10-08 (Ale)

  • Restart LBServer in debug mode

2007-10-04 (Ale)

Start to install a LB 3.1

Install yaim

  • rpm -ihv glite-yaim-core-4.0.0-14.noarch.rpm
  • rpm -ihv glite-yaim-lb-4.0.0-4.noarch.rpm

Install by hand (waiting for the LB metapackage)
  • yum install mysql-server
    • mysql
    • perl-DBD-MySQL
    • perl-DBI
    • perl-Net-Daemon
    • perl-PlRPC

  • apt-get install c-ares

  • apt-get install lcg-CA
  • apt-get install fetch-crl
  • rpm -ihv lcg-vomscerts-4.6.0-1.noarch.rpm

  • apt-get install vdt_globus_essentials
  • rpm -ihv gpt-VDT1.6.0x86_rhas_4-1.i386.rpm

  • rpm -ihv glite-lb-ws-interface-2.4.0-1.slc4.i386.rpm
  • apt-get install glite-lb-common glite-lb-server-bones glite-security-gsoap-plugin
    • glite-wms-utils-exception
    • glite-wms-utils-jobid

  • apt-get install gridsite-shared glite-security-voms-api-c

  • apt-get install glite-lb-client

  • rpm -ihv glite-lb-server-1.7.1-1.slc4.i386.rpm

Post Install
  • Copy hostcert.pem hostkey.pem under /etc/grid-security/

Configure yaim
  • Create site-info.def

Bugs Fixes

  • Define /opt/glite/yaim/node-info.d/glite-lb:
LB_FUNCTIONS="
config_add_pool_env
config_crl
config_host_certs
config_edgusers
config_globus_clients
config_glite_lb
config_glite_initd"

  • Fix line 46 of /opt/glite/yaim/functions/config_glite_lb
    • /etc/init.d/mysqld start

Configure

  • /opt/glite/yaim/bin/yaim -c -s site-info.def -n LB

Post Configure

  • Insert the WMS (devel14) DN in the /opt/glite/etc/LB-super-users file and restart the service

NOTE:

  • Warning: glite-lb-notif-interlogd not installed, LB notifications will not work

-- AlessioGianelle - 04 Oct 2007

Edit | Attach | PDF | History: r22 | r14 < r13 < r12 < r11 | Backlinks | Raw View | More topic actions...
Topic revision: r12 - 2008-04-15 - AlessioGianelle
 
  • Edit
  • Attach
This site is powered by the TWiki collaboration platformCopyright © 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback