Tags:
, view all tags

Devel14 Work Log

2009-05-11 (Ale)

  • Updating:
    lcg-CA 1.29-1

2009-04-06(Ale)

  • Updating:
    bdii 4.0.1-4
    lcg-vomscerts 5.4.0-1

2009-01-29 (Ale)

  • Updating:
    glite-info-provider-service noarch 1.0.1-3 glite-WMS
    glite-security-voms-api-c i386 1.8.8-2.slc4 glite-WMS
    glite-security-voms-clients i386 1.8.8-2.slc4 glite-WMS
    glue-schema noarch 1.3.0-5 glite-WMS
    lcg-vomscerts noarch 5.2.0-1 glite-WMS

2009-01-12 (Ale)

  • Update ICE components

2008-12-02 (Ale)

  • Updating:
    glite-jdl-api-cpp i386 3.1.16-2.slc4 WMS-PreCert
    glite-security-voms-api-cpp i386 1.8.8-3.slc4 WMS-PreCert
    glite-wms-manager i386 3.1.44-1.slc4 WMS-PreCert
    glite-wms-utils-jobid i386 3.1.5-1.slc4 WMS-PreCert
    glite-wms-wmproxy i386 3.1.41-1.slc4 WMS-PreCert

2008-11-28 (Ale)

  • Updating
    glite-jdl-api-cpp i386 3.1.16-1.slc4 WMS-PreCert
    glite-wms-helper i386 3.1.29-1.slc4 WMS-PreCert
    glite-wms-manager i386 3.1.43-1.slc4 WMS-PreCert
    glite-wms-wmproxy i386 3.1.40-1.slc4 WMS-PreCert
    glite-yaim-wms noarch 4.0.4-0 WMS-PreCert

2008-09-08 (Ale)

  • Updating
    glite-wms-utils-jobid i386 3.1.4-1.slc4 WMS-PreCert
    glite-wms-wmproxy i386 3.1.38-1.slc4 WMS-PreCert

2008-09-02 (Ale)

  • Reinstalling a WMS 3.1.100 from scratch
    • Define new yum repository
    • yum install cert-glite-WMS glite-wms-ice glite-info-provider-service
    • Copy hostcert.pem hostkey.pem under /etc/grid-security/
    • Configure site-info.def
    • /opt/glite/yaim/bin/yaim -c -s site-info.def -n WMS
    • Install google-perftools-0.98-1.i386.rpm google-perftools-devel-0.98-1.i386.rpm to decrease the wm's use of memory (from 1.3Gb to 300Mb!)
  • Removed dismissed packages:
    • rpm -e --nodeps glite-wms-checkpointing-3.1.2-3.slc4 glite-wms-partitioner-3.1.2-2.slc4.i386
    • rpm -e --nodeps glite-wms-interactive-3.1.5-1.slc4
    • rpm -e --nodeps glite-rgma-api-cpp glite-rgma-base glite-rgma-api-c glite-service-discovery-rgma-c



2008-04-21 (Ale)

glite-wms-manager i386 3.1.35-1.slc4 devel17
glite-wms-wmproxy i386 3.1.33-3.slc4 devel17
glite-wms-common i386 3.1.20-1.slc4 volatile repository

2008-04-15 (Ale)

  • Updating:
bdii noarch 3.9.1-5 glite-wms
cert-glite-WMS i386 3.1.2-0 glite-wms
glite-initscript-globus-gridftp noarch 1.0.2-1 glite-wms
glite-lb-client i386 3.1.5-1.slc4 glite-wms
glite-wms-manager i386 3.1.34-1.slc4 devel17
glite-yaim-core noarch 4.0.4-1 glite-wms
glite-yaim-wms noarch 4.0.1-7 glite-wms
lcg-vomscerts noarch 4.9.0-1 devel17
vdt_globus_data_server i386 VDT1.6.1x86_rhas_4-5 glite-wms
vdt_globus_essentials i386 VDT1.6.1x86_rhas_4-6 glite-wms
  • Installing for dependencies:
glue-schema noarch 1.3.0-3 glite-wms

2008-03-19 (Ale)

  • Update Lcg-CA 1.20-1

2008-03-11 (Ale)

  • rpm -Uhv glite-wms-jobsubmission-3.1.10-4.slc4.i386.rpm

2008-03-06 (Ale)

  • rpm -Uhv glite-lb-client-3.1.3-1.slc4.i386.rpm glite-lb-client-interface-3.1.1-2.slc4.i386.rpm

2008-03-04 (Ale)

  • rpm -ihv --force glite-security-voms-api-c-1.8.3-2.slc4.i386.rpm glite-security-voms-api-cpp-1.8.3-2.slc4.i386.rpm
  • rpm -Uhv --force glite-wms-manager-3.1.32-3.slc4.i386.rpm glite-wms-wmproxy-3.1.31-3.slc4.i386.rpm

2008-02-27 (Ale)

  • Updating:
    glite-jdl-api-cpp i386 3.1.14-1.slc4 devel17
    glite-lb-client i386 3.1.2-2.slc4 devel17
    glite-lb-common i386 6.1.1-2.slc4 devel17
    glite-lb-logger i386 1.4.9-2.slc4 devel17
    glite-lb-proxy i386 1.5.2-2.slc4 devel17
    glite-wms-broker i386 3.1.5-5.slc4 devel17
    glite-wms-brokerinfo i386 3.1.10-3.slc4 devel17
    glite-wms-classad_plugin i386 3.1.9-2.slc4 devel17
    glite-wms-common i386 3.1.19-3.slc4 devel17
    glite-wms-configuration i386 3.1.11-2.slc4 devel17
    glite-wms-helper i386 3.1.20-2.slc4 devel17
    glite-wms-ism i386 3.1.16-3.slc4 devel17
    glite-wms-jobsubmission i386 3.1.10-3.slc4 devel17
    glite-wms-manager i386 3.1.32-3.slc4 devel17
    glite-wms-matchmaking i386 3.1.8-2.slc4 devel17
    glite-wms-purger i386 3.1.10-3.slc4 devel17
    glite-wms-thirdparty-bypass i386 3.1.3-3.slc4 devel17
    glite-wms-wmproxy i386 3.1.31-3.slc4 devel17
    lcg-vomscerts noarch 4.8.0-1 devel17

  • Downgrade:
    glite-security-voms-api-c i386 1.7.24-1.slc4 devel17
    glite-security-voms-api-cpp i386 1.7.24-1.slc4 devel17

2008-02-02 (Ale)

  • Updating:
glite-security-lcas-plugins-voms i386 1.3.4-4.slc4 devel17
glite-security-lcmaps i386 1.4.3-2.slc4 devel17
glite-security-lcmaps-plugins-voms i386 1.3.7-4.slc4 devel17
glite-security-voms-api-c i386 1.8.2-1.slc4 devel17
glite-security-voms-api-cpp i386 1.8.2-1.slc4 devel17
lcg-CA noarch 1.19-1 CA

2008-01-23 (Ale)

  • Updating:
    • glite-security-voms i386 1.8.2-1.slc4 devel17

2008-01-21 (Ale)

  • Update this rpm (using repository on devel17) with an important fix for handling undefined event expiration that may cause loosing LB events:
    • glite-lb-logger (1.4.9-1.slc4)

2008-01-15 (Ale)

  • Update these rpms (using repository on devel17):
    • glite-ce-cream-client-api-c (1.7.16-0.slc4)
    • glite-ce-monitor-client-api-c (1.7.15-0.slc4)
    • glite-jdl-api-cpp (3.1.13-1.slc4)
    • glite-lb-client (3.1.2-1.slc4)
    • glite-lb-client-interface (3.1.1-1.slc4)
    • glite-lb-common (6.1.1-1.slc4)
    • glite-lb-logger (1.4.8-1.slc4)
    • glite-lb-proxy (1.5.2-1.slc4)
    • glite-security-lcmaps (1.4.3-1.slc4)
    • glite-security-proxyrenewal (1.3.5-1.slc4)
    • glite-security-voms (1.8.1-1.slc4)
    • glite-security-voms-api-cpp (1.8.1-1.slc4)
    • glite-wms-checkpointing (3.1.2-4.slc4)
    • glite-wms-common (3.1.18-1.slc4)
    • glite-wms-helper (3.1.20-1.slc4)
    • glite-wms-interactive (3.1.6-1.slc4)
    • glite-wms-purger (3.1.10-1.slc4)
    • glite-wms-thirdparty-bypass (3.1.3-1.slc4)
    • glite-wms-wmproxy ( 3.1.30-5.slc4)
    • glite-security-voms-api-c (1.8.1-1.slc4)
    • glite-security-lcas-plugins-voms (1.3.4-3.slc4)
    • glite-security-lcmaps-plugins-voms (1.3.7-3.slc4)
    • glite-wms-ice (3.1.25-2.slc4)

2007-11-09 (Ale)

  • Install a new version of wms-manager to test "recovery"

2007-11-08 (Ale)

  • Update voms:
    • glite-security-voms-api-cpp-1.7.24-1.slc4
    • glite-security-voms-api-c-1.7.24-1.slc4

2007-11-06 (Ale)

  • Starting testing of ice

2007-10-23 (Ale)

  • Installed google-perftools-0.93-1.i386.rpm google-perftools-devel-0.93-1.i386.rpm to decrease the wm's use of memory (from 1.3Gb to 300Mb!)
    • Restart the wm setting LD_PRELOAD="/usr/lib/libtcmalloc_minimal.so"

2007-10-19 (Ale)

  • Installed glite-wms-wmproxy-3.1.30-3.slc4-LIBTAR-STATIC.i386.rpm to test new fixes about the use of the static libtar lib

2007-10-18 (Ale)

  • Update these rpms:
    • glite-security-gsoap-plugin-1.5.2-1.slc4.i386.rpm (to fix the problem "LB[Proxy] Error: Connection timed out" seen on 08 October)
    • glite-wms-manager-3.1.30-1.slc4.i386.rpm (compiled by giaco to fix a problem with dependencies: ldap)
    • lcg-CA-1.17-1 (and all the CA_*)

2007-10-15 (Ale)

Installing ICE
  • rpm -ihv db-4.2.52-1.slc4.i386.rpm
  • rpm -ihv log4cpp-0.3.4b-1.slc4.i386.rpm
  • rpm -ihv glite-ce-cream-client-api-c-1.7.15-1.slc4.i386.rpm
  • rpm -ihv glite-ce-monitor-client-api-c-1.7.14-1.slc4.i386.rpm
  • update boost to version: boost-1.32.0-6.rhel4
  • rpm -ihv glite-wms-ice-3.1.24-1.slc4.i386.rpm
  • add to file /opt/glite/etc/profile.d/grid-env.sh this line:
    • gridpath_append "LD_LIBRARY_PATH" "/opt/log4cpp/lib/"
  • source /opt/glite/etc/profile.d/grid-env.sh and then start ice:
    • /opt/glite/etc/init.d/glite-wms-ice start

2007-10-12 (Ale)

  • Updated these rpms from glite-wms_R_3_1_82 (build locally by giaco)
    • glite-wms-helper-3.1.17-5.slc4.i386.rpm
    • glite-wms-ism-3.1.15-2.slc4.i386.rpm
    • glite-wms-purger-3.1.8-3.slc4.i386.rpm
    • glite-wms-manager-3.1.30-1.slc4.i386.rpm (compiled by salvo to test wm recovery)
    • glite-wms-wmproxy-3.1.29-1.slc4.i386.rpm (compiled by maraska to fix some bugs)

  • To enable recovery set this parameter EnableRecovery = true; on glite_wms.conf (WorkloadManager section)

2007-10-10 (Ale)

  • Removed the line export http_proxy=myproxy.my.domain from /opt/glite/libexec/fetch-crl.sh
In the site-info.def file this variable SITE_HTTP_PROXY="myproxy.my.domain" is set, if not used please comment it. (This MUST be the default, but....)

2007-10-08 (Ale)

  • 30% of jobs fail due to this problem:
Status Reason:      LBProxy is enabled
Unable to query LB and LBProxy
edg_wll_QueryEvents[Proxy]
Exit code: 110
LB[Proxy] Error: Connection timed out
(edg_wll_gss_connect())

The jobs stay in the waiting state forever and they can be "resubmitted" through the command: glite-wms-job-submit --start _jobid_

2007-10-05 (Ale)

  • Found a bug on wmproxy: logging the Enqueued/OK events the "queue" parameter is not set
    • The symptom is: Status Reason: cannot retrieve jdl
    • The real problem: glite-lb-proxy[8426]: Message incomplete (Message incomplete, missing or empty field DG.ENQUEUED.QUEUE.)

2007-10-04 (Ale)

Configure jobdir
  • Set jobdir ad input method for workload-manager instead of filelist
    • Set these variables in the glite_wms.conf file (WorkloadManager section)
      • DispatcherType = "jobdir";
      • Input = "${GLITE_LOCATION_VAR}/workload_manager/jobdir";
    • Create these directories and then give the ownership to glite.glite
      • /var/glite/workload_manager/jobdir/new/
      • /var/glite/workload_manager/jobdir/old/
      • /var/glite/workload_manager/jobdir/tmp/
    • Restart the services

2007-10-03 (Ale)

Start to install a WMS 3.1

Install yaim

  • rpm -ihv glite-yaim-core-4.0.0-14.noarch.rpm
  • rpm -ihv glite-yaim-wms-4.0.0-1.noarch.rpm

Configure yaim
  • Create site-info.def
  • Create users.conf
  • Create groups.conf

Resolve dependencies
  • bdii needs:
    • yum install openldap-clients openldap-servers
    • yum install perl-libwww-perl
      • perl-HTML-Parser
      • perl-HTML-Tagset
      • perl-URI

  • edg-mkgridmap needs:
    • yum install perl-Crypt-SSLeay perl-DateManip perl-IO-Socket-SSL perl-LDAP perl-Net-SSLeay perl-Term-ReadKey perl-XML-DOM perl-XML-RegExp
      • perl-Convert-ASN1
      • perl-XML-NamespaceSupport
      • perl-XML-SAX

  • mysql needs:
    • yum install perl-DBI perl-PlRPC perl-Net-Daemon

  • glite-wms-manager needs:
    • rpm -ihv vdt_globus_info_essentials-VDT1.6.0x86_rhas_4-1.i386.rpm

  • condor needs:
    • yum install compat-libstdc++-33

  • gridsite-apache (not present in the repository, why?) needs:
    • yum install curl libidn

Install
  • /opt/glite/yaim/bin/yaim -i -s site-info.def -m glite-WMS

Post Install
  • Copy hostcert.pem hostkey.pem under /etc/grid-security/

Resolve dependencies (these are not required by rpm but are necessary)

  • Needs to configure edg-mkgridmap.pl (Patch #1403)
    • yum install perl-XML-Parser

  • Needs to configure globus
    • rpm -ihv gpt-VDT1.6.0x86_rhas_4-1.i386.rpm

  • Needs by lbproxy
    • yum install mysql-server
      • perl-DBD-MySQL

  • Needs by wmproxy
    • yum install httpd
      • apr
      • apr-util
      • httpd-suexec
    • yum install mod_ssl
      • distcache
    • rpm -ihv glite-security-lcmaps-plugins-voms-1.3.7-3.slc4.i386.rpm

  • needs by condor (gahp)
    • rpm -ihv condor-lcg-1.1.0-1.i386.rpm

  • Needs by configuration script
    • rpm -ihv glite-lb-logger (Why do you not install it?)

Bugs Fixes

  • Remove from file /opt/glite/yaim/node-info.d/glite-wms the line:
    • config_gip_service (why do you configure a GIP on a WMS?)

  • Fix line 41 of /opt/glite/yaim/functions/config_glite_lbproxy
    • /etc/init.d/mysqld start

  • To start correctly workload-manager add to file /opt/glite/yaim/functions/config_glite_wms (it needs liblog4cxx.so.9.0.0)
    • yaimgridpath_append LD_LIBRARY_PATH /usr/local/lib

  • To run correctly wmproxy add to file /opt/glite/yaim/functions/config_glite_wms (for libfcgi* and libtar)
    • yaimgridpath_append LD_LIBRARY_PATH /opt/fcgi/lib
    • yaimgridpath_append LD_LIBRARY_PATH /opt/libtar/lib

Configure

  • /opt/glite/yaim/bin/yaim -c -s site-info.def -n WMS

Post Configure
  • Install voms certificate:
    • rpm -ihv lcg-vomscerts-4.6.0-1.noarch.rpm

NOTE
  • /opt/glite/bin/glite-lb-interlogd doesn't exit with a "/opt/glite/etc/init.d/glite-lb-locallogger stop" you need "Kill -9"
  • you need to configure LBServer = {"devel15.cnaf.infn.it:9000"}; on glite_wms.conf
  • /opt/glite/bin/glite_wms_wmproxy_dirmanager is bugged due to libtar link (Bug under investigation by Maraska) use this one
  • chmod 4555 /opt/glite/bin/glite_wms_wmproxy_dirmanager (Bug under investigation by Maraska)
  • use the correct glite-wms-purger.cron script
  • set the right value HostProxyFile = "${GLITE_LOCATION_VAR}/wms.proxy"; on glite_wms.conf
  • install rpm -ihv lcg-expiregridmapdir-2.0.0-1.noarch.rpm and fix lcg-expiregridmapdir cron job (with the correct path)
  • install glite-wms-wmproxy-logrotate.cron and set its conf file (/opt/glite/etc/wmproxy_logrotate.conf)
  • add MaxOutputSandboxSize = -1; to glite_wms.conf (see bug #27215)
  • create /opt/glite/etc/vomses files
  • add this line to file /opt/glite/etc/profile.d/grid-env.sh
    • gridenv_set "MYPROXY_TCP_PORT_RANGE" "20000,25000"

Installing the new gridftp server (vdt1.6)

  • Install these rpms:
    • vdt_globus_data_server-VDT1.6.0x86_rhas_4-3.i386.rpm
    • glite-security-lcas-lcmaps-gt4-interface-0.0.13-2.slc4.i386.rpm
    • glite-security-lcas-1.3.7-1.slc4.i386.rpm
    • glite-security-lcas-plugins-voms-1.3.4-3.slc4.i386.rpm
    • glite-security-lcas-interface-1.3.6-2.slc4.i386.rpm
    • glite-security-lcas-plugins-basic-1.3.2-2.slc4.i386.rpm

  • Remove edg-mkgridmap from the cron.d dir

  • Add the proper VO entry in the /etc/grid-security/grid-mapfile: e.g.

  • Add the proper VO entry in the /etc/grid-security/groupmapfile: e.g.

  • Configure the gridftp server:
    • Run /opt/glite/sbin/gt4-interface-install.sh install (it creates /etc/grid-security/gsi-authz.conf)
    • Touch the file /opt/glite/etc/lcas/ban_users.db
    • Create the file /opt/glite/etc/lcas/lcas.db: e.g.
    • Create the file /opt/glite/etc/lcmaps/lcmaps.db.gridftp: e.g.

  • To start the service:
    • export LCMAPS_DB_FILE=/opt/glite/etc/lcmaps/lcmaps.db.gridftp
    • /opt/globus/sbin/globus-gridftp-server -p 2811 -l /var/log/gridftp.log -S

Remove old gridftp service

  • rpm -e --nodeps glite-wms-thirdparty-globus_gridftp_server
  • rpm -e --nodeps edg-mkgridmap

  • rpm -e perl-Crypt-SSLeay perl-DateManip perl-IO-Socket-SSL perl-LDAP perl-Net-SSLeay perl-Term-ReadKey perl-XML-DOM perl-XML-RegExp
  • rpm -e perl-Convert-ASN1 perl-XML-NamespaceSupport perl-XML-SAX

-- AlessioGianelle - 03 Oct 2007

Edit | Attach | PDF | History: r57 | r35 < r34 < r33 < r32 | Backlinks | Raw View | More topic actions...
Topic revision: r33 - 2009-05-11 - AlessioGianelle
 
  • Edit
  • Attach
This site is powered by the TWiki collaboration platformCopyright © 2008-2022 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback