EMI2 RC3 Deployment tests for IGI components

Summary

Platform SL5 Install SL5 Update SL6 Install
Product yum yaim works? yum yaim works? yum yaim works?
STORM Yes / Done Yes / Done No Yes / Done Yes / Done No No - -
UI No - - No - - No - -
VOMS Yes / Done Yes / Done Yes / Done - - - - - -
ARGUS Yes / Done Yes / Done Yes / Done Yes / Done No + workaround - - - -

STORM

SL5 Platform

[ale@cream-12 tstorm-1.2.0-5]$ clientSRM ping -e httpg://emitestbed04.cnaf.infn.it:8444/
============================================================
Sending Ping request to: httpg://emitestbed04.cnaf.infn.it:8444/
Before execute:
execute Request with:Ping
started calling ns1__srmPing:
finished calling ns1__srmPing:
Afer execute:
Request Status Code -1
Poll Flag 0
============================================================
Request status:
gSoap code: -1

soap_print_fault:
Error -1 fault: SOAP-ENV:Client [no subcode]
"CGSI-gSOAP running on cream-12.pd.infn.it reports Error reading token data header: Connection closed"
Detail: [no detail]


soap_print_fault_location:
============================================================

This can be workarounded setting monitoring.enabled=true in /etc/storm/frontend-server/storm-frontend-server.conf

15:20:35.301 - ERROR [XML-RPC-0] - Unable to call successfully native map_user() method. Return value is INIT_FAILURE: <errorCode=1 ; errorMessage=lcmaps initialization failed>
15:20:35.302 - ERROR [XML-RPC-0] - Error in mapping 'C=IT, O=INFN, OU=Personal Certificate, L=Padova, CN=Alessio Gianelle' to a local user: LCMAPS error, cannot map user credentials to local user.
15:20:35.302 - ERROR [XML-RPC-0] - Unable to retrieve the local group for 'Grid User (VOMS) =  DN:'C=IT, O=INFN, OU=Personal Certificate, L=Padova, CN=Alessio Gianelle' FQANS:[/testers.eu-emi.eu/Role=NULL/Capability=NULL]'

The path of lcmaps modules in /etc/storm/backend-server/lcmaps.db need to be set to /usr/lib64/lcmaps

SL6 Platform

Error: Package: emi-storm-frontend-mp-1.1.0-1.sl6.x86_64 (EMI-2-RC3-base)
           Requires: storm-frontend-server

UI

SL5 Platform

Error: Missing Dependency: CGSI_gSOAP_2.7 is needed by package emi-ui-2.0.0-1.rc3.sl5.x86_64 (EMI-2-RC3-base)
Error: Missing Dependency: unicore-ucc is needed by package emi-ui-2.0.0-1.rc3.sl5.x86_64 (EMI-2-RC3-base)

Transaction Check Error:
  file /usr/bin/gfal_version from install of gfal-1.12.0-3.el5.x86_64 conflicts with file from package gfal-py26-1.11.19-3.sl5.x86_64
  file /usr/lib64/libgfal.so.1 from install of gfal-1.12.0-3.el5.x86_64 conflicts with file from package gfal-py26-1.11.19-3.sl5.x86_64
  file /usr/lib64/libgfal_pthr.so.1 from install of gfal-1.12.0-3.el5.x86_64 conflicts with file from package gfal-py26-1.11.19-3.sl5.x86_64
  file /usr/lib64/liblcg_util.so.1 from install of lcg-util-libs-1.12.0-1.el5.x86_64 conflicts with file from package lcg-util-py26-1.11.19-3.sl5.x86_64
  file /usr/bin/lcg-aa from install of lcg-util-1.12.0-1.el5.x86_64 conflicts with file from package lcg-util-py26-1.11.19-3.sl5.x86_64
  file /usr/bin/lcg-bringonline from install of lcg-util-1.12.0-1.el5.x86_64 conflicts with file from package lcg-util-py26-1.11.19-3.sl5.x86_64
  file /usr/bin/lcg-cp from install of lcg-util-1.12.0-1.el5.x86_64 conflicts with file from package lcg-util-py26-1.11.19-3.sl5.x86_64
  file /usr/bin/lcg-cr from install of lcg-util-1.12.0-1.el5.x86_64 conflicts with file from package lcg-util-py26-1.11.19-3.sl5.x86_64
  file /usr/bin/lcg-del from install of lcg-util-1.12.0-1.el5.x86_64 conflicts with file from package lcg-util-py26-1.11.19-3.sl5.x86_64
  file /usr/bin/lcg-get-checksum from install of lcg-util-1.12.0-1.el5.x86_64 conflicts with file from package lcg-util-py26-1.11.19-3.sl5.x86_64
  file /usr/bin/lcg-getturls from install of lcg-util-1.12.0-1.el5.x86_64 conflicts with file from package lcg-util-py26-1.11.19-3.sl5.x86_64
  file /usr/bin/lcg-gt from install of lcg-util-1.12.0-1.el5.x86_64 conflicts with file from package lcg-util-py26-1.11.19-3.sl5.x86_64
  file /usr/bin/lcg-la from install of lcg-util-1.12.0-1.el5.x86_64 conflicts with file from package lcg-util-py26-1.11.19-3.sl5.x86_64
  file /usr/bin/lcg-lg from install of lcg-util-1.12.0-1.el5.x86_64 conflicts with file from package lcg-util-py26-1.11.19-3.sl5.x86_64
  file /usr/bin/lcg-lr from install of lcg-util-1.12.0-1.el5.x86_64 conflicts with file from package lcg-util-py26-1.11.19-3.sl5.x86_64
  file /usr/bin/lcg-ls from install of lcg-util-1.12.0-1.el5.x86_64 conflicts with file from package lcg-util-py26-1.11.19-3.sl5.x86_64
  file /usr/bin/lcg-ra from install of lcg-util-1.12.0-1.el5.x86_64 conflicts with file from package lcg-util-py26-1.11.19-3.sl5.x86_64
  file /usr/bin/lcg-rep from install of lcg-util-1.12.0-1.el5.x86_64 conflicts with file from package lcg-util-py26-1.11.19-3.sl5.x86_64
  file /usr/bin/lcg-replica-manager from install of lcg-util-1.12.0-1.el5.x86_64 conflicts with file from package lcg-util-py26-1.11.19-3.sl5.x86_64
  file /usr/bin/lcg-rf from install of lcg-util-1.12.0-1.el5.x86_64 conflicts with file from package lcg-util-py26-1.11.19-3.sl5.x86_64
  file /usr/bin/lcg-sd from install of lcg-util-1.12.0-1.el5.x86_64 conflicts with file from package lcg-util-py26-1.11.19-3.sl5.x86_64
  file /usr/bin/lcg-stmd from install of lcg-util-1.12.0-1.el5.x86_64 conflicts with file from package lcg-util-py26-1.11.19-3.sl5.x86_64
  file /usr/bin/lcg-uf from install of lcg-util-1.12.0-1.el5.x86_64 conflicts with file from package lcg-util-py26-1.11.19-3.sl5.x86_64

Error Summary

To workaround the problem manually remove gfal-py26 and lcg-util-py26

SL6 Platform

Error: Package: emi-ui-2.0.0-1.rc3.sl6.x86_64 (EMI-2-RC3-base)
           Requires: emi.amga.amga-cli
Error: Package: emi-ui-2.0.0-1.rc3.sl6.x86_64 (EMI-2-RC3-base)
           Requires: glite-ce-monitor-client-api-c
Error: Package: emi-ui-2.0.0-1.rc3.sl6.x86_64 (EMI-2-RC3-base)
           Requires: glite-ce-cream-cli
Error: Package: emi-ui-2.0.0-1.rc3.sl6.x86_64 (EMI-2-RC3-base)
           Requires: unicore-ucc
Error: Package: emi-ui-2.0.0-1.rc3.sl6.x86_64 (EMI-2-RC3-base)
           Requires: CGSI_gSOAP_2.7
Error: Package: nordugrid-arc-client-tools-1.0.1-1.el6.noarch (EMI-2-RC3-base)
           Requires: nordugrid-arc-compat
Error: Package: emi-ui-2.0.0-1.rc3.sl6.x86_64 (EMI-2-RC3-base)
           Requires: storm-srm-client
Error: Package: emi-ui-2.0.0-1.rc3.sl6.x86_64 (EMI-2-RC3-base)
           Requires: transfer-cli
Topic attachments
I Attachment Action Size DateSorted descending Who Comment
Texttxt storm_install_sl5.txt manage 315.5 K 2012-03-14 - 15:07 AlessioGianelle torm install SL5 log file
Texttxt storm_install_sl6.txt manage 161.9 K 2012-03-14 - 09:20 AlessioGianelle Storm install SL6 log file
Texttxt ui.txt manage 95.9 K 2012-03-13 - 16:17 AlessioGianelle UI Update EMI2-RC3
Texttxt ui_install_sl5.txt manage 130.5 K 2012-03-13 - 16:16 AlessioGianelle SL5 install
Texttxt ui_install_sl6.txt manage 149.3 K 2012-03-13 - 16:16 AlessioGianelle Install sl6
Texttxt storm.txt manage 97.1 K 2012-03-12 - 15:50 AlessioGianelle Update EMI2-RC3
Edit | Attach | PDF | History: r6 < r5 < r4 < r3 < r2 | Backlinks | Raw View | More topic actions
Topic revision: r6 - 2012-03-14 - DaniloDongiovanni
 
This site is powered by the TWiki collaboration platformCopyright © 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback