back to Notes about Installation and Configuration of A Site BDII

# yum install emi-bdii-site
Loaded plugins: downloadonly, kernel-module, priorities, protect-packages, protectbase, security, verify, versionlock
263 packages excluded due to repository priority protections
0 packages excluded due to repository protections
Reading version lock configuration
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package emi-bdii-site.x86_64 0:1.0.0-1.sl5 set to be updated
--> Processing Dependency: emi-version for package: emi-bdii-site
--> Processing Dependency: glite-yaim-bdii for package: emi-bdii-site
--> Processing Dependency: glite-info-site for package: emi-bdii-site
--> Processing Dependency: glite-info-static for package: emi-bdii-site
--> Processing Dependency: bdii for package: emi-bdii-site
--> Processing Dependency: glue-schema for package: emi-bdii-site
--> Processing Dependency: glite-info-provider-service for package: emi-bdii-site
--> Processing Dependency: bdii-config-site for package: emi-bdii-site
--> Processing Dependency: glite-yaim-core for package: emi-bdii-site
--> Processing Dependency: glite-info-provider-ldap for package: emi-bdii-site
--> Running transaction check
---> Package bdii.noarch 0:5.2.10-1.el5 set to be updated
--> Processing Dependency: openldap-servers for package: bdii
--> Processing Dependency: expect for package: bdii
--> Processing Dependency: openldap-clients for package: bdii
---> Package bdii-config-site.noarch 0:1.0.5-2.el5 set to be updated
--> Processing Dependency: openldap2.4-servers for package: bdii-config-site
---> Package emi-version.x86_64 0:1.10.0-1.sl5 set to be updated
---> Package glite-info-provider-ldap.noarch 0:1.4.1-1.el5 set to be updated
--> Processing Dependency: perl(LWP::Simple) for package: glite-info-provider-ldap
---> Package glite-info-provider-service.noarch 0:1.8.1-2.el5 set to be updated
---> Package glite-info-site.noarch 0:0.4.0-1.el5 set to be updated
---> Package glite-info-static.noarch 0:0.2.0-1.el5 set to be updated
---> Package glite-yaim-bdii.noarch 0:4.3.9-1.el5 set to be updated
---> Package glite-yaim-core.noarch 0:5.0.2-1.sl5 set to be updated
---> Package glue-schema.noarch 0:2.0.8-1.el5 set to be updated
--> Running transaction check
---> Package expect.x86_64 0:5.43.0-5.1 set to be updated
---> Package openldap-clients.x86_64 0:2.3.43-12.el5_6.7 set to be updated
---> Package openldap-servers.x86_64 0:2.3.43-12.el5_6.7 set to be updated
--> Processing Dependency: libltdl.so.3()(64bit) for package: openldap-servers
---> Package openldap2.4-servers.x86_64 0:2.4.22-1.el5 set to be updated
--> Processing Dependency: lib64ldap2.4_2 = 2.4.22-1.el5 for package: openldap2.4-servers
--> Processing Dependency: cyrus-sasl = 2.1.22 for package: openldap2.4-servers
--> Processing Dependency: openldap2.4-extra-schemas >= 1.3-7 for package: openldap2.4-servers
--> Processing Dependency: openldap2.4-extra-schemas >= 1.3-7 for package: openldap2.4-servers
--> Processing Dependency: libldap_r-2.4.so.2()(64bit) for package: openldap2.4-servers
--> Processing Dependency: liblber-2.4.so.2()(64bit) for package: openldap2.4-servers
--> Processing Dependency: libodbc.so.1()(64bit) for package: openldap2.4-servers
---> Package perl-libwww-perl.noarch 0:5.805-1.1.1 set to be updated
--> Processing Dependency: perl-HTML-Parser >= 3.33 for package: perl-libwww-perl
--> Processing Dependency: perl(URI::URL) for package: perl-libwww-perl
--> Processing Dependency: perl(URI) for package: perl-libwww-perl
--> Processing Dependency: perl(HTML::Entities) for package: perl-libwww-perl
--> Processing Dependency: perl(Compress::Zlib) for package: perl-libwww-perl
--> Processing Dependency: perl(URI::Escape) for package: perl-libwww-perl
--> Processing Dependency: perl(URI::Heuristic) for package: perl-libwww-perl
--> Running transaction check
---> Package cyrus-sasl.x86_64 0:2.1.22-5.el5_4.3 set to be updated
---> Package lib64ldap2.4_2.x86_64 0:2.4.22-1.el5 set to be updated
--> Processing Dependency: openldap2.4 >= 2.1.25-4mdk for package: lib64ldap2.4_2
---> Package libtool-ltdl.x86_64 0:1.5.22-7.el5_4 set to be updated
---> Package openldap2.4-extra-schemas.noarch 0:1.3-10.el5 set to be updated
---> Package perl-Compress-Zlib.x86_64 0:1.42-1.fc6 set to be updated
---> Package perl-HTML-Parser.x86_64 0:3.55-1.fc6 set to be updated
--> Processing Dependency: perl-HTML-Tagset >= 3.03 for package: perl-HTML-Parser
--> Processing Dependency: perl(HTML::Tagset) for package: perl-HTML-Parser
---> Package perl-URI.noarch 0:1.35-3 set to be updated
---> Package unixODBC.x86_64 0:2.2.11-7.1 set to be updated
--> Running transaction check
---> Package openldap2.4.x86_64 0:2.4.22-1.el5 set to be updated
---> Package perl-HTML-Tagset.noarch 0:3.10-2.1.1 set to be updated
--> Finished Dependency Resolution
Beginning Kernel Module Plugin
Finished Kernel Module Plugin

Dependencies Resolved

===========================================================================================================================================================================================================================================
 Package                                                            Arch                                          Version                                                   Repository                                                Size
===========================================================================================================================================================================================================================================
Installing:
 emi-bdii-site                                                      x86_64                                        1.0.0-1.sl5                                               EMI-1-base                                               1.7 k
Installing for dependencies:
 bdii                                                               noarch                                        5.2.10-1.el5                                              EMI-1-updates                                             22 k
 bdii-config-site                                                   noarch                                        1.0.5-2.el5                                               EMI-1-updates                                            4.8 k
 cyrus-sasl                                                         x86_64                                        2.1.22-5.el5_4.3                                          sl-base                                                  1.2 M
 emi-version                                                        x86_64                                        1.10.0-1.sl5                                              EMI-1-updates                                            2.0 k
 expect                                                             x86_64                                        5.43.0-5.1                                                sl-base                                                  160 k
 glite-info-provider-ldap                                           noarch                                        1.4.1-1.el5                                               EMI-1-updates                                            7.1 k
 glite-info-provider-service                                        noarch                                        1.8.1-2.el5                                               EMI-1-updates                                             59 k
 glite-info-site                                                    noarch                                        0.4.0-1.el5                                               EMI-1-base                                               3.9 k
 glite-info-static                                                  noarch                                        0.2.0-1.el5                                               EMI-1-base                                               5.9 k
 glite-yaim-bdii                                                    noarch                                        4.3.9-1.el5                                               EMI-1-updates                                             10 k
 glite-yaim-core                                                    noarch                                        5.0.2-1.sl5                                               EMI-1-updates                                            116 k
 glue-schema                                                        noarch                                        2.0.8-1.el5                                               EMI-1-updates                                             33 k
 lib64ldap2.4_2                                                     x86_64                                        2.4.22-1.el5                                              EMI-1-third-party                                        300 k
 libtool-ltdl                                                       x86_64                                        1.5.22-7.el5_4                                            sl-base                                                   38 k
 openldap-clients                                                   x86_64                                        2.3.43-12.el5_6.7                                         sl-base                                                  223 k
 openldap-servers                                                   x86_64                                        2.3.43-12.el5_6.7                                         sl-base                                                  2.2 M
 openldap2.4                                                        x86_64                                        2.4.22-1.el5                                              EMI-1-third-party                                         40 k
 openldap2.4-extra-schemas                                          noarch                                        1.3-10.el5                                                EMI-1-third-party                                         46 k
 openldap2.4-servers                                                x86_64                                        2.4.22-1.el5                                              EMI-1-third-party                                        2.1 M
 perl-Compress-Zlib                                                 x86_64                                        1.42-1.fc6                                                sl-base                                                   52 k
 perl-HTML-Parser                                                   x86_64                                        3.55-1.fc6                                                sl-base                                                   91 k
 perl-HTML-Tagset                                                   noarch                                        3.10-2.1.1                                                sl-base                                                   14 k
 perl-URI                                                           noarch                                        1.35-3                                                    sl-base                                                  116 k
 perl-libwww-perl                                                   noarch                                        5.805-1.1.1                                               sl-base                                                  375 k
 unixODBC                                                           x86_64                                        2.2.11-7.1                                                sl-base                                                  834 k

Transaction Summary
===========================================================================================================================================================================================================================================
Install      26 Package(s)
Upgrade       0 Package(s)

Total download size: 8.0 M
Is this ok [y/N]:y
Downloading Packages:
(1/26): emi-bdii-site-1.0.0-1.sl5.x86_64.rpm                                                                                                                                                                        | 1.7 kB     00:00     
(2/26): emi-version-1.10.0-1.sl5.x86_64.rpm                                                                                                                                                                         | 2.0 kB     00:00     
(3/26): glite-info-site-0.4.0-1.el5.noarch.rpm                                                                                                                                                                      | 3.9 kB     00:00     
(4/26): bdii-config-site-1.0.5-2.el5.noarch.rpm                                                                                                                                                                     | 4.8 kB     00:00     
(5/26): glite-info-static-0.2.0-1.el5.noarch.rpm                                                                                                                                                                    | 5.9 kB     00:00     
(6/26): glite-info-provider-ldap-1.4.1-1.el5.noarch.rpm                                                                                                                                                             | 7.1 kB     00:00     
(7/26): glite-yaim-bdii-4.3.9-1.el5.noarch.rpm                                                                                                                                                                      |  10 kB     00:00     
(8/26): perl-HTML-Tagset-3.10-2.1.1.noarch.rpm                                                                                                                                                                      |  14 kB     00:00     
(9/26): bdii-5.2.10-1.el5.noarch.rpm                                                                                                                                                                                |  22 kB     00:00     
(10/26): glue-schema-2.0.8-1.el5.noarch.rpm                                                                                                                                                                         |  33 kB     00:00     
(11/26): libtool-ltdl-1.5.22-7.el5_4.x86_64.rpm                                                                                                                                                                     |  38 kB     00:00     
(12/26): openldap2.4-2.4.22-1.el5.x86_64.rpm                                                                                                                                                                        |  40 kB     00:00     
(13/26): openldap2.4-extra-schemas-1.3-10.el5.noarch.rpm                                                                                                                                                            |  46 kB     00:00     
(14/26): perl-Compress-Zlib-1.42-1.fc6.x86_64.rpm                                                                                                                                                                   |  52 kB     00:00     
(15/26): glite-info-provider-service-1.8.1-2.el5.noarch.rpm                                                                                                                                                         |  59 kB     00:00     
(16/26): perl-HTML-Parser-3.55-1.fc6.x86_64.rpm                                                                                                                                                                     |  91 kB     00:00     
(17/26): perl-URI-1.35-3.noarch.rpm                                                                                                                                                                                 | 116 kB     00:00     
(18/26): glite-yaim-core-5.0.2-1.sl5.noarch.rpm                                                                                                                                                                     | 116 kB     00:00     
(19/26): expect-5.43.0-5.1.x86_64.rpm                                                                                                                                                                               | 160 kB     00:00     
(20/26): openldap-clients-2.3.43-12.el5_6.7.x86_64.rpm                                                                                                                                                              | 223 kB     00:00     
(21/26): lib64ldap2.4_2-2.4.22-1.el5.x86_64.rpm                                                                                                                                                                     | 300 kB     00:00     
(22/26): perl-libwww-perl-5.805-1.1.1.noarch.rpm                                                                                                                                                                    | 375 kB     00:00     
(23/26): unixODBC-2.2.11-7.1.x86_64.rpm                                                                                                                                                                             | 834 kB     00:00     
(24/26): cyrus-sasl-2.1.22-5.el5_4.3.x86_64.rpm                                                                                                                                                                     | 1.2 MB     00:00     
(25/26): openldap2.4-servers-2.4.22-1.el5.x86_64.rpm                                                                                                                                                                | 2.1 MB     00:00     
(26/26): openldap-servers-2.3.43-12.el5_6.7.x86_64.rpm                                                                                                                                                              | 2.2 MB     00:00     
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                                                                      949 kB/s | 8.0 MB     00:08     
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID df9e12ef
EMI-1-updates/gpgkey                                                                                                                                                                                                | 1.7 kB     00:00     
Importing GPG key 0xDF9E12EF "Doina Cristina Aiftimiei (EMI Release Manager) <aiftim@pd.infn.it>" from /etc/pki/rpm-gpg/RPM-GPG-KEY-emi
Is this ok [y/N]: y
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : libtool-ltdl                                                                                                                                                                                                       1/26 
  Installing     : openldap-servers                                                                                                                                                                                                   2/26 
  Installing     : glite-info-site                                                                                                                                                                                                    3/26 
  Installing     : glite-info-static                                                                                                                                                                                                  4/26 
  Installing     : glite-info-provider-service                                                                                                                                                                                        5/26 
  Installing     : glue-schema                                                                                                                                                                                                        6/26 
  Installing     : expect                                                                                                                                                                                                             7/26 
  Installing     : openldap-clients                                                                                                                                                                                                   8/26 
  Installing     : unixODBC                                                                                                                                                                                                           9/26 
  Installing     : cyrus-sasl                                                                                                                                                                                                        10/26 
  Installing     : perl-Compress-Zlib                                                                                                                                                                                                11/26 
  Installing     : bdii                                                                                                                                                                                                              12/26 
  Installing     : emi-version                                                                                                                                                                                                       13/26 
  Installing     : glite-yaim-core                                                                                                                                                                                                   14/26 
  Installing     : perl-HTML-Tagset                                                                                                                                                                                                  15/26 
  Installing     : perl-HTML-Parser                                                                                                                                                                                                  16/26 
  Installing     : perl-URI                                                                                                                                                                                                          17/26 
  Installing     : perl-libwww-perl                                                                                                                                                                                                  18/26 
  Installing     : glite-info-provider-ldap                                                                                                                                                                                          19/26 
  Installing     : glite-yaim-bdii                                                                                                                                                                                                   20/26 
  Installing     : lib64ldap2.4_2                                                                                                                                                                                                    21/26 
  Installing     : openldap2.4                                                                                                                                                                                                       22/26 
  Installing     : openldap2.4-extra-schemas                                                                                                                                                                                         23/26 
useradd: user ldap exists
Adding user ldap to group ldap
  Installing     : openldap2.4-servers                                                                                                                                                                                               24/26 
Generating self-signed certificate...
To generate a self-signed certificate, you can use the utility
/usr/share/openldap2.4/gencert.sh...
  Installing     : bdii-config-site                                                                                                                                                                                                  25/26 
  Installing     : emi-bdii-site                                                                                                                                                                                                     26/26 

Installed:
  emi-bdii-site.x86_64 0:1.0.0-1.sl5                                                                                                                                                                                                       

Dependency Installed:
  bdii.noarch 0:5.2.10-1.el5                     bdii-config-site.noarch 0:1.0.5-2.el5             cyrus-sasl.x86_64 0:2.1.22-5.el5_4.3           emi-version.x86_64 0:1.10.0-1.sl5          expect.x86_64 0:5.43.0-5.1                  
  glite-info-provider-ldap.noarch 0:1.4.1-1.el5  glite-info-provider-service.noarch 0:1.8.1-2.el5  glite-info-site.noarch 0:0.4.0-1.el5           glite-info-static.noarch 0:0.2.0-1.el5     glite-yaim-bdii.noarch 0:4.3.9-1.el5        
  glite-yaim-core.noarch 0:5.0.2-1.sl5           glue-schema.noarch 0:2.0.8-1.el5                  lib64ldap2.4_2.x86_64 0:2.4.22-1.el5           libtool-ltdl.x86_64 0:1.5.22-7.el5_4       openldap-clients.x86_64 0:2.3.43-12.el5_6.7 
  openldap-servers.x86_64 0:2.3.43-12.el5_6.7    openldap2.4.x86_64 0:2.4.22-1.el5                 openldap2.4-extra-schemas.noarch 0:1.3-10.el5  openldap2.4-servers.x86_64 0:2.4.22-1.el5  perl-Compress-Zlib.x86_64 0:1.42-1.fc6      
  perl-HTML-Parser.x86_64 0:3.55-1.fc6           perl-HTML-Tagset.noarch 0:3.10-2.1.1              perl-URI.noarch 0:1.35-3                       perl-libwww-perl.noarch 0:5.805-1.1.1      unixODBC.x86_64 0:2.2.11-7.1                

Complete!

-- AlessandroPaolini - 2012-04-17

Topic revision: r1 - 2012-04-17 - AlessandroPaolini
 
This site is powered by the TWiki collaboration platformCopyright © 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback