Certification for tasks 24846 and 24847

Disclaimer: VOMS and VOMS Admin are certified together, the same report holds for both tasks.

Clean installation deployment test

SL5/x86_64

VOMS MySQL

VOMS Oracle


[root@emitestbed18 siteinfo]# yum  install emi-voms-oracle
Loaded plugins: downloadonly, kernel-module, priorities, protect-packages, protectbase, security, verify, versionlock
Repository EGI-trustanchors is listed more than once in the configuration
4324 packages excluded due to repository priority protections
0 packages excluded due to repository protections
Reading version lock configuration
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package emi-voms-oracle.x86_64 0:1.0.1-1.el5 set to be updated
--> Processing Dependency: voms-oracle-plugin for package: emi-voms-oracle
--> Running transaction check
---> Package voms-oracle-plugin.x86_64 0:3.1.15-1.el5 set to be updated
--> Finished Dependency Resolution
Beginning Kernel Module Plugin
Finished Kernel Module Plugin

Dependencies Resolved

==========================================================================================================================================================================================
 Package                                           Arch                                  Version                                       Repository                                    Size
==========================================================================================================================================================================================
Installing:
 emi-voms-oracle                                   x86_64                                1.0.1-1.el5                                   EMI-2-RC-base                                2.1 k
Installing for dependencies:
 voms-oracle-plugin                                x86_64                                3.1.15-1.el5                                  EMI-2-RC-base                                 56 k

Transaction Summary
==========================================================================================================================================================================================
Install       2 Package(s)
Upgrade       0 Package(s)

Total download size: 58 k
Is this ok [y/N]: y
Downloading Packages:
(1/2): emi-voms-oracle-1.0.1-1.el5.x86_64.rpm                                                                                                                      | 2.1 kB     00:00     
(2/2): voms-oracle-plugin-3.1.15-1.el5.x86_64.rpm                                                                                                                  |  56 kB     00:00     
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                     181 kB/s |  58 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : voms-oracle-plugin                                                                                                                                                 1/2 
  Installing     : emi-voms-oracle                                                                                                                                                    2/2 

Installed:
  emi-voms-oracle.x86_64 0:1.0.1-1.el5                                                                                                                                                    

Dependency Installed:
  voms-oracle-plugin.x86_64 0:3.1.15-1.el5                                                                                                                                                

Complete!


SL6/x86_64


[root@cert-30 ~]# wget --no-check-certificate https://twiki.cern.ch/twiki/pub/EMI/EMI-2/emi-2-rc-sl6.repo -O /etc/yum.repos.d/emi-2-rc-sl6.repo
--2012-05-04 12:07:14--  https://twiki.cern.ch/twiki/pub/EMI/EMI-2/emi-2-rc-sl6.repo
Resolving twiki.cern.ch... 137.138.6.73
Connecting to twiki.cern.ch|137.138.6.73|:443... connected.
WARNING: cannot verify twiki.cern.ch’s certificate, issued by “/C=US/O=VeriSign, Inc./OU=VeriSign Trust Network/OU=Terms of use at https://www.verisign.com/rpa (c)10/CN=VeriSign Class 3 Secure Server CA - G3”:
  Unable to locally verify the issuer’s authority.
HTTP request sent, awaiting response... 200 OK
Length: 1561 (1.5K) [application/octet-stream]
Saving to: “/etc/yum.repos.d/emi-2-rc-sl6.repo”

100%[===========================================================================================================================================>] 1,561       --.-K/s   in 0s      

2012-05-04 12:07:14 (38.1 MB/s) - “/etc/yum.repos.d/emi-2-rc-sl6.repo” saved [1561/1561]




[root@cert-30 ~]# wget http://emisoft.web.cern.ch/emisoft/dist/EMI/2/RPM-GPG-KEY-emi
--2012-05-04 12:08:03--  http://emisoft.web.cern.ch/emisoft/dist/EMI/2/RPM-GPG-KEY-emi
Resolving emisoft.web.cern.ch... 137.138.139.27
Connecting to emisoft.web.cern.ch|137.138.139.27|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1726 (1.7K) [text/plain]
Saving to: “RPM-GPG-KEY-emi”

100%[===========================================================================================================================================>] 1,726       --.-K/s   in 0s      

2012-05-04 12:08:03 (208 MB/s) - “RPM-GPG-KEY-emi” saved [1726/1726]



[root@cert-30 ~]# mv RPM-GPG-KEY-emi /etc/pki/rpm-gpg/


[root@cert-30 ~]# yum clean all
Loaded plugins: priorities, protectbase, security, verify, versionlock
Cleaning repos: EGI-trustanchors EMI-2-RC-base EMI-2-RC-third-party Oracle core epel extras sl sl-security
Cleaning up Everything


[root@cert-30 ~]# yum makecache 
Loaded plugins: priorities, protectbase, security, verify, versionlock
Metadata Cache Created


[root@cert-30 ~]# yum -y install emi-release
Loaded plugins: priorities, protectbase, security, verify, versionlock
EGI-trustanchors                                                                                                                                             |  951 B     00:00     
EGI-trustanchors/primary                                                                                                                                     |  31 kB     00:00     
EGI-trustanchors                                                                                                                                                            215/215
EMI-2-RC-base                                                                                                                                                | 1.9 kB     00:00     
EMI-2-RC-base/primary_db                                                                                                                                     | 412 kB     00:00     
EMI-2-RC-third-party                                                                                                                                         | 1.9 kB     00:00     
EMI-2-RC-third-party/primary_db                                                                                                                              |  22 kB     00:00     
Oracle                                                                                                                                                       | 1.9 kB     00:00     
Oracle/primary_db                                                                                                                                            | 2.1 kB     00:00     
core                                                                                                                                                         | 3.2 kB     00:00     
core/primary_db                                                                                                                                              | 4.1 MB     00:01     
epel/metalink                                                                                                                                                |  17 kB     00:00     
epel                                                                                                                                                         | 4.0 kB     00:00     
epel/primary_db                                                                                                                                              | 4.3 MB     00:04     
extras                                                                                                                                                       | 4.0 kB     00:00     
extras/primary_db                                                                                                                                            | 4.3 MB     00:02     
sl                                                                                                                                                           | 3.2 kB     00:00     
sl/primary_db                                                                                                                                                | 4.1 MB     00:02     
sl-security                                                                                                                                                  | 1.9 kB     00:00     
sl-security/primary_db                                                                                                                                       | 2.3 MB     00:01     
262 packages excluded due to repository priority protections
0 packages excluded due to repository protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package emi-release.noarch 0:2.0.0-1.sl6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

====================================================================================================================================================================================
 Package                                     Arch                                   Version                                     Repository                                     Size
====================================================================================================================================================================================
Installing:
 emi-release                                 noarch                                 2.0.0-1.sl6                                 EMI-2-RC-base                                 5.1 k

Transaction Summary
====================================================================================================================================================================================
Install       1 Package(s)

Total download size: 5.1 k
Installed size: 2.5 k
Downloading Packages:
emi-release-2.0.0-1.sl6.noarch.rpm                                                                                                                           | 5.1 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : emi-release-2.0.0-1.sl6.noarch                                                                                                                                   1/1 

Installed:
  emi-release.noarch 0:2.0.0-1.sl6                                                                                                                                                  

Complete!




[root@cert-30 ~]# yum -y install yum-protectbase
Loaded plugins: priorities, protectbase, security, verify, versionlock
292 packages excluded due to repository priority protections
0 packages excluded due to repository protections
Setting up Install Process
Package yum-plugin-protectbase-1.1.30-10.el6.noarch already installed and latest version
Nothing to do



[root@cert-30 ~]# yum -y install yum-priorities
Loaded plugins: priorities, protectbase, security, verify, versionlock
292 packages excluded due to repository priority protections
0 packages excluded due to repository protections
Setting up Install Process
Package yum-plugin-priorities-1.1.30-10.el6.noarch already installed and latest version
Nothing to do



[root@cert-30 ~]# yum install ca-policy-egi-core

...
...
...

(59/103): ca_NCSA-mics-1.47-1.noarch.rpm                                                                                                                     | 5.3 kB     00:00     
(60/103): ca_NCSA-slcs-1.47-1.noarch.rpm                                                                                                                     | 5.3 kB     00:00     
(61/103): ca_NCSA-tfca-1.47-1.noarch.rpm                                                                                                                     | 5.2 kB     00:00     
(62/103): ca_NECTEC-1.47-1.noarch.rpm                                                                                                                        | 5.5 kB     00:00     
(63/103): ca_NERSC-SLCS-1.47-1.noarch.rpm                                                                                                                    | 5.8 kB     00:00     
(64/103): ca_NICS-MyProxy-1.47-1.noarch.rpm                                                                                                                  | 5.3 kB     00:00     
(65/103): ca_NIIF-1.47-1.noarch.rpm                                                                                                                          | 5.2 kB     00:00     
(66/103): ca_NIKHEF-1.47-1.noarch.rpm                                                                                                                        | 5.4 kB     00:00     
(67/103): ca_NorduGrid-1.47-1.noarch.rpm                                                                                                                     | 5.1 kB     00:00     
(68/103): ca_PK-Grid-2007-1.47-1.noarch.rpm                                                                                                                  | 5.7 kB     00:00     
(69/103): ca_PRAGMA-UCSD-1.47-1.noarch.rpm                                                                                                                   | 5.6 kB     00:00     
(70/103): ca_PSC-Myproxy-CA-1.47-1.noarch.rpm                                                                                                                | 5.3 kB     00:00     
(71/103): ca_PolishGrid-1.47-1.noarch.rpm                                                                                                                    | 5.2 kB     00:00     
(72/103): ca_QuoVadis-Root-CA1-1.47-1.noarch.rpm                                                                                                             | 5.7 kB     00:00     
(73/103): ca_RDIG-1.47-1.noarch.rpm                                                                                                                          | 5.6 kB     00:00     
(74/103): ca_REUNA-ca-1.47-1.noarch.rpm                                                                                                                      | 5.3 kB     00:00     
(75/103): ca_RomanianGRID-1.47-1.noarch.rpm                                                                                                                  | 5.3 kB     00:00     
(76/103): ca_SDG-1.47-1.noarch.rpm                                                                                                                           | 5.3 kB     00:00     
(77/103): ca_SEE-GRID-1.47-1.noarch.rpm                                                                                                                      | 5.4 kB     00:00     
(78/103): ca_SRCE-1.47-1.noarch.rpm                                                                                                                          | 4.9 kB     00:00     
(79/103): ca_SWITCH-QuoVadis-Grid-ICA-1.47-1.noarch.rpm                                                                                                      | 5.2 kB     00:00     
(80/103): ca_SWITCHgrid-Root-1.47-1.noarch.rpm                                                                                                               | 5.3 kB     00:00     
(81/103): ca_SWITCHslcs2011-1.47-1.noarch.rpm                                                                                                                | 4.9 kB     00:00     
(82/103): ca_SiGNET-CA-1.47-1.noarch.rpm                                                                                                                     | 5.4 kB     00:00     
(83/103): ca_SlovakGrid-1.47-1.noarch.rpm                                                                                                                    | 5.3 kB     00:00     
(84/103): ca_TACC-Classic-1.47-1.noarch.rpm                                                                                                                  | 5.3 kB     00:00     
(85/103): ca_TACC-MICS-1.47-1.noarch.rpm                                                                                                                     | 5.3 kB     00:00     
(86/103): ca_TACC-Root-1.47-1.noarch.rpm                                                                                                                     | 5.2 kB     00:00     
(87/103): ca_TERENA-eScience-SSL-CA-1.47-1.noarch.rpm                                                                                                        | 5.7 kB     00:00     
(88/103): ca_TERENAeSciencePersonalCA-1.47-1.noarch.rpm                                                                                                      | 5.2 kB     00:00     
(89/103): ca_TRGrid-1.47-1.noarch.rpm                                                                                                                        | 5.2 kB     00:00     
(90/103): ca_UGRID-1.47-1.noarch.rpm                                                                                                                         | 5.1 kB     00:00     
(91/103): ca_UKeScienceCA-2007-1.47-1.noarch.rpm                                                                                                             | 4.9 kB     00:00     
(92/103): ca_UKeScienceCA-2A-1.47-1.noarch.rpm                                                                                                               | 4.9 kB     00:00     
(93/103): ca_UKeScienceCA-2B-1.47-1.noarch.rpm                                                                                                               | 4.9 kB     00:00     
(94/103): ca_UKeScienceRoot-2007-1.47-1.noarch.rpm                                                                                                           | 5.4 kB     00:00     
(95/103): ca_ULAGrid-CA-2008-1.47-1.noarch.rpm                                                                                                               | 5.4 kB     00:00     
(96/103): ca_UNAMgrid-ca-1.47-1.noarch.rpm                                                                                                                   | 5.5 kB     00:00     
(97/103): ca_UNLPGrid-1.47-1.noarch.rpm                                                                                                                      | 5.3 kB     00:00     
(98/103): ca_UTN-USERFirst-Hardware-1.47-1.noarch.rpm                                                                                                        | 5.7 kB     00:00     
(99/103): ca_UTNAAAClient-1.47-1.noarch.rpm                                                                                                                  | 5.1 kB     00:00     
(100/103): ca_UniandesCA-1.47-1.noarch.rpm                                                                                                                   | 5.3 kB     00:00     
(101/103): ca_cilogon-silver-1.47-1.noarch.rpm                                                                                                               | 5.1 kB     00:00     
(102/103): ca_ncsa-gridshib-ca-1.47-1.noarch.rpm                                                                                                             | 5.4 kB     00:00     
(103/103): ca_pkIRISGrid-1.47-1.noarch.rpm                                                                                                                   | 5.5 kB     00:00     
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                70 kB/s | 551 kB     00:07     
warning: rpmts_HdrFromFdno: Header V3 DSA/SHA1 Signature, key ID 3cdbbc71: NOKEY
Retrieving key from http://repository.egi.eu/sw/production/cas/1/GPG-KEY-EUGridPMA-RPM-3
Importing GPG key 0x3CDBBC71:
 Userid: "EUGridPMA Distribution Signing Key 3 <info@eugridpma.org>"
 From  : http://repository.egi.eu/sw/production/cas/1/GPG-KEY-EUGridPMA-RPM-3
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : ca_UKeScienceRoot-2007-1.47-1.noarch                                                                                                                           1/103 
  Installing : ca_TACC-Root-1.47-1.noarch                                                                                                                                     2/103 
  Installing : ca_CERN-Root-1.47-1.noarch                                                                                                                                     3/103 
  Installing : ca_AAACertificateServices-1.47-1.noarch                                                                                                                        4/103 
  Installing : ca_UTNAAAClient-1.47-1.noarch                                                                                                                                  5/103 
  Installing : ca_SWITCHgrid-Root-1.47-1.noarch                                                                                                                               6/103 
  Installing : ca_QuoVadis-Root-CA1-1.47-1.noarch                                                                                                                             7/103 
  Installing : ca_CNRS2-1.47-1.noarch                                                                                                                                         8/103 
  Installing : ca_CNRS2-Projets-1.47-1.noarch                                                                                                                                 9/103 
  Installing : ca_AddTrust-External-CA-Root-1.47-1.noarch                                                                                                                    10/103 
  Installing : ca_UTN-USERFirst-Hardware-1.47-1.noarch                                                                                                                       11/103 
  Installing : ca_ESnet-1.47-1.noarch                                                                                                                                        12/103 
  Installing : ca_HellasGrid-Root-1.47-1.noarch                                                                                                                              13/103 
  Installing : ca_CESNET-CA-Root-1.47-1.noarch                                                                                                                               14/103 
  Installing : ca_DigiCertGridRootCA-Root-1.47-1.noarch                                                                                                                      15/103 
  Installing : ca_DigiCertAssuredIDRootCA-Root-1.47-1.noarch                                                                                                                 16/103 
  Installing : ca_DigiCertGridTrustCA-Classic-1.47-1.noarch                                                                                                                  17/103 
  Installing : ca_DigiCertGridCA-1-Classic-1.47-1.noarch                                                                                                                     18/103 
  Installing : ca_CESNET-CA-3-1.47-1.noarch                                                                                                                                  19/103 
  Installing : ca_HellasGrid-CA-2006-1.47-1.noarch                                                                                                                           20/103 
  Installing : ca_DOEGrids-1.47-1.noarch                                                                                                                                     21/103 
  Installing : ca_TERENA-eScience-SSL-CA-1.47-1.noarch                                                                                                                       22/103 
  Installing : ca_CNRS2-Grid-FR-1.47-1.noarch                                                                                                                                23/103 
  Installing : ca_SWITCH-QuoVadis-Grid-ICA-1.47-1.noarch                                                                                                                     24/103 
  Installing : ca_SWITCHslcs2011-1.47-1.noarch                                                                                                                               25/103 
  Installing : ca_TERENAeSciencePersonalCA-1.47-1.noarch                                                                                                                     26/103 
  Installing : ca_CERN-TCA-1.47-1.noarch                                                                                                                                     27/103 
  Installing : ca_TACC-MICS-1.47-1.noarch                                                                                                                                    28/103 
  Installing : ca_TACC-Classic-1.47-1.noarch                                                                                                                                 29/103 
  Installing : ca_UKeScienceCA-2007-1.47-1.noarch                                                                                                                            30/103 
  Installing : ca_UKeScienceCA-2A-1.47-1.noarch                                                                                                                              31/103 
  Installing : ca_UKeScienceCA-2B-1.47-1.noarch                                                                                                                              32/103 
  Installing : ca_APAC-1.47-1.noarch                                                                                                                                         33/103 
  Installing : ca_SDG-1.47-1.noarch                                                                                                                                          34/103 
  Installing : ca_BrGrid-1.47-1.noarch                                                                                                                                       35/103 
  Installing : ca_MD-Grid-1.47-1.noarch                                                                                                                                      36/103 
  Installing : ca_TRGrid-1.47-1.noarch                                                                                                                                       37/103 
  Installing : ca_IGCA-1.47-1.noarch                                                                                                                                         38/103 
  Installing : ca_ncsa-gridshib-ca-1.47-1.noarch                                                                                                                             39/103 
  Installing : ca_CNIC-1.47-1.noarch                                                                                                                                         40/103 
  Installing : ca_MaGrid-1.47-1.noarch                                                                                                                                       41/103 
  Installing : ca_NCHC-1.47-1.noarch                                                                                                                                         42/103 
  Installing : ca_BYGCA-1.47-1.noarch                                                                                                                                        43/103 
  Installing : ca_FNAL-SLCS-1.47-1.noarch                                                                                                                                    44/103 
  Installing : ca_BG-ACAD-CA-1.47-1.noarch                                                                                                                                   45/103 
  Installing : ca_SEE-GRID-1.47-1.noarch                                                                                                                                     46/103 
  Installing : ca_NIIF-1.47-1.noarch                                                                                                                                         47/103 
  Installing : ca_SRCE-1.47-1.noarch                                                                                                                                         48/103 
  Installing : ca_REUNA-ca-1.47-1.noarch                                                                                                                                     49/103 
  Installing : ca_CALG-1.47-1.noarch                                                                                                                                         50/103 
  Installing : ca_PolishGrid-1.47-1.noarch                                                                                                                                   51/103 
  Installing : ca_NCSA-slcs-1.47-1.noarch                                                                                                                                    52/103 
  Installing : ca_PK-Grid-2007-1.47-1.noarch                                                                                                                                 53/103 
  Installing : ca_CyGrid-1.47-1.noarch                                                                                                                                       54/103 
  Installing : ca_ASGCCA-2007-1.47-1.noarch                                                                                                                                  55/103 
  Installing : ca_MYIFAM-1.47-1.noarch                                                                                                                                       56/103 
  Installing : ca_ArmeSFo-1.47-1.noarch                                                                                                                                      57/103 
  Installing : ca_DFN-GridGermany-Root-1.47-1.noarch                                                                                                                         58/103 
  Installing : ca_PSC-Myproxy-CA-1.47-1.noarch                                                                                                                               59/103 
  Installing : ca_HIAST-1.47-1.noarch                                                                                                                                        60/103 
  Installing : ca_PRAGMA-UCSD-1.47-1.noarch                                                                                                                                  61/103 
  Installing : ca_NICS-MyProxy-1.47-1.noarch                                                                                                                                 62/103 
  Installing : ca_ULAGrid-CA-2008-1.47-1.noarch                                                                                                                              63/103 
  Installing : ca_UniandesCA-1.47-1.noarch                                                                                                                                   64/103 
  Installing : ca_SiGNET-CA-1.47-1.noarch                                                                                                                                    65/103 
  Installing : ca_HKU-1.47-1.noarch                                                                                                                                          66/103 
  Installing : ca_NCSA-tfca-1.47-1.noarch                                                                                                                                    67/103 
  Installing : ca_GridCanada-1.47-1.noarch                                                                                                                                   68/103 
  Installing : ca_NAREGI-1.47-1.noarch                                                                                                                                       69/103 
  Installing : ca_AEGIS-1.47-1.noarch                                                                                                                                        70/103 
  Installing : ca_JUnet-CA-1.47-1.noarch                                                                                                                                     71/103 
  Installing : ca_NIKHEF-1.47-1.noarch                                                                                                                                       72/103 
  Installing : ca_IRAN-GRID-1.47-1.noarch                                                                                                                                    73/103 
  Installing : ca_SlovakGrid-1.47-1.noarch                                                                                                                                   74/103 
  Installing : ca_cilogon-silver-1.47-1.noarch                                                                                                                               75/103 
  Installing : ca_GermanGrid-1.47-1.noarch                                                                                                                                   76/103 
  Installing : ca_INFN-CA-2006-1.47-1.noarch                                                                                                                                 77/103 
  Installing : ca_RDIG-1.47-1.noarch                                                                                                                                         78/103 
  Installing : ca_DFN-SLCS-1.47-1.noarch                                                                                                                                     79/103 
  Installing : ca_LACGridCA-1.47-1.noarch                                                                                                                                    80/103 
  Installing : ca_NECTEC-1.47-1.noarch                                                                                                                                       81/103 
  Installing : ca_MREN-CA-1.47-1.noarch                                                                                                                                      82/103 
  Installing : ca_UNAMgrid-ca-1.47-1.noarch                                                                                                                                  83/103 
  Installing : ca_KISTI-2007-1.47-1.noarch                                                                                                                                   84/103 
  Installing : ca_BalticGrid-1.47-1.noarch                                                                                                                                   85/103 
  Installing : ca_LIPCA-1.47-1.noarch                                                                                                                                        86/103 
  Installing : ca_IUCC-1.47-1.noarch                                                                                                                                         87/103 
  Installing : ca_NERSC-SLCS-1.47-1.noarch                                                                                                                                   88/103 
  Installing : ca_NCSA-mics-1.47-1.noarch                                                                                                                                    89/103 
  Installing : ca_UNLPGrid-1.47-1.noarch                                                                                                                                     90/103 
  Installing : ca_RomanianGRID-1.47-1.noarch                                                                                                                                 91/103 
  Installing : ca_UGRID-1.47-1.noarch                                                                                                                                        92/103 
  Installing : ca_AustrianGrid-1.47-1.noarch                                                                                                                                 93/103 
  Installing : ca_AIST-1.47-1.noarch                                                                                                                                         94/103 
  Installing : ca_IHEP-1.47-1.noarch                                                                                                                                         95/103 
  Installing : ca_Grid-Ireland-1.47-1.noarch                                                                                                                                 96/103 
  Installing : ca_DZeScience-1.47-1.noarch                                                                                                                                   97/103 
  Installing : ca_BEGrid2008-1.47-1.noarch                                                                                                                                   98/103 
  Installing : ca_NorduGrid-1.47-1.noarch                                                                                                                                    99/103 
  Installing : ca_pkIRISGrid-1.47-1.noarch                                                                                                                                  100/103 
  Installing : ca_MARGI-1.47-1.noarch                                                                                                                                       101/103 
  Installing : ca_KEK-1.47-1.noarch                                                                                                                                         102/103 
  Installing : ca-policy-egi-core-1.47-1.noarch                                                                                                                             103/103 

Installed:
  ca-policy-egi-core.noarch 0:1.47-1                                                                                                                                                

Dependency Installed:
  ca_AAACertificateServices.noarch 0:1.47-1                     ca_AEGIS.noarch 0:1.47-1                                  ca_AIST.noarch 0:1.47-1                                   
  ca_APAC.noarch 0:1.47-1                                       ca_ASGCCA-2007.noarch 0:1.47-1                            ca_AddTrust-External-CA-Root.noarch 0:1.47-1              
  ca_ArmeSFo.noarch 0:1.47-1                                    ca_AustrianGrid.noarch 0:1.47-1                           ca_BEGrid2008.noarch 0:1.47-1                             
  ca_BG-ACAD-CA.noarch 0:1.47-1                                 ca_BYGCA.noarch 0:1.47-1                                  ca_BalticGrid.noarch 0:1.47-1                             
  ca_BrGrid.noarch 0:1.47-1                                     ca_CALG.noarch 0:1.47-1                                   ca_CERN-Root.noarch 0:1.47-1                              
  ca_CERN-TCA.noarch 0:1.47-1                                   ca_CESNET-CA-3.noarch 0:1.47-1                            ca_CESNET-CA-Root.noarch 0:1.47-1                         
  ca_CNIC.noarch 0:1.47-1                                       ca_CNRS2.noarch 0:1.47-1                                  ca_CNRS2-Grid-FR.noarch 0:1.47-1                          
  ca_CNRS2-Projets.noarch 0:1.47-1                              ca_CyGrid.noarch 0:1.47-1                                 ca_DFN-GridGermany-Root.noarch 0:1.47-1                   
  ca_DFN-SLCS.noarch 0:1.47-1                                   ca_DOEGrids.noarch 0:1.47-1                               ca_DZeScience.noarch 0:1.47-1                             
  ca_DigiCertAssuredIDRootCA-Root.noarch 0:1.47-1               ca_DigiCertGridCA-1-Classic.noarch 0:1.47-1               ca_DigiCertGridRootCA-Root.noarch 0:1.47-1                
  ca_DigiCertGridTrustCA-Classic.noarch 0:1.47-1                ca_ESnet.noarch 0:1.47-1                                  ca_FNAL-SLCS.noarch 0:1.47-1                              
  ca_GermanGrid.noarch 0:1.47-1                                 ca_Grid-Ireland.noarch 0:1.47-1                           ca_GridCanada.noarch 0:1.47-1                             
  ca_HIAST.noarch 0:1.47-1                                      ca_HKU.noarch 0:1.47-1                                    ca_HellasGrid-CA-2006.noarch 0:1.47-1                     
  ca_HellasGrid-Root.noarch 0:1.47-1                            ca_IGCA.noarch 0:1.47-1                                   ca_IHEP.noarch 0:1.47-1                                   
  ca_INFN-CA-2006.noarch 0:1.47-1                               ca_IRAN-GRID.noarch 0:1.47-1                              ca_IUCC.noarch 0:1.47-1                                   
  ca_JUnet-CA.noarch 0:1.47-1                                   ca_KEK.noarch 0:1.47-1                                    ca_KISTI-2007.noarch 0:1.47-1                             
  ca_LACGridCA.noarch 0:1.47-1                                  ca_LIPCA.noarch 0:1.47-1                                  ca_MARGI.noarch 0:1.47-1                                  
  ca_MD-Grid.noarch 0:1.47-1                                    ca_MREN-CA.noarch 0:1.47-1                                ca_MYIFAM.noarch 0:1.47-1                                 
  ca_MaGrid.noarch 0:1.47-1                                     ca_NAREGI.noarch 0:1.47-1                                 ca_NCHC.noarch 0:1.47-1                                   
  ca_NCSA-mics.noarch 0:1.47-1                                  ca_NCSA-slcs.noarch 0:1.47-1                              ca_NCSA-tfca.noarch 0:1.47-1                              
  ca_NECTEC.noarch 0:1.47-1                                     ca_NERSC-SLCS.noarch 0:1.47-1                             ca_NICS-MyProxy.noarch 0:1.47-1                           
  ca_NIIF.noarch 0:1.47-1                                       ca_NIKHEF.noarch 0:1.47-1                                 ca_NorduGrid.noarch 0:1.47-1                              
  ca_PK-Grid-2007.noarch 0:1.47-1                               ca_PRAGMA-UCSD.noarch 0:1.47-1                            ca_PSC-Myproxy-CA.noarch 0:1.47-1                         
  ca_PolishGrid.noarch 0:1.47-1                                 ca_QuoVadis-Root-CA1.noarch 0:1.47-1                      ca_RDIG.noarch 0:1.47-1                                   
  ca_REUNA-ca.noarch 0:1.47-1                                   ca_RomanianGRID.noarch 0:1.47-1                           ca_SDG.noarch 0:1.47-1                                    
  ca_SEE-GRID.noarch 0:1.47-1                                   ca_SRCE.noarch 0:1.47-1                                   ca_SWITCH-QuoVadis-Grid-ICA.noarch 0:1.47-1               
  ca_SWITCHgrid-Root.noarch 0:1.47-1                            ca_SWITCHslcs2011.noarch 0:1.47-1                         ca_SiGNET-CA.noarch 0:1.47-1                              
  ca_SlovakGrid.noarch 0:1.47-1                                 ca_TACC-Classic.noarch 0:1.47-1                           ca_TACC-MICS.noarch 0:1.47-1                              
  ca_TACC-Root.noarch 0:1.47-1                                  ca_TERENA-eScience-SSL-CA.noarch 0:1.47-1                 ca_TERENAeSciencePersonalCA.noarch 0:1.47-1               
  ca_TRGrid.noarch 0:1.47-1                                     ca_UGRID.noarch 0:1.47-1                                  ca_UKeScienceCA-2007.noarch 0:1.47-1                      
  ca_UKeScienceCA-2A.noarch 0:1.47-1                            ca_UKeScienceCA-2B.noarch 0:1.47-1                        ca_UKeScienceRoot-2007.noarch 0:1.47-1                    
  ca_ULAGrid-CA-2008.noarch 0:1.47-1                            ca_UNAMgrid-ca.noarch 0:1.47-1                            ca_UNLPGrid.noarch 0:1.47-1                               
  ca_UTN-USERFirst-Hardware.noarch 0:1.47-1                     ca_UTNAAAClient.noarch 0:1.47-1                           ca_UniandesCA.noarch 0:1.47-1                             
  ca_cilogon-silver.noarch 0:1.47-1                             ca_ncsa-gridshib-ca.noarch 0:1.47-1                       ca_pkIRISGrid.noarch 0:1.47-1                             

Complete!



VOMS MySQL

[root@cert-30 ~]# yum -y install emi-voms-mysql
Loaded plugins: priorities, protectbase, security, verify, versionlock
292 packages excluded due to repository priority protections
0 packages excluded due to repository protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package emi-voms-mysql.x86_64 0:1.0.1-1.el6 will be installed
--> Processing Dependency: yaim-voms for package: emi-voms-mysql-1.0.1-1.el6.x86_64
--> Processing Dependency: glite-yaim-bdii for package: emi-voms-mysql-1.0.1-1.el6.x86_64
--> Processing Dependency: fetch-crl for package: emi-voms-mysql-1.0.1-1.el6.x86_64
--> Processing Dependency: bdii for package: emi-voms-mysql-1.0.1-1.el6.x86_64
--> Processing Dependency: voms-admin-server for package: emi-voms-mysql-1.0.1-1.el6.x86_64
--> Processing Dependency: glite-info-provider-service for package: emi-voms-mysql-1.0.1-1.el6.x86_64
--> Processing Dependency: voms-admin-client for package: emi-voms-mysql-1.0.1-1.el6.x86_64
--> Processing Dependency: mysql-server for package: emi-voms-mysql-1.0.1-1.el6.x86_64
--> Processing Dependency: voms-mysql-plugin for package: emi-voms-mysql-1.0.1-1.el6.x86_64
--> Processing Dependency: voms-server for package: emi-voms-mysql-1.0.1-1.el6.x86_64
--> Running transaction check
---> Package bdii.noarch 0:5.2.10-1.el6 will be installed
--> Processing Dependency: glue-schema >= 2.0.0 for package: bdii-5.2.10-1.el6.noarch
--> Processing Dependency: openldap-servers for package: bdii-5.2.10-1.el6.noarch
--> Processing Dependency: expect for package: bdii-5.2.10-1.el6.noarch
--> Processing Dependency: policycoreutils-python for package: bdii-5.2.10-1.el6.noarch
--> Processing Dependency: openldap-clients for package: bdii-5.2.10-1.el6.noarch
---> Package fetch-crl.noarch 0:3.0.8-1.el6 will be installed
--> Processing Dependency: perl(LWP) for package: fetch-crl-3.0.8-1.el6.noarch
---> Package glite-info-provider-service.noarch 0:1.8.1-2.el6 will be installed
---> Package glite-yaim-bdii.noarch 0:4.3.9-1.el6 will be installed
---> Package mysql-server.x86_64 0:5.1.61-1.el6_2.1 will be installed
--> Processing Dependency: mysql = 5.1.61-1.el6_2.1 for package: mysql-server-5.1.61-1.el6_2.1.x86_64
--> Processing Dependency: perl-DBD-MySQL for package: mysql-server-5.1.61-1.el6_2.1.x86_64
--> Processing Dependency: perl(DBI) for package: mysql-server-5.1.61-1.el6_2.1.x86_64
--> Processing Dependency: perl-DBI for package: mysql-server-5.1.61-1.el6_2.1.x86_64
---> Package voms-admin-client.noarch 0:2.0.17-1.el6 will be installed
--> Processing Dependency: python-ZSI for package: voms-admin-client-2.0.17-1.el6.noarch
--> Processing Dependency: PyXML for package: voms-admin-client-2.0.17-1.el6.noarch
--> Processing Dependency: python-simplejson for package: voms-admin-client-2.0.17-1.el6.noarch
---> Package voms-admin-server.noarch 0:2.7.0-1.el6 will be installed
--> Processing Dependency: bouncycastle >= 1.39 for package: voms-admin-server-2.7.0-1.el6.noarch
--> Processing Dependency: emi-trustmanager for package: voms-admin-server-2.7.0-1.el6.noarch
--> Processing Dependency: java for package: voms-admin-server-2.7.0-1.el6.noarch
--> Processing Dependency: tomcat6 for package: voms-admin-server-2.7.0-1.el6.noarch
--> Processing Dependency: emi-trustmanager-tomcat for package: voms-admin-server-2.7.0-1.el6.noarch
---> Package voms-mysql-plugin.x86_64 0:3.1.6-1.el6 will be installed
---> Package voms-server.x86_64 0:2.0.8-1.el6 will be installed
--> Processing Dependency: voms(x86-64) = 2.0.8-1.el6 for package: voms-server-2.0.8-1.el6.x86_64
--> Processing Dependency: libvomsapi.so.1()(64bit) for package: voms-server-2.0.8-1.el6.x86_64
---> Package yaim-voms.noarch 0:1.1.1-1.el6 will be installed
--> Processing Dependency: glite-yaim-core for package: yaim-voms-1.1.1-1.el6.noarch
--> Running transaction check
---> Package PyXML.x86_64 0:0.8.4-19.el6 will be installed
---> Package bouncycastle.noarch 0:1.46-1.el6 will be installed
--> Processing Dependency: jpackage-utils >= 1.7 for package: bouncycastle-1.46-1.el6.noarch
--> Processing Dependency: jpackage-utils >= 1.5 for package: bouncycastle-1.46-1.el6.noarch
--> Processing Dependency: jpackage-utils >= 1.7 for package: bouncycastle-1.46-1.el6.noarch
--> Processing Dependency: java >= 1.7 for package: bouncycastle-1.46-1.el6.noarch
---> Package emi-trustmanager.noarch 0:3.1.3-1.sl6 will be installed
---> Package emi-trustmanager-tomcat.noarch 0:3.0.1-1.sl6 will be installed
--> Processing Dependency: log4j for package: emi-trustmanager-tomcat-3.0.1-1.sl6.noarch
---> Package expect.x86_64 0:5.44.1.15-2.el6 will be installed
--> Processing Dependency: libtcl8.5.so()(64bit) for package: expect-5.44.1.15-2.el6.x86_64
---> Package glite-yaim-core.noarch 0:5.1.0-1.sl6 will be installed
--> Processing Dependency: redhat-lsb for package: glite-yaim-core-5.1.0-1.sl6.noarch
---> Package glue-schema.noarch 0:2.0.8-1.el6 will be installed
---> Package java-1.5.0-gcj.x86_64 0:1.5.0.0-29.1.el6 will be installed
--> Processing Dependency: libgcj >= 4.1.2-5 for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
--> Processing Dependency: /usr/bin/gcj-dbtool for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
--> Processing Dependency: sinjdoc for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
--> Processing Dependency: /usr/bin/gij for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
--> Processing Dependency: /usr/lib64/security/classpath.security for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
--> Processing Dependency: /usr/bin/gcj-dbtool for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
--> Processing Dependency: /usr/bin/gij for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
---> Package mysql.x86_64 0:5.1.61-1.el6_2.1 will be installed
--> Processing Dependency: mysql-libs = 5.1.61-1.el6_2.1 for package: mysql-5.1.61-1.el6_2.1.x86_64
---> Package openldap-clients.x86_64 0:2.4.23-20.el6 will be installed
---> Package openldap-servers.x86_64 0:2.4.23-20.el6 will be installed
--> Processing Dependency: make for package: openldap-servers-2.4.23-20.el6.x86_64
--> Processing Dependency: libltdl.so.7()(64bit) for package: openldap-servers-2.4.23-20.el6.x86_64
---> Package perl-DBD-MySQL.x86_64 0:4.013-3.el6 will be installed
---> Package perl-DBI.x86_64 0:1.609-4.el6 will be installed
---> Package perl-libwww-perl.noarch 0:5.833-2.el6 will be installed
--> Processing Dependency: perl-HTML-Parser >= 3.33 for package: perl-libwww-perl-5.833-2.el6.noarch
--> Processing Dependency: mailcap for package: perl-libwww-perl-5.833-2.el6.noarch
--> Processing Dependency: perl(URI::Heuristic) for package: perl-libwww-perl-5.833-2.el6.noarch
--> Processing Dependency: perl(URI::URL) for package: perl-libwww-perl-5.833-2.el6.noarch
--> Processing Dependency: perl(URI) for package: perl-libwww-perl-5.833-2.el6.noarch
--> Processing Dependency: perl(HTML::Entities) for package: perl-libwww-perl-5.833-2.el6.noarch
--> Processing Dependency: perl(Compress::Zlib) for package: perl-libwww-perl-5.833-2.el6.noarch
---> Package policycoreutils-python.x86_64 0:2.0.83-19.18.el6 will be installed
--> Processing Dependency: libsemanage-python >= 2.0.43-4 for package: policycoreutils-python-2.0.83-19.18.el6.x86_64
--> Processing Dependency: audit-libs-python >= 1.4.2-1 for package: policycoreutils-python-2.0.83-19.18.el6.x86_64
--> Processing Dependency: libcgroup for package: policycoreutils-python-2.0.83-19.18.el6.x86_64
--> Processing Dependency: setools-libs-python for package: policycoreutils-python-2.0.83-19.18.el6.x86_64
--> Processing Dependency: libselinux-python for package: policycoreutils-python-2.0.83-19.18.el6.x86_64
---> Package python-ZSI.noarch 0:2.0-6.el6 will be installed
---> Package python-simplejson.x86_64 0:2.0.9-3.1.el6 will be installed
---> Package tomcat6.noarch 0:6.0.24-36.el6_2 will be installed
--> Processing Dependency: tomcat6-lib = 6.0.24-36.el6_2 for package: tomcat6-6.0.24-36.el6_2.noarch
--> Processing Dependency: jakarta-commons-dbcp for package: tomcat6-6.0.24-36.el6_2.noarch
--> Processing Dependency: jakarta-commons-collections for package: tomcat6-6.0.24-36.el6_2.noarch
--> Processing Dependency: jakarta-commons-pool for package: tomcat6-6.0.24-36.el6_2.noarch
--> Processing Dependency: mx4j for package: tomcat6-6.0.24-36.el6_2.noarch
--> Processing Dependency: jakarta-commons-daemon for package: tomcat6-6.0.24-36.el6_2.noarch
--> Processing Dependency: jakarta-commons-logging for package: tomcat6-6.0.24-36.el6_2.noarch
---> Package voms.x86_64 0:2.0.8-1.el6 will be installed
--> Running transaction check
---> Package audit-libs-python.x86_64 0:2.1.3-3.el6 will be installed
---> Package jakarta-commons-collections.noarch 0:3.2.1-3.4.el6 will be installed
---> Package jakarta-commons-daemon.x86_64 1:1.0.1-8.9.el6 will be installed
---> Package jakarta-commons-dbcp.noarch 0:1.2.1-13.8.el6 will be installed
---> Package jakarta-commons-logging.noarch 0:1.0.4-10.el6 will be installed
---> Package jakarta-commons-pool.x86_64 0:1.3-12.7.el6 will be installed
---> Package java-1.6.0-openjdk.x86_64 1:1.6.0.0-1.43.1.10.6.el6_2 will be installed
--> Processing Dependency: libjpeg = 6b for package: 1:java-1.6.0-openjdk-1.6.0.0-1.43.1.10.6.el6_2.x86_64
--> Processing Dependency: libasound.so.2(ALSA_0.9)(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.43.1.10.6.el6_2.x86_64
--> Processing Dependency: fontconfig for package: 1:java-1.6.0-openjdk-1.6.0.0-1.43.1.10.6.el6_2.x86_64
--> Processing Dependency: rhino for package: 1:java-1.6.0-openjdk-1.6.0.0-1.43.1.10.6.el6_2.x86_64
--> Processing Dependency: libasound.so.2(ALSA_0.9.0rc4)(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.43.1.10.6.el6_2.x86_64
--> Processing Dependency: libpng12.so.0(PNG12_0)(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.43.1.10.6.el6_2.x86_64
--> Processing Dependency: tzdata-java for package: 1:java-1.6.0-openjdk-1.6.0.0-1.43.1.10.6.el6_2.x86_64
--> Processing Dependency: libpulse.so.0(PULSE_0)(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.43.1.10.6.el6_2.x86_64
--> Processing Dependency: libXext.so.6()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.43.1.10.6.el6_2.x86_64
--> Processing Dependency: libfreetype.so.6()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.43.1.10.6.el6_2.x86_64
--> Processing Dependency: libpulse.so.0()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.43.1.10.6.el6_2.x86_64
--> Processing Dependency: libXtst.so.6()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.43.1.10.6.el6_2.x86_64
--> Processing Dependency: libXrender.so.1()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.43.1.10.6.el6_2.x86_64
--> Processing Dependency: libasound.so.2()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.43.1.10.6.el6_2.x86_64
--> Processing Dependency: libjpeg.so.62()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.43.1.10.6.el6_2.x86_64
--> Processing Dependency: libX11.so.6()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.43.1.10.6.el6_2.x86_64
--> Processing Dependency: libpng12.so.0()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.43.1.10.6.el6_2.x86_64
--> Processing Dependency: libXi.so.6()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.43.1.10.6.el6_2.x86_64
--> Processing Dependency: libgif.so.4()(64bit) for package: 1:java-1.6.0-openjdk-1.6.0.0-1.43.1.10.6.el6_2.x86_64
---> Package jpackage-utils.noarch 0:1.7.5-3.12.el6 will be installed
---> Package libcgroup.x86_64 0:0.37-3.el6 will be installed
---> Package libgcj.x86_64 0:4.4.6-3.el6 will be installed
--> Processing Dependency: gtk2 >= 2.4.0 for package: libgcj-4.4.6-3.el6.x86_64
--> Processing Dependency: libart_lgpl >= 2.1.0 for package: libgcj-4.4.6-3.el6.x86_64
--> Processing Dependency: zip >= 2.1 for package: libgcj-4.4.6-3.el6.x86_64
--> Processing Dependency: libpangocairo-1.0.so.0()(64bit) for package: libgcj-4.4.6-3.el6.x86_64
--> Processing Dependency: libgtk-x11-2.0.so.0()(64bit) for package: libgcj-4.4.6-3.el6.x86_64
--> Processing Dependency: libpangoft2-1.0.so.0()(64bit) for package: libgcj-4.4.6-3.el6.x86_64
--> Processing Dependency: libcairo.so.2()(64bit) for package: libgcj-4.4.6-3.el6.x86_64
--> Processing Dependency: libatk-1.0.so.0()(64bit) for package: libgcj-4.4.6-3.el6.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: libgcj-4.4.6-3.el6.x86_64
--> Processing Dependency: libgdk-x11-2.0.so.0()(64bit) for package: libgcj-4.4.6-3.el6.x86_64
--> Processing Dependency: libXrandr.so.2()(64bit) for package: libgcj-4.4.6-3.el6.x86_64
--> Processing Dependency: libICE.so.6()(64bit) for package: libgcj-4.4.6-3.el6.x86_64
--> Processing Dependency: libpango-1.0.so.0()(64bit) for package: libgcj-4.4.6-3.el6.x86_64
--> Processing Dependency: libSM.so.6()(64bit) for package: libgcj-4.4.6-3.el6.x86_64
---> Package libselinux-python.x86_64 0:2.0.94-5.2.el6 will be installed
---> Package libsemanage-python.x86_64 0:2.0.43-4.1.el6 will be installed
---> Package libtool-ltdl.x86_64 0:2.2.6-15.5.el6 will be installed
---> Package log4j.x86_64 0:1.2.14-6.4.el6 will be installed
--> Processing Dependency: xml-commons-apis for package: log4j-1.2.14-6.4.el6.x86_64
---> Package mailcap.noarch 0:2.1.31-2.el6 will be installed
---> Package make.x86_64 1:3.81-19.el6 will be installed
---> Package mx4j.noarch 1:3.0.1-9.13.el6 will be installed
--> Processing Dependency: axis >= 1.1 for package: 1:mx4j-3.0.1-9.13.el6.noarch
--> Processing Dependency: bcel >= 5.0 for package: 1:mx4j-3.0.1-9.13.el6.noarch
--> Processing Dependency: javamail >= 1.2-5jpp for package: 1:mx4j-3.0.1-9.13.el6.noarch
--> Processing Dependency: jaf for package: 1:mx4j-3.0.1-9.13.el6.noarch
--> Processing Dependency: xml-commons-resolver for package: 1:mx4j-3.0.1-9.13.el6.noarch
---> Package mysql-libs.x86_64 0:5.1.52-1.el6_0.1 will be updated
---> Package mysql-libs.x86_64 0:5.1.61-1.el6_2.1 will be an update
---> Package perl-Compress-Zlib.x86_64 0:2.020-119.el6_1.1 will be installed
--> Processing Dependency: perl(Compress::Raw::Zlib) >= 2.020 for package: perl-Compress-Zlib-2.020-119.el6_1.1.x86_64
--> Processing Dependency: perl(IO::Uncompress::Gunzip) >= 2.020 for package: perl-Compress-Zlib-2.020-119.el6_1.1.x86_64
--> Processing Dependency: perl(IO::Compress::Gzip) >= 2.020 for package: perl-Compress-Zlib-2.020-119.el6_1.1.x86_64
--> Processing Dependency: perl(IO::Compress::Base::Common) >= 2.020 for package: perl-Compress-Zlib-2.020-119.el6_1.1.x86_64
--> Processing Dependency: perl(IO::Compress::Gzip::Constants) >= 2.020 for package: perl-Compress-Zlib-2.020-119.el6_1.1.x86_64
---> Package perl-HTML-Parser.x86_64 0:3.64-2.el6 will be installed
--> Processing Dependency: perl(HTML::Tagset) >= 3.03 for package: perl-HTML-Parser-3.64-2.el6.x86_64
--> Processing Dependency: perl(HTML::Tagset) for package: perl-HTML-Parser-3.64-2.el6.x86_64
---> Package perl-URI.noarch 0:1.40-2.el6 will be installed
---> Package redhat-lsb.x86_64 0:4.0-3.el6 will be installed
--> Processing Dependency: /usr/bin/batch for package: redhat-lsb-4.0-3.el6.x86_64
--> Processing Dependency: /usr/bin/bc for package: redhat-lsb-4.0-3.el6.x86_64
--> Processing Dependency: /bin/gettext for package: redhat-lsb-4.0-3.el6.x86_64
--> Processing Dependency: /usr/bin/msgfmt for package: redhat-lsb-4.0-3.el6.x86_64
--> Processing Dependency: perl-Test-Harness for package: redhat-lsb-4.0-3.el6.x86_64
--> Processing Dependency: redhat-lsb-graphics for package: redhat-lsb-4.0-3.el6.x86_64
--> Processing Dependency: redhat-lsb-printing for package: redhat-lsb-4.0-3.el6.x86_64
--> Processing Dependency: /bin/ed for package: redhat-lsb-4.0-3.el6.x86_64
--> Processing Dependency: /usr/bin/file for package: redhat-lsb-4.0-3.el6.x86_64
--> Processing Dependency: /usr/bin/pax for package: redhat-lsb-4.0-3.el6.x86_64
--> Processing Dependency: perl-CGI for package: redhat-lsb-4.0-3.el6.x86_64
--> Processing Dependency: /usr/bin/patch for package: redhat-lsb-4.0-3.el6.x86_64
--> Processing Dependency: /usr/bin/man for package: redhat-lsb-4.0-3.el6.x86_64
--> Processing Dependency: /usr/bin/at for package: redhat-lsb-4.0-3.el6.x86_64
--> Processing Dependency: perl-Test-Simple for package: redhat-lsb-4.0-3.el6.x86_64
--> Processing Dependency: /usr/bin/time for package: redhat-lsb-4.0-3.el6.x86_64
--> Processing Dependency: perl-ExtUtils-MakeMaker for package: redhat-lsb-4.0-3.el6.x86_64
---> Package setools-libs-python.x86_64 0:3.3.7-4.el6 will be installed
--> Processing Dependency: setools-libs = 3.3.7-4.el6 for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libqpol.so.1(VERS_1.3)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libapol.so.4(VERS_4.1)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libseaudit.so.4(VERS_4.2)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libapol.so.4(VERS_4.0)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libpoldiff.so.1(VERS_1.2)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libpoldiff.so.1(VERS_1.3)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libqpol.so.1(VERS_1.2)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libqpol.so.1(VERS_1.4)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libsefs.so.4(VERS_4.0)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libseaudit.so.4(VERS_4.1)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libseaudit.so.4()(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libsefs.so.4()(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libapol.so.4()(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libpoldiff.so.1()(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libqpol.so.1()(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
---> Package sinjdoc.x86_64 0:0.5-9.1.el6 will be installed
--> Processing Dependency: java_cup >= 0.10 for package: sinjdoc-0.5-9.1.el6.x86_64
---> Package tcl.x86_64 1:8.5.7-6.el6 will be installed
---> Package tomcat6-lib.noarch 0:6.0.24-36.el6_2 will be installed
--> Processing Dependency: tomcat6-servlet-2.5-api = 6.0.24-36.el6_2 for package: tomcat6-lib-6.0.24-36.el6_2.noarch
--> Processing Dependency: tomcat6-el-2.1-api = 6.0.24-36.el6_2 for package: tomcat6-lib-6.0.24-36.el6_2.noarch
--> Processing Dependency: tomcat6-jsp-2.1-api = 6.0.24-36.el6_2 for package: tomcat6-lib-6.0.24-36.el6_2.noarch
--> Processing Dependency: ecj for package: tomcat6-lib-6.0.24-36.el6_2.noarch
--> Running transaction check
---> Package alsa-lib.x86_64 0:1.0.22-3.el6 will be installed
---> Package at.x86_64 0:3.1.10-43.el6 will be installed
---> Package atk.x86_64 0:1.28.0-2.el6 will be installed
---> Package axis.noarch 0:1.2.1-7.2.el6 will be installed
--> Processing Dependency: jakarta-commons-httpclient for package: axis-1.2.1-7.2.el6.noarch
--> Processing Dependency: jakarta-commons-discovery for package: axis-1.2.1-7.2.el6.noarch
--> Processing Dependency: wsdl4j for package: axis-1.2.1-7.2.el6.noarch
---> Package bc.x86_64 0:1.06.95-1.el6 will be installed
---> Package bcel.x86_64 0:5.2-7.2.el6 will be installed
--> Processing Dependency: regexp for package: bcel-5.2-7.2.el6.x86_64
---> Package cairo.x86_64 0:1.8.8-3.1.el6 will be installed
--> Processing Dependency: libpixman-1.so.0()(64bit) for package: cairo-1.8.8-3.1.el6.x86_64
---> Package classpathx-jaf.x86_64 0:1.0-15.4.el6 will be installed
---> Package classpathx-mail.noarch 0:1.1.1-9.4.el6 will be installed
---> Package ecj.x86_64 1:3.4.2-6.el6 will be installed
---> Package ed.x86_64 0:1.1-3.3.el6 will be installed
---> Package file.x86_64 0:5.04-11.el6 will be installed
---> Package fontconfig.x86_64 0:2.8.0-3.el6 will be installed
---> Package freetype.x86_64 0:2.3.11-6.el6_2.9 will be installed
---> Package gettext.x86_64 0:0.17-16.el6 will be installed
--> Processing Dependency: cvs for package: gettext-0.17-16.el6.x86_64
--> Processing Dependency: libgomp.so.1(GOMP_1.0)(64bit) for package: gettext-0.17-16.el6.x86_64
--> Processing Dependency: libgomp.so.1()(64bit) for package: gettext-0.17-16.el6.x86_64
---> Package giflib.x86_64 0:4.1.6-3.1.el6 will be installed
---> Package gtk2.x86_64 0:2.18.9-6.el6 will be installed
--> Processing Dependency: libtiff >= 3.6.1 for package: gtk2-2.18.9-6.el6.x86_64
--> Processing Dependency: hicolor-icon-theme for package: gtk2-2.18.9-6.el6.x86_64
--> Processing Dependency: libjasper.so.1()(64bit) for package: gtk2-2.18.9-6.el6.x86_64
--> Processing Dependency: libXcomposite.so.1()(64bit) for package: gtk2-2.18.9-6.el6.x86_64
--> Processing Dependency: libXinerama.so.1()(64bit) for package: gtk2-2.18.9-6.el6.x86_64
--> Processing Dependency: libtiff.so.3()(64bit) for package: gtk2-2.18.9-6.el6.x86_64
--> Processing Dependency: libXdamage.so.1()(64bit) for package: gtk2-2.18.9-6.el6.x86_64
--> Processing Dependency: libXfixes.so.3()(64bit) for package: gtk2-2.18.9-6.el6.x86_64
--> Processing Dependency: libcups.so.2()(64bit) for package: gtk2-2.18.9-6.el6.x86_64
--> Processing Dependency: libXcursor.so.1()(64bit) for package: gtk2-2.18.9-6.el6.x86_64
---> Package java_cup.x86_64 1:0.10k-5.el6 will be installed
---> Package libICE.x86_64 0:1.0.6-1.el6 will be installed
---> Package libSM.x86_64 0:1.1.0-7.1.el6 will be installed
---> Package libX11.x86_64 0:1.3-2.el6 will be installed
--> Processing Dependency: libX11-common = 1.3-2.el6 for package: libX11-1.3-2.el6.x86_64
--> Processing Dependency: libxcb.so.1()(64bit) for package: libX11-1.3-2.el6.x86_64
---> Package libXext.x86_64 0:1.1-3.el6 will be installed
---> Package libXi.x86_64 0:1.3-3.el6 will be installed
---> Package libXrandr.x86_64 0:1.3.0-4.el6 will be installed
---> Package libXrender.x86_64 0:0.9.5-1.el6 will be installed
---> Package libXtst.x86_64 0:1.0.99.2-3.el6 will be installed
---> Package libart_lgpl.x86_64 0:2.3.20-5.1.el6 will be installed
---> Package libjpeg.x86_64 0:6b-46.el6 will be installed
---> Package libpng.x86_64 2:1.2.49-1.el6_2 will be installed
---> Package man.x86_64 0:1.6f-29.el6 will be installed
--> Processing Dependency: lzma for package: man-1.6f-29.el6.x86_64
---> Package pango.x86_64 0:1.28.1-3.el6_0.5 will be installed
--> Processing Dependency: libthai >= 0.1.9 for package: pango-1.28.1-3.el6_0.5.x86_64
--> Processing Dependency: libthai.so.0(LIBTHAI_0.1)(64bit) for package: pango-1.28.1-3.el6_0.5.x86_64
--> Processing Dependency: libthai.so.0()(64bit) for package: pango-1.28.1-3.el6_0.5.x86_64
--> Processing Dependency: libXft.so.2()(64bit) for package: pango-1.28.1-3.el6_0.5.x86_64
---> Package patch.x86_64 0:2.6-6.el6 will be installed
---> Package pax.x86_64 0:3.4-10.1.el6 will be installed
---> Package perl-CGI.x86_64 0:3.51-119.el6_1.1 will be installed
---> Package perl-Compress-Raw-Zlib.x86_64 0:2.023-119.el6_1.1 will be installed
---> Package perl-ExtUtils-MakeMaker.x86_64 0:6.55-119.el6_1.1 will be installed
--> Processing Dependency: perl-devel for package: perl-ExtUtils-MakeMaker-6.55-119.el6_1.1.x86_64
---> Package perl-HTML-Tagset.noarch 0:3.20-4.el6 will be installed
---> Package perl-IO-Compress-Base.x86_64 0:2.020-119.el6_1.1 will be installed
---> Package perl-IO-Compress-Zlib.x86_64 0:2.020-119.el6_1.1 will be installed
---> Package perl-Test-Harness.x86_64 0:3.17-119.el6_1.1 will be installed
---> Package perl-Test-Simple.x86_64 0:0.92-119.el6_1.1 will be installed
---> Package pulseaudio-libs.x86_64 0:0.9.21-13.el6 will be installed
--> Processing Dependency: libsndfile.so.1(libsndfile.so.1.0)(64bit) for package: pulseaudio-libs-0.9.21-13.el6.x86_64
--> Processing Dependency: libasyncns.so.0()(64bit) for package: pulseaudio-libs-0.9.21-13.el6.x86_64
--> Processing Dependency: libsndfile.so.1()(64bit) for package: pulseaudio-libs-0.9.21-13.el6.x86_64
---> Package redhat-lsb-graphics.x86_64 0:4.0-3.el6 will be installed
--> Processing Dependency: libQtCore.so.4()(64bit) for package: redhat-lsb-graphics-4.0-3.el6.x86_64
--> Processing Dependency: libGLU.so.1()(64bit) for package: redhat-lsb-graphics-4.0-3.el6.x86_64
--> Processing Dependency: libqt-mt.so.3()(64bit) for package: redhat-lsb-graphics-4.0-3.el6.x86_64
--> Processing Dependency: libQtSql.so.4()(64bit) for package: redhat-lsb-graphics-4.0-3.el6.x86_64
--> Processing Dependency: libQtSvg.so.4()(64bit) for package: redhat-lsb-graphics-4.0-3.el6.x86_64
--> Processing Dependency: libXt.so.6()(64bit) for package: redhat-lsb-graphics-4.0-3.el6.x86_64
--> Processing Dependency: libQtXml.so.4()(64bit) for package: redhat-lsb-graphics-4.0-3.el6.x86_64
--> Processing Dependency: libQtNetwork.so.4()(64bit) for package: redhat-lsb-graphics-4.0-3.el6.x86_64
--> Processing Dependency: libGL.so.1()(64bit) for package: redhat-lsb-graphics-4.0-3.el6.x86_64
--> Processing Dependency: libQtOpenGL.so.4()(64bit) for package: redhat-lsb-graphics-4.0-3.el6.x86_64
--> Processing Dependency: libQtGui.so.4()(64bit) for package: redhat-lsb-graphics-4.0-3.el6.x86_64
---> Package redhat-lsb-printing.x86_64 0:4.0-3.el6 will be installed
--> Processing Dependency: /usr/bin/gs for package: redhat-lsb-printing-4.0-3.el6.x86_64
--> Processing Dependency: /usr/bin/lp for package: redhat-lsb-printing-4.0-3.el6.x86_64
--> Processing Dependency: /usr/bin/foomatic-rip for package: redhat-lsb-printing-4.0-3.el6.x86_64
--> Processing Dependency: /usr/bin/lpr for package: redhat-lsb-printing-4.0-3.el6.x86_64
---> Package rhino.noarch 0:1.7-0.7.r2.2.el6 will be installed
--> Processing Dependency: jline for package: rhino-1.7-0.7.r2.2.el6.noarch
---> Package setools-libs.x86_64 0:3.3.7-4.el6 will be installed
---> Package time.x86_64 0:1.7-37.1.el6 will be installed
---> Package tomcat6-el-2.1-api.noarch 0:6.0.24-36.el6_2 will be installed
---> Package tomcat6-jsp-2.1-api.noarch 0:6.0.24-36.el6_2 will be installed
---> Package tomcat6-servlet-2.5-api.noarch 0:6.0.24-36.el6_2 will be installed
---> Package tzdata-java.noarch 0:2012b-3.el6 will be installed
---> Package xml-commons-apis.x86_64 0:1.3.04-3.6.el6 will be installed
---> Package xml-commons-resolver.x86_64 0:1.1-4.18.el6 will be installed
---> Package zip.x86_64 0:3.0-1.el6 will be installed
--> Running transaction check
---> Package cups.x86_64 1:1.4.2-44.el6 will be installed
--> Processing Dependency: dbus >= 0.90 for package: 1:cups-1.4.2-44.el6.x86_64
--> Processing Dependency: libgnutls.so.26(GNUTLS_1_4)(64bit) for package: 1:cups-1.4.2-44.el6.x86_64
--> Processing Dependency: poppler-utils for package: 1:cups-1.4.2-44.el6.x86_64
--> Processing Dependency: portreserve for package: 1:cups-1.4.2-44.el6.x86_64
--> Processing Dependency: tmpwatch for package: 1:cups-1.4.2-44.el6.x86_64
--> Processing Dependency: libavahi-client.so.3()(64bit) for package: 1:cups-1.4.2-44.el6.x86_64
--> Processing Dependency: libavahi-common.so.3()(64bit) for package: 1:cups-1.4.2-44.el6.x86_64
--> Processing Dependency: libgnutls.so.26()(64bit) for package: 1:cups-1.4.2-44.el6.x86_64
---> Package cups-libs.x86_64 1:1.4.2-44.el6 will be installed
---> Package cvs.x86_64 0:1.11.23-11.el6_2.1 will be installed
---> Package foomatic.x86_64 0:4.0.4-1.el6_1.1 will be installed
--> Processing Dependency: foomatic-db for package: foomatic-4.0.4-1.el6_1.1.x86_64
---> Package ghostscript.x86_64 0:8.70-11.el6_2.6 will be installed
--> Processing Dependency: urw-fonts >= 1.1 for package: ghostscript-8.70-11.el6_2.6.x86_64
--> Processing Dependency: ghostscript-fonts for package: ghostscript-8.70-11.el6_2.6.x86_64
---> Package hicolor-icon-theme.noarch 0:0.11-1.1.el6 will be installed
---> Package jakarta-commons-discovery.noarch 1:0.4-5.4.el6 will be installed
---> Package jakarta-commons-httpclient.x86_64 1:3.1-0.6.el6 will be installed
---> Package jasper-libs.x86_64 0:1.900.1-15.el6_1.1 will be installed
---> Package jline.noarch 0:0.9.94-0.8.el6 will be installed
---> Package libX11-common.noarch 0:1.3-2.el6 will be installed
---> Package libXcomposite.x86_64 0:0.4.1-2.el6 will be installed
---> Package libXcursor.x86_64 0:1.1.10-2.el6 will be installed
---> Package libXdamage.x86_64 0:1.1.2-1.el6 will be installed
---> Package libXfixes.x86_64 0:4.0.4-1.el6 will be installed
---> Package libXft.x86_64 0:2.1.13-4.1.el6 will be installed
---> Package libXinerama.x86_64 0:1.1-1.el6 will be installed
---> Package libXt.x86_64 0:1.0.7-1.el6 will be installed
---> Package libasyncns.x86_64 0:0.8-1.1.el6 will be installed
---> Package libgomp.x86_64 0:4.4.6-3.el6 will be installed
---> Package libsndfile.x86_64 0:1.0.20-5.el6 will be installed
--> Processing Dependency: libogg.so.0()(64bit) for package: libsndfile-1.0.20-5.el6.x86_64
--> Processing Dependency: libvorbisenc.so.2()(64bit) for package: libsndfile-1.0.20-5.el6.x86_64
--> Processing Dependency: libFLAC.so.8()(64bit) for package: libsndfile-1.0.20-5.el6.x86_64
--> Processing Dependency: libvorbis.so.0()(64bit) for package: libsndfile-1.0.20-5.el6.x86_64
---> Package libthai.x86_64 0:0.1.12-3.el6 will be installed
---> Package libtiff.x86_64 0:3.9.4-5.el6_2 will be installed
---> Package libxcb.x86_64 0:1.5-1.el6 will be installed
--> Processing Dependency: libXau.so.6()(64bit) for package: libxcb-1.5-1.el6.x86_64
---> Package mesa-libGL.x86_64 0:7.11-3.el6 will be installed
--> Processing Dependency: mesa-dri-drivers(x86-64) = 7.11-3.el6 for package: mesa-libGL-7.11-3.el6.x86_64
--> Processing Dependency: libXxf86vm.so.1()(64bit) for package: mesa-libGL-7.11-3.el6.x86_64
---> Package mesa-libGLU.x86_64 0:7.11-3.el6 will be installed
---> Package perl-devel.x86_64 4:5.10.1-119.el6_1.1 will be installed
--> Processing Dependency: perl(ExtUtils::ParseXS) for package: 4:perl-devel-5.10.1-119.el6_1.1.x86_64
---> Package pixman.x86_64 0:0.18.4-1.el6_0.1 will be installed
---> Package qt.x86_64 1:4.6.2-20.el6 will be installed
---> Package qt-x11.x86_64 1:4.6.2-20.el6 will be installed
--> Processing Dependency: qt-sqlite(x86-64) = 1:4.6.2-20.el6 for package: 1:qt-x11-4.6.2-20.el6.x86_64
--> Processing Dependency: phonon-backend(x86-64) >= 4.3 for package: 1:qt-x11-4.6.2-20.el6.x86_64
--> Processing Dependency: libgstvideo-0.10.so.0()(64bit) for package: 1:qt-x11-4.6.2-20.el6.x86_64
--> Processing Dependency: libgstinterfaces-0.10.so.0()(64bit) for package: 1:qt-x11-4.6.2-20.el6.x86_64
--> Processing Dependency: libgstreamer-0.10.so.0()(64bit) for package: 1:qt-x11-4.6.2-20.el6.x86_64
--> Processing Dependency: libgstbase-0.10.so.0()(64bit) for package: 1:qt-x11-4.6.2-20.el6.x86_64
--> Processing Dependency: libmng.so.1()(64bit) for package: 1:qt-x11-4.6.2-20.el6.x86_64
---> Package qt3.x86_64 0:3.3.8b-30.el6 will be installed
---> Package regexp.x86_64 0:1.5-4.4.el6 will be installed
---> Package wsdl4j.noarch 0:1.5.2-7.8.el6 will be installed
---> Package xz-lzma-compat.x86_64 0:4.999.9-0.3.beta.20091007git.el6 will be installed
--> Processing Dependency: xz = 4.999.9-0.3.beta.20091007git.el6 for package: xz-lzma-compat-4.999.9-0.3.beta.20091007git.el6.x86_64
--> Running transaction check
---> Package avahi-libs.x86_64 0:0.6.25-11.el6 will be installed
---> Package dbus.x86_64 1:1.2.24-5.el6_1 will be installed
---> Package flac.x86_64 0:1.2.1-6.1.el6 will be installed
---> Package foomatic-db.noarch 0:4.0-7.20091126.el6 will be installed
--> Processing Dependency: foomatic-db-ppds = 4.0-7.20091126.el6 for package: foomatic-db-4.0-7.20091126.el6.noarch
--> Processing Dependency: foomatic-db-filesystem = 4.0-7.20091126.el6 for package: foomatic-db-4.0-7.20091126.el6.noarch
---> Package ghostscript-fonts.noarch 0:5.50-23.1.el6 will be installed
--> Processing Dependency: xorg-x11-font-utils for package: ghostscript-fonts-5.50-23.1.el6.noarch
---> Package gnutls.x86_64 0:2.8.5-4.el6_2.2 will be installed
--> Processing Dependency: libtasn1.so.3(LIBTASN1_0_3)(64bit) for package: gnutls-2.8.5-4.el6_2.2.x86_64
--> Processing Dependency: libtasn1.so.3()(64bit) for package: gnutls-2.8.5-4.el6_2.2.x86_64
---> Package gstreamer.x86_64 0:0.10.29-1.el6 will be installed
--> Processing Dependency: gstreamer-tools >= 0.10.29 for package: gstreamer-0.10.29-1.el6.x86_64
---> Package gstreamer-plugins-base.x86_64 0:0.10.29-1.el6 will be installed
--> Processing Dependency: liboil >= 0.3.12-9 for package: gstreamer-plugins-base-0.10.29-1.el6.x86_64
--> Processing Dependency: libtheoraenc.so.1(libtheoraenc_1.0)(64bit) for package: gstreamer-plugins-base-0.10.29-1.el6.x86_64
--> Processing Dependency: libtheoradec.so.1(libtheoradec_1.0)(64bit) for package: gstreamer-plugins-base-0.10.29-1.el6.x86_64
--> Processing Dependency: iso-codes for package: gstreamer-plugins-base-0.10.29-1.el6.x86_64
--> Processing Dependency: libtheoradec.so.1()(64bit) for package: gstreamer-plugins-base-0.10.29-1.el6.x86_64
--> Processing Dependency: libcdda_interface.so.0()(64bit) for package: gstreamer-plugins-base-0.10.29-1.el6.x86_64
--> Processing Dependency: libXv.so.1()(64bit) for package: gstreamer-plugins-base-0.10.29-1.el6.x86_64
--> Processing Dependency: libgudev-1.0.so.0()(64bit) for package: gstreamer-plugins-base-0.10.29-1.el6.x86_64
--> Processing Dependency: libtheoraenc.so.1()(64bit) for package: gstreamer-plugins-base-0.10.29-1.el6.x86_64
--> Processing Dependency: libcdda_paranoia.so.0()(64bit) for package: gstreamer-plugins-base-0.10.29-1.el6.x86_64
--> Processing Dependency: libvisual-0.4.so.0()(64bit) for package: gstreamer-plugins-base-0.10.29-1.el6.x86_64
--> Processing Dependency: liboil-0.3.so.0()(64bit) for package: gstreamer-plugins-base-0.10.29-1.el6.x86_64
---> Package libXau.x86_64 0:1.0.5-1.el6 will be installed
---> Package libXxf86vm.x86_64 0:1.1.0-1.el6 will be installed
---> Package libmng.x86_64 0:1.0.10-4.1.el6 will be installed
--> Processing Dependency: liblcms.so.1()(64bit) for package: libmng-1.0.10-4.1.el6.x86_64
---> Package libogg.x86_64 2:1.1.4-2.1.el6 will be installed
---> Package libvorbis.x86_64 1:1.2.3-4.el6_2.1 will be installed
---> Package mesa-dri-drivers.x86_64 0:7.11-3.el6 will be installed
---> Package perl-ExtUtils-ParseXS.x86_64 1:2.2003.0-119.el6_1.1 will be installed
---> Package phonon-backend-gstreamer.x86_64 1:4.6.2-20.el6 will be installed
---> Package poppler-utils.x86_64 0:0.12.4-3.el6_0.1 will be installed
--> Processing Dependency: poppler = 0.12.4-3.el6_0.1 for package: poppler-utils-0.12.4-3.el6_0.1.x86_64
--> Processing Dependency: libopenjpeg.so.2()(64bit) for package: poppler-utils-0.12.4-3.el6_0.1.x86_64
--> Processing Dependency: libpoppler.so.5()(64bit) for package: poppler-utils-0.12.4-3.el6_0.1.x86_64
---> Package portreserve.x86_64 0:0.0.4-4.el6_1.1 will be installed
---> Package qt-sqlite.x86_64 1:4.6.2-20.el6 will be installed
---> Package tmpwatch.x86_64 0:2.9.16-4.el6 will be installed
---> Package urw-fonts.noarch 0:2.4-10.el6 will be installed
---> Package xz.x86_64 0:4.999.9-0.3.beta.20091007git.el6 will be installed
--> Running transaction check
---> Package cdparanoia-libs.x86_64 0:10.2-5.1.el6 will be installed
---> Package foomatic-db-filesystem.noarch 0:4.0-7.20091126.el6 will be installed
---> Package foomatic-db-ppds.noarch 0:4.0-7.20091126.el6 will be installed
---> Package gstreamer-tools.x86_64 0:0.10.29-1.el6 will be installed
--> Processing Dependency: pkgconfig for package: gstreamer-tools-0.10.29-1.el6.x86_64
---> Package iso-codes.noarch 0:3.16-2.el6 will be installed
--> Processing Dependency: xml-common for package: iso-codes-3.16-2.el6.noarch
---> Package lcms-libs.x86_64 0:1.19-1.el6 will be installed
---> Package libXv.x86_64 0:1.0.5-1.el6 will be installed
---> Package libgudev1.x86_64 0:147-2.40.el6 will be installed
---> Package liboil.x86_64 0:0.3.16-4.1.el6 will be installed
---> Package libtasn1.x86_64 0:2.3-3.el6_2.1 will be installed
---> Package libtheora.x86_64 1:1.1.0-2.el6 will be installed
---> Package libvisual.x86_64 0:0.4.0-9.1.el6 will be installed
---> Package openjpeg-libs.x86_64 0:1.3-7.el6 will be installed
---> Package poppler.x86_64 0:0.12.4-3.el6_0.1 will be installed
--> Processing Dependency: poppler-data >= 0.4.0 for package: poppler-0.12.4-3.el6_0.1.x86_64
---> Package xorg-x11-font-utils.x86_64 1:7.2-11.el6 will be installed
--> Processing Dependency: libfontenc.so.1()(64bit) for package: 1:xorg-x11-font-utils-7.2-11.el6.x86_64
--> Processing Dependency: libXfont.so.1()(64bit) for package: 1:xorg-x11-font-utils-7.2-11.el6.x86_64
--> Running transaction check
---> Package libXfont.x86_64 0:1.4.1-2.el6_1 will be installed
---> Package libfontenc.x86_64 0:1.0.5-2.el6 will be installed
---> Package pkgconfig.x86_64 1:0.23-9.1.el6 will be installed
---> Package poppler-data.noarch 0:0.4.0-1.el6 will be installed
---> Package xml-common.noarch 0:0.6.3-32.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                     Arch   Version                 Repository     Size
================================================================================
Installing:
 emi-voms-mysql              x86_64 1.0.1-1.el6             EMI-2-RC-base 2.3 k
Installing for dependencies:
 PyXML                       x86_64 0.8.4-19.el6            core          892 k
 alsa-lib                    x86_64 1.0.22-3.el6            core          369 k
 at                          x86_64 3.1.10-43.el6           core           59 k
 atk                         x86_64 1.28.0-2.el6            core          190 k
 audit-libs-python           x86_64 2.1.3-3.el6             core           57 k
 avahi-libs                  x86_64 0.6.25-11.el6           core           53 k
 axis                        noarch 1.2.1-7.2.el6           core          1.5 M
 bc                          x86_64 1.06.95-1.el6           core          109 k
 bcel                        x86_64 5.2-7.2.el6             core          1.4 M
 bdii                        noarch 5.2.10-1.el6            EMI-2-RC-base  22 k
 bouncycastle                noarch 1.46-1.el6              epel          2.3 M
 cairo                       x86_64 1.8.8-3.1.el6           core          308 k
 cdparanoia-libs             x86_64 10.2-5.1.el6            core           47 k
 classpathx-jaf              x86_64 1.0-15.4.el6            core           99 k
 classpathx-mail             noarch 1.1.1-9.4.el6           core          478 k
 cups                        x86_64 1:1.4.2-44.el6          core          2.3 M
 cups-libs                   x86_64 1:1.4.2-44.el6          core          314 k
 cvs                         x86_64 1.11.23-11.el6_2.1      sl-security   711 k
 dbus                        x86_64 1:1.2.24-5.el6_1        core          206 k
 ecj                         x86_64 1:3.4.2-6.el6           core          2.8 M
 ed                          x86_64 1.1-3.3.el6             core           71 k
 emi-trustmanager            noarch 3.1.3-1.sl6             EMI-2-RC-base 249 k
 emi-trustmanager-tomcat     noarch 3.0.1-1.sl6             EMI-2-RC-base  28 k
 expect                      x86_64 5.44.1.15-2.el6         core          255 k
 fetch-crl                   noarch 3.0.8-1.el6             epel           45 k
 file                        x86_64 5.04-11.el6             core           44 k
 flac                        x86_64 1.2.1-6.1.el6           core          242 k
 fontconfig                  x86_64 2.8.0-3.el6             core          185 k
 foomatic                    x86_64 4.0.4-1.el6_1.1         core          250 k
 foomatic-db                 noarch 4.0-7.20091126.el6      core          979 k
 foomatic-db-filesystem      noarch 4.0-7.20091126.el6      core          3.4 k
 foomatic-db-ppds            noarch 4.0-7.20091126.el6      core           19 M
 freetype                    x86_64 2.3.11-6.el6_2.9        sl-security   358 k
 gettext                     x86_64 0.17-16.el6             core          1.8 M
 ghostscript                 x86_64 8.70-11.el6_2.6         sl-security   4.4 M
 ghostscript-fonts           noarch 5.50-23.1.el6           core          749 k
 giflib                      x86_64 4.1.6-3.1.el6           core           36 k
 glite-info-provider-service noarch 1.8.1-2.el6             EMI-2-RC-base  55 k
 glite-yaim-bdii             noarch 4.3.9-1.el6             EMI-2-RC-base  10 k
 glite-yaim-core             noarch 5.1.0-1.sl6             EMI-2-RC-base 102 k
 glue-schema                 noarch 2.0.8-1.el6             EMI-2-RC-base  31 k
 gnutls                      x86_64 2.8.5-4.el6_2.2         sl-security   341 k
 gstreamer                   x86_64 0.10.29-1.el6           core          763 k
 gstreamer-plugins-base      x86_64 0.10.29-1.el6           core          942 k
 gstreamer-tools             x86_64 0.10.29-1.el6           core           22 k
 gtk2                        x86_64 2.18.9-6.el6            core          3.3 M
 hicolor-icon-theme          noarch 0.11-1.1.el6            core           39 k
 iso-codes                   noarch 3.16-2.el6              core          2.4 M
 jakarta-commons-collections noarch 3.2.1-3.4.el6           core          522 k
 jakarta-commons-daemon      x86_64 1:1.0.1-8.9.el6         core           44 k
 jakarta-commons-dbcp        noarch 1.2.1-13.8.el6          core          115 k
 jakarta-commons-discovery   noarch 1:0.4-5.4.el6           core           72 k
 jakarta-commons-httpclient  x86_64 1:3.1-0.6.el6           core          579 k
 jakarta-commons-logging     noarch 1.0.4-10.el6            core           51 k
 jakarta-commons-pool        x86_64 1.3-12.7.el6            core          121 k
 jasper-libs                 x86_64 1.900.1-15.el6_1.1      sl-security   135 k
 java-1.5.0-gcj              x86_64 1.5.0.0-29.1.el6        core          138 k
 java-1.6.0-openjdk          x86_64 1:1.6.0.0-1.43.1.10.6.el6_2
                                                            sl-security    25 M
 java_cup                    x86_64 1:0.10k-5.el6           core          196 k
 jline                       noarch 0.9.94-0.8.el6          core           85 k
 jpackage-utils              noarch 1.7.5-3.12.el6          core           58 k
 lcms-libs                   x86_64 1.19-1.el6              core           99 k
 libICE                      x86_64 1.0.6-1.el6             core           52 k
 libSM                       x86_64 1.1.0-7.1.el6           core           25 k
 libX11                      x86_64 1.3-2.el6               core          581 k
 libX11-common               noarch 1.3-2.el6               core          187 k
 libXau                      x86_64 1.0.5-1.el6             core           21 k
 libXcomposite               x86_64 0.4.1-2.el6             core           16 k
 libXcursor                  x86_64 1.1.10-2.el6            core           31 k
 libXdamage                  x86_64 1.1.2-1.el6             core           15 k
 libXext                     x86_64 1.1-3.el6               core           32 k
 libXfixes                   x86_64 4.0.4-1.el6             core           19 k
 libXfont                    x86_64 1.4.1-2.el6_1           core          127 k
 libXft                      x86_64 2.1.13-4.1.el6          core           48 k
 libXi                       x86_64 1.3-3.el6               core           31 k
 libXinerama                 x86_64 1.1-1.el6               core           14 k
 libXrandr                   x86_64 1.3.0-4.el6             core           29 k
 libXrender                  x86_64 0.9.5-1.el6             core           26 k
 libXt                       x86_64 1.0.7-1.el6             core          173 k
 libXtst                     x86_64 1.0.99.2-3.el6          core           21 k
 libXv                       x86_64 1.0.5-1.el6             core           20 k
 libXxf86vm                  x86_64 1.1.0-1.el6             core           18 k
 libart_lgpl                 x86_64 2.3.20-5.1.el6          core           64 k
 libasyncns                  x86_64 0.8-1.1.el6             core           23 k
 libcgroup                   x86_64 0.37-3.el6              core          103 k
 libfontenc                  x86_64 1.0.5-2.el6             core           24 k
 libgcj                      x86_64 4.4.6-3.el6             core           19 M
 libgomp                     x86_64 4.4.6-3.el6             core          114 k
 libgudev1                   x86_64 147-2.40.el6            core           58 k
 libjpeg                     x86_64 6b-46.el6               core          133 k
 libmng                      x86_64 1.0.10-4.1.el6          core          164 k
 libogg                      x86_64 2:1.1.4-2.1.el6         core           20 k
 liboil                      x86_64 0.3.16-4.1.el6          core          120 k
 libpng                      x86_64 2:1.2.49-1.el6_2        sl-security   181 k
 libselinux-python           x86_64 2.0.94-5.2.el6          core          201 k
 libsemanage-python          x86_64 2.0.43-4.1.el6          core           80 k
 libsndfile                  x86_64 1.0.20-5.el6            core          232 k
 libtasn1                    x86_64 2.3-3.el6_2.1           sl-security   237 k
 libthai                     x86_64 0.1.12-3.el6            core          182 k
 libtheora                   x86_64 1:1.1.0-2.el6           core          128 k
 libtiff                     x86_64 3.9.4-5.el6_2           sl-security   340 k
 libtool-ltdl                x86_64 2.2.6-15.5.el6          core           43 k
 libvisual                   x86_64 0.4.0-9.1.el6           core          134 k
 libvorbis                   x86_64 1:1.2.3-4.el6_2.1       sl-security   167 k
 libxcb                      x86_64 1.5-1.el6               core           99 k
 log4j                       x86_64 1.2.14-6.4.el6          core          678 k
 mailcap                     noarch 2.1.31-2.el6            core           26 k
 make                        x86_64 1:3.81-19.el6           core          388 k
 man                         x86_64 1.6f-29.el6             core          262 k
 mesa-dri-drivers            x86_64 7.11-3.el6              core           11 M
 mesa-libGL                  x86_64 7.11-3.el6              core          144 k
 mesa-libGLU                 x86_64 7.11-3.el6              core          200 k
 mx4j                        noarch 1:3.0.1-9.13.el6        core          1.1 M
 mysql                       x86_64 5.1.61-1.el6_2.1        sl-security   881 k
 mysql-server                x86_64 5.1.61-1.el6_2.1        sl-security   8.1 M
 openjpeg-libs               x86_64 1.3-7.el6               core           58 k
 openldap-clients            x86_64 2.4.23-20.el6           core          160 k
 openldap-servers            x86_64 2.4.23-20.el6           core          2.0 M
 pango                       x86_64 1.28.1-3.el6_0.5        core          350 k
 patch                       x86_64 2.6-6.el6               core           90 k
 pax                         x86_64 3.4-10.1.el6            core           68 k
 perl-CGI                    x86_64 3.51-119.el6_1.1        core          205 k
 perl-Compress-Raw-Zlib      x86_64 2.023-119.el6_1.1       core           66 k
 perl-Compress-Zlib          x86_64 2.020-119.el6_1.1       core           42 k
 perl-DBD-MySQL              x86_64 4.013-3.el6             core          133 k
 perl-DBI                    x86_64 1.609-4.el6             core          704 k
 perl-ExtUtils-MakeMaker     x86_64 6.55-119.el6_1.1        core          289 k
 perl-ExtUtils-ParseXS       x86_64 1:2.2003.0-119.el6_1.1  core           41 k
 perl-HTML-Parser            x86_64 3.64-2.el6              core          108 k
 perl-HTML-Tagset            noarch 3.20-4.el6              core           15 k
 perl-IO-Compress-Base       x86_64 2.020-119.el6_1.1       core           65 k
 perl-IO-Compress-Zlib       x86_64 2.020-119.el6_1.1       core          132 k
 perl-Test-Harness           x86_64 3.17-119.el6_1.1        core          228 k
 perl-Test-Simple            x86_64 0.92-119.el6_1.1        core          109 k
 perl-URI                    noarch 1.40-2.el6              core          116 k
 perl-devel                  x86_64 4:5.10.1-119.el6_1.1    core          419 k
 perl-libwww-perl            noarch 5.833-2.el6             core          386 k
 phonon-backend-gstreamer    x86_64 1:4.6.2-20.el6          core          125 k
 pixman                      x86_64 0.18.4-1.el6_0.1        core          146 k
 pkgconfig                   x86_64 1:0.23-9.1.el6          core           69 k
 policycoreutils-python      x86_64 2.0.83-19.18.el6        core          336 k
 poppler                     x86_64 0.12.4-3.el6_0.1        core          556 k
 poppler-data                noarch 0.4.0-1.el6             core          2.2 M
 poppler-utils               x86_64 0.12.4-3.el6_0.1        core           72 k
 portreserve                 x86_64 0.0.4-4.el6_1.1         core           21 k
 pulseaudio-libs             x86_64 0.9.21-13.el6           core          461 k
 python-ZSI                  noarch 2.0-6.el6               epel          421 k
 python-simplejson           x86_64 2.0.9-3.1.el6           core          126 k
 qt                          x86_64 1:4.6.2-20.el6          core          4.0 M
 qt-sqlite                   x86_64 1:4.6.2-20.el6          core           49 k
 qt-x11                      x86_64 1:4.6.2-20.el6          core           12 M
 qt3                         x86_64 3.3.8b-30.el6           core          3.5 M
 redhat-lsb                  x86_64 4.0-3.el6               core           23 k
 redhat-lsb-graphics         x86_64 4.0-3.el6               core           11 k
 redhat-lsb-printing         x86_64 4.0-3.el6               core          9.6 k
 regexp                      x86_64 1.5-4.4.el6             core          104 k
 rhino                       noarch 1.7-0.7.r2.2.el6        core          777 k
 setools-libs                x86_64 3.3.7-4.el6             core          399 k
 setools-libs-python         x86_64 3.3.7-4.el6             core          221 k
 sinjdoc                     x86_64 0.5-9.1.el6             core          704 k
 tcl                         x86_64 1:8.5.7-6.el6           core          1.9 M
 time                        x86_64 1.7-37.1.el6            core           25 k
 tmpwatch                    x86_64 2.9.16-4.el6            core           30 k
 tomcat6                     noarch 6.0.24-36.el6_2         sl-security    86 k
 tomcat6-el-2.1-api          noarch 6.0.24-36.el6_2         sl-security    41 k
 tomcat6-jsp-2.1-api         noarch 6.0.24-36.el6_2         sl-security    78 k
 tomcat6-lib                 noarch 6.0.24-36.el6_2         sl-security   2.8 M
 tomcat6-servlet-2.5-api     noarch 6.0.24-36.el6_2         sl-security    92 k
 tzdata-java                 noarch 2012b-3.el6             sl-security   153 k
 urw-fonts                   noarch 2.4-10.el6              core          3.0 M
 voms                        x86_64 2.0.8-1.el6             EMI-2-RC-base 136 k
 voms-admin-client           noarch 2.0.17-1.el6            EMI-2-RC-base  67 k
 voms-admin-server           noarch 2.7.0-1.el6             EMI-2-RC-base  60 M
 voms-mysql-plugin           x86_64 3.1.6-1.el6             EMI-2-RC-base  24 k
 voms-server                 x86_64 2.0.8-1.el6             EMI-2-RC-base 170 k
 wsdl4j                      noarch 1.5.2-7.8.el6           core          156 k
 xml-common                  noarch 0.6.3-32.el6            core          8.4 k
 xml-commons-apis            x86_64 1.3.04-3.6.el6          core          438 k
 xml-commons-resolver        x86_64 1.1-4.18.el6            core          144 k
 xorg-x11-font-utils         x86_64 1:7.2-11.el6            core           74 k
 xz                          x86_64 4.999.9-0.3.beta.20091007git.el6
                                                            core          136 k
 xz-lzma-compat              x86_64 4.999.9-0.3.beta.20091007git.el6
                                                            core           15 k
 yaim-voms                   noarch 1.1.1-1.el6             EMI-2-RC-base  23 k
 zip                         x86_64 3.0-1.el6               core          259 k
Updating for dependencies:
 mysql-libs                  x86_64 5.1.61-1.el6_2.1        sl-security   1.2 M

Transaction Summary
================================================================================
Install     185 Package(s)
Upgrade       1 Package(s)

Total download size: 227 M
Downloading Packages:
--------------------------------------------------------------------------------
Total                                           2.4 MB/s | 227 MB     01:35     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction

  Installing : freetype-2.3.11-6.el6_2.9.x86_64                           1/187 

  Installing : fontconfig-2.8.0-3.el6.x86_64                              2/187 

  Installing : libjpeg-6b-46.el6.x86_64                                   3/187 

  Installing : 2:libpng-1.2.49-1.el6_2.x86_64                             4/187 

  Installing : libICE-1.0.6-1.el6.x86_64                                  5/187 

  Installing : jpackage-utils-1.7.5-3.12.el6.noarch                       6/187 

  Installing : libSM-1.1.0-7.1.el6.x86_64                                 7/187 

  Installing : alsa-lib-1.0.22-3.el6.x86_64                               8/187 

  Installing : 2:libogg-1.1.4-2.1.el6.x86_64                              9/187 

  Installing : jakarta-commons-logging-1.0.4-10.el6.noarch               10/187 

  Installing : 1:qt-4.6.2-20.el6.x86_64                                  11/187 

  Updating   : mysql-libs-5.1.61-1.el6_2.1.x86_64                        12/187 

  Installing : libtiff-3.9.4-5.el6_2.x86_64                              13/187 

  Installing : jakarta-commons-collections-3.2.1-3.4.el6.noarch          14/187 

  Installing : 1:make-3.81-19.el6.x86_64                                 15/187 

  Installing : lcms-libs-1.19-1.el6.x86_64                               16/187 

  Installing : atk-1.28.0-2.el6.x86_64                                   17/187 

  Installing : libmng-1.0.10-4.1.el6.x86_64                              18/187 

  Installing : 1:libvorbis-1.2.3-4.el6_2.1.x86_64                        19/187 

  Installing : jasper-libs-1.900.1-15.el6_1.1.x86_64                     20/187 

  Installing : avahi-libs-0.6.25-11.el6.x86_64                           21/187 

  Installing : libfontenc-1.0.5-2.el6.x86_64                             22/187 

  Installing : perl-IO-Compress-Base-2.020-119.el6_1.1.x86_64            23/187 

  Installing : foomatic-db-filesystem-4.0-7.20091126.el6.noarch          24/187 

  Installing : perl-DBI-1.609-4.el6.x86_64                               25/187 

  Installing : 1:pkgconfig-0.23-9.1.el6.x86_64                           26/187 

  Installing : perl-Compress-Raw-Zlib-2.023-119.el6_1.1.x86_64           27/187 

  Installing : PyXML-0.8.4-19.el6.x86_64                                 28/187 

  Installing : openjpeg-libs-1.3-7.el6.x86_64                            29/187 

  Installing : tomcat6-servlet-2.5-api-6.0.24-36.el6_2.noarch            30/187 

  Installing : tomcat6-jsp-2.1-api-6.0.24-36.el6_2.noarch                31/187 

  Installing : python-ZSI-2.0-6.el6.noarch                               32/187 

  Installing : perl-IO-Compress-Zlib-2.020-119.el6_1.1.x86_64            33/187 

  Installing : perl-Compress-Zlib-2.020-119.el6_1.1.x86_64               34/187 

  Installing : gstreamer-tools-0.10.29-1.el6.x86_64                      35/187 

  Installing : gstreamer-0.10.29-1.el6.x86_64                            36/187 

  Installing : perl-DBD-MySQL-4.013-3.el6.x86_64                         37/187 

  Installing : libXfont-1.4.1-2.el6_1.x86_64                             38/187 

  Installing : 1:xorg-x11-font-utils-7.2-11.el6.x86_64                   39/187 

  Installing : ghostscript-fonts-5.50-23.1.el6.noarch                    40/187 

  Installing : mysql-5.1.61-1.el6_2.1.x86_64                             41/187 

  Installing : mysql-server-5.1.61-1.el6_2.1.x86_64                      42/187 

  Installing : 1:qt-sqlite-4.6.2-20.el6.x86_64                           43/187 

  Installing : 1:jakarta-commons-discovery-0.4-5.4.el6.noarch            44/187 

  Installing : flac-1.2.1-6.1.el6.x86_64                                 45/187 

  Installing : libsndfile-1.0.20-5.el6.x86_64                            46/187 

  Installing : 1:libtheora-1.1.0-2.el6.x86_64                            47/187 

  Installing : urw-fonts-2.4-10.el6.noarch                               48/187 

  Installing : perl-Test-Harness-3.17-119.el6_1.1.x86_64                 49/187 

  Installing : perl-ExtUtils-MakeMaker-6.55-119.el6_1.1.x86_64           50/187 

  Installing : 4:perl-devel-5.10.1-119.el6_1.1.x86_64                    51/187 

  Installing : 1:perl-ExtUtils-ParseXS-2.2003.0-119.el6_1.1.x86_64       52/187 

  Installing : perl-Test-Simple-0.92-119.el6_1.1.x86_64                  53/187 

  Installing : cvs-1.11.23-11.el6_2.1.x86_64                             54/187 

  Installing : glite-info-provider-service-1.8.1-2.el6.noarch            55/187 

  Installing : 1:dbus-1.2.24-5.el6_1.x86_64                              56/187 

  Installing : xml-common-0.6.3-32.el6.noarch                            57/187 

  Installing : iso-codes-3.16-2.el6.noarch                               58/187 

  Installing : portreserve-0.0.4-4.el6_1.1.x86_64                        59/187 

  Installing : glue-schema-2.0.8-1.el6.noarch                            60/187 

  Installing : mailcap-2.1.31-2.el6.noarch                               61/187 

  Installing : file-5.04-11.el6.x86_64                                   62/187 

  Installing : perl-URI-1.40-2.el6.noarch                                63/187 

  Installing : libvisual-0.4.0-9.1.el6.x86_64                            64/187 

  Installing : jline-0.9.94-0.8.el6.noarch                               65/187 

  Installing : rhino-1.7-0.7.r2.2.el6.noarch                             66/187 

  Installing : python-simplejson-2.0.9-3.1.el6.x86_64                    67/187 

  Installing : voms-admin-client-2.0.17-1.el6.noarch                     68/187 

  Installing : tzdata-java-2012b-3.el6.noarch                            69/187 

  Installing : libXau-1.0.5-1.el6.x86_64                                 70/187 

  Installing : libxcb-1.5-1.el6.x86_64                                   71/187 

  Installing : openldap-clients-2.4.23-20.el6.x86_64                     72/187 

  Installing : libgomp-4.4.6-3.el6.x86_64                                73/187 

  Installing : gettext-0.17-16.el6.x86_64                                74/187 

  Installing : mesa-dri-drivers-7.11-3.el6.x86_64                        75/187 

  Installing : libtasn1-2.3-3.el6_2.1.x86_64                             76/187 

  Installing : gnutls-2.8.5-4.el6_2.2.x86_64                             77/187 

  Installing : 1:cups-libs-1.4.2-44.el6.x86_64                           78/187 

  Installing : patch-2.6-6.el6.x86_64                                    79/187 

  Installing : time-1.7-37.1.el6.x86_64                                  80/187 

  Installing : at-3.1.10-43.el6.x86_64                                   81/187 

  Installing : audit-libs-python-2.1.3-3.el6.x86_64                      82/187 

  Installing : libgudev1-147-2.40.el6.x86_64                             83/187 

  Installing : zip-3.0-1.el6.x86_64                                      84/187 

  Installing : voms-2.0.8-1.el6.x86_64                                   85/187 

  Installing : voms-server-2.0.8-1.el6.x86_64                            86/187 

  Installing : voms-mysql-plugin-3.1.6-1.el6.x86_64                      87/187 

  Installing : libart_lgpl-2.3.20-5.1.el6.x86_64                         88/187 

  Installing : 1:tcl-8.5.7-6.el6.x86_64                                  89/187 

  Installing : expect-5.44.1.15-2.el6.x86_64                             90/187 

  Installing : glite-yaim-bdii-4.3.9-1.el6.noarch                        91/187 

  Installing : liboil-0.3.16-4.1.el6.x86_64                              92/187 

  Installing : bc-1.06.95-1.el6.x86_64                                   93/187 

  Installing : tmpwatch-2.9.16-4.el6.x86_64                              94/187 

  Installing : perl-HTML-Tagset-3.20-4.el6.noarch                        95/187 

  Installing : perl-HTML-Parser-3.64-2.el6.x86_64                        96/187 

  Installing : perl-libwww-perl-5.833-2.el6.noarch                       97/187 

  Installing : fetch-crl-3.0.8-1.el6.noarch                              98/187 

  Installing : libtool-ltdl-2.2.6-15.5.el6.x86_64                        99/187 

  Installing : openldap-servers-2.4.23-20.el6.x86_64                    100/187 

  Installing : poppler-data-0.4.0-1.el6.noarch                          101/187 

  Installing : poppler-0.12.4-3.el6_0.1.x86_64                          102/187 

  Installing : poppler-utils-0.12.4-3.el6_0.1.x86_64                    103/187 

  Installing : 1:cups-1.4.2-44.el6.x86_64                               104/187 

  Installing : foomatic-db-ppds-4.0-7.20091126.el6.noarch               105/187 

  Installing : foomatic-db-4.0-7.20091126.el6.noarch                    106/187 

  Installing : setools-libs-3.3.7-4.el6.x86_64                          107/187 

  Installing : setools-libs-python-3.3.7-4.el6.x86_64                   108/187 

  Installing : libasyncns-0.8-1.1.el6.x86_64                            109/187 

  Installing : pixman-0.18.4-1.el6_0.1.x86_64                           110/187 

  Installing : xz-4.999.9-0.3.beta.20091007git.el6.x86_64               111/187 

  Installing : xz-lzma-compat-4.999.9-0.3.beta.20091007git.el6.x86_64   112/187 

  Installing : man-1.6f-29.el6.x86_64                                   113/187 

  Installing : pax-3.4-10.1.el6.x86_64                                  114/187 

  Installing : libsemanage-python-2.0.43-4.1.el6.x86_64                 115/187 

  Installing : ed-1.1-3.3.el6.x86_64                                    116/187 

  Installing : cdparanoia-libs-10.2-5.1.el6.x86_64                      117/187 

  Installing : perl-CGI-3.51-119.el6_1.1.x86_64                         118/187 

  Installing : libcgroup-0.37-3.el6.x86_64                              119/187 

  Installing : hicolor-icon-theme-0.11-1.1.el6.noarch                   120/187 

  Installing : libselinux-python-2.0.94-5.2.el6.x86_64                  121/187 

  Installing : policycoreutils-python-2.0.83-19.18.el6.x86_64           122/187 

  Installing : bdii-5.2.10-1.el6.noarch                                 123/187 

  Installing : libthai-0.1.12-3.el6.x86_64                              124/187 

  Installing : libX11-common-1.3-2.el6.noarch                           125/187 

  Installing : libX11-1.3-2.el6.x86_64                                  126/187 

  Installing : libXext-1.1-3.el6.x86_64                                 127/187 

  Installing : libXrender-0.9.5-1.el6.x86_64                            128/187 

  Installing : cairo-1.8.8-3.1.el6.x86_64                               129/187 

  Installing : libXi-1.3-3.el6.x86_64                                   130/187 

  Installing : libXfixes-4.0.4-1.el6.x86_64                             131/187 

  Installing : libXtst-1.0.99.2-3.el6.x86_64                            132/187 

  Installing : libXrandr-1.3.0-4.el6.x86_64                             133/187 

  Installing : libXcursor-1.1.10-2.el6.x86_64                           134/187 

  Installing : libXft-2.1.13-4.1.el6.x86_64                             135/187 

  Installing : pango-1.28.1-3.el6_0.5.x86_64                            136/187 

  Installing : libXinerama-1.1-1.el6.x86_64                             137/187 

  Installing : libXdamage-1.1.2-1.el6.x86_64                            138/187 

  Installing : libXt-1.0.7-1.el6.x86_64                                 139/187 

  Installing : ghostscript-8.70-11.el6_2.6.x86_64                       140/187 

  Installing : foomatic-4.0.4-1.el6_1.1.x86_64                          141/187 

  Installing : redhat-lsb-printing-4.0-3.el6.x86_64                     142/187 

  Installing : qt3-3.3.8b-30.el6.x86_64                                 143/187 

  Installing : pulseaudio-libs-0.9.21-13.el6.x86_64                     144/187 

  Installing : libXcomposite-0.4.1-2.el6.x86_64                         145/187 

  Installing : gtk2-2.18.9-6.el6.x86_64                                 146/187 

  Installing : libgcj-4.4.6-3.el6.x86_64                                147/187 

  Installing : java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64                   148/187 

  Installing : 1:java_cup-0.10k-5.el6.x86_64                            149/187 

  Installing : sinjdoc-0.5-9.1.el6.x86_64                               150/187 

  Installing : classpathx-jaf-1.0-15.4.el6.x86_64                       151/187 

  Installing : jakarta-commons-pool-1.3-12.7.el6.x86_64                 152/187 

  Installing : xml-commons-apis-1.3.04-3.6.el6.x86_64                   153/187 

  Installing : log4j-1.2.14-6.4.el6.x86_64                              154/187 

  Installing : jakarta-commons-dbcp-1.2.1-13.8.el6.noarch               155/187 

  Installing : xml-commons-resolver-1.1-4.18.el6.x86_64                 156/187 

  Installing : 1:ecj-3.4.2-6.el6.x86_64                                 157/187 

  Installing : 1:jakarta-commons-httpclient-3.1-0.6.el6.x86_64          158/187 

  Installing : 1:jakarta-commons-daemon-1.0.1-8.9.el6.x86_64            159/187 

  Installing : libXv-1.0.5-1.el6.x86_64                                 160/187 

  Installing : gstreamer-plugins-base-0.10.29-1.el6.x86_64              161/187 

  Installing : libXxf86vm-1.1.0-1.el6.x86_64                            162/187 

  Installing : mesa-libGL-7.11-3.el6.x86_64                             163/187 

  Installing : mesa-libGLU-7.11-3.el6.x86_64                            164/187 

  Installing : 1:qt-x11-4.6.2-20.el6.x86_64                             165/187 

  Installing : 1:phonon-backend-gstreamer-4.6.2-20.el6.x86_64           166/187 

  Installing : redhat-lsb-graphics-4.0-3.el6.x86_64                     167/187 

  Installing : redhat-lsb-4.0-3.el6.x86_64                              168/187 

  Installing : glite-yaim-core-5.1.0-1.sl6.noarch                       169/187 

  Installing : yaim-voms-1.1.1-1.el6.noarch                             170/187 

  Installing : giflib-4.1.6-3.1.el6.x86_64                              171/187 

  Installing : 1:java-1.6.0-openjdk-1.6.0.0-1.43.1.10.6.el6_2.x86_64    172/187 

  Installing : classpathx-mail-1.1.1-9.4.el6.noarch                     173/187 

  Installing : emi-trustmanager-3.1.3-1.sl6.noarch                      174/187 

  Installing : bouncycastle-1.46-1.el6.noarch                           175/187 

  Installing : emi-trustmanager-tomcat-3.0.1-1.sl6.noarch               176/187 

  Installing : regexp-1.5-4.4.el6.x86_64                                177/187 

  Installing : bcel-5.2-7.2.el6.x86_64                                  178/187 

  Installing : wsdl4j-1.5.2-7.8.el6.noarch                              179/187 

  Installing : axis-1.2.1-7.2.el6.noarch                                180/187 

  Installing : 1:mx4j-3.0.1-9.13.el6.noarch                             181/187 

  Installing : tomcat6-el-2.1-api-6.0.24-36.el6_2.noarch                182/187 

  Installing : tomcat6-lib-6.0.24-36.el6_2.noarch                       183/187 

  Installing : tomcat6-6.0.24-36.el6_2.noarch                           184/187 

  Installing : voms-admin-server-2.7.0-1.el6.noarch                     185/187 

  Installing : emi-voms-mysql-1.0.1-1.el6.x86_64                        186/187 

  Cleanup    : mysql-libs-5.1.52-1.el6_0.1.x86_64                       187/187 

Installed:
  emi-voms-mysql.x86_64 0:1.0.1-1.el6                                           

Dependency Installed:
  PyXML.x86_64 0:0.8.4-19.el6                                                   
  alsa-lib.x86_64 0:1.0.22-3.el6                                                
  at.x86_64 0:3.1.10-43.el6                                                     
  atk.x86_64 0:1.28.0-2.el6                                                     
  audit-libs-python.x86_64 0:2.1.3-3.el6                                        
  avahi-libs.x86_64 0:0.6.25-11.el6                                             
  axis.noarch 0:1.2.1-7.2.el6                                                   
  bc.x86_64 0:1.06.95-1.el6                                                     
  bcel.x86_64 0:5.2-7.2.el6                                                     
  bdii.noarch 0:5.2.10-1.el6                                                    
  bouncycastle.noarch 0:1.46-1.el6                                              
  cairo.x86_64 0:1.8.8-3.1.el6                                                  
  cdparanoia-libs.x86_64 0:10.2-5.1.el6                                         
  classpathx-jaf.x86_64 0:1.0-15.4.el6                                          
  classpathx-mail.noarch 0:1.1.1-9.4.el6                                        
  cups.x86_64 1:1.4.2-44.el6                                                    
  cups-libs.x86_64 1:1.4.2-44.el6                                               
  cvs.x86_64 0:1.11.23-11.el6_2.1                                               
  dbus.x86_64 1:1.2.24-5.el6_1                                                  
  ecj.x86_64 1:3.4.2-6.el6                                                      
  ed.x86_64 0:1.1-3.3.el6                                                       
  emi-trustmanager.noarch 0:3.1.3-1.sl6                                         
  emi-trustmanager-tomcat.noarch 0:3.0.1-1.sl6                                  
  expect.x86_64 0:5.44.1.15-2.el6                                               
  fetch-crl.noarch 0:3.0.8-1.el6                                                
  file.x86_64 0:5.04-11.el6                                                     
  flac.x86_64 0:1.2.1-6.1.el6                                                   
  fontconfig.x86_64 0:2.8.0-3.el6                                               
  foomatic.x86_64 0:4.0.4-1.el6_1.1                                             
  foomatic-db.noarch 0:4.0-7.20091126.el6                                       
  foomatic-db-filesystem.noarch 0:4.0-7.20091126.el6                            
  foomatic-db-ppds.noarch 0:4.0-7.20091126.el6                                  
  freetype.x86_64 0:2.3.11-6.el6_2.9                                            
  gettext.x86_64 0:0.17-16.el6                                                  
  ghostscript.x86_64 0:8.70-11.el6_2.6                                          
  ghostscript-fonts.noarch 0:5.50-23.1.el6                                      
  giflib.x86_64 0:4.1.6-3.1.el6                                                 
  glite-info-provider-service.noarch 0:1.8.1-2.el6                              
  glite-yaim-bdii.noarch 0:4.3.9-1.el6                                          
  glite-yaim-core.noarch 0:5.1.0-1.sl6                                          
  glue-schema.noarch 0:2.0.8-1.el6                                              
  gnutls.x86_64 0:2.8.5-4.el6_2.2                                               
  gstreamer.x86_64 0:0.10.29-1.el6                                              
  gstreamer-plugins-base.x86_64 0:0.10.29-1.el6                                 
  gstreamer-tools.x86_64 0:0.10.29-1.el6                                        
  gtk2.x86_64 0:2.18.9-6.el6                                                    
  hicolor-icon-theme.noarch 0:0.11-1.1.el6                                      
  iso-codes.noarch 0:3.16-2.el6                                                 
  jakarta-commons-collections.noarch 0:3.2.1-3.4.el6                            
  jakarta-commons-daemon.x86_64 1:1.0.1-8.9.el6                                 
  jakarta-commons-dbcp.noarch 0:1.2.1-13.8.el6                                  
  jakarta-commons-discovery.noarch 1:0.4-5.4.el6                                
  jakarta-commons-httpclient.x86_64 1:3.1-0.6.el6                               
  jakarta-commons-logging.noarch 0:1.0.4-10.el6                                 
  jakarta-commons-pool.x86_64 0:1.3-12.7.el6                                    
  jasper-libs.x86_64 0:1.900.1-15.el6_1.1                                       
  java-1.5.0-gcj.x86_64 0:1.5.0.0-29.1.el6                                      
  java-1.6.0-openjdk.x86_64 1:1.6.0.0-1.43.1.10.6.el6_2                         
  java_cup.x86_64 1:0.10k-5.el6                                                 
  jline.noarch 0:0.9.94-0.8.el6                                                 
  jpackage-utils.noarch 0:1.7.5-3.12.el6                                        
  lcms-libs.x86_64 0:1.19-1.el6                                                 
  libICE.x86_64 0:1.0.6-1.el6                                                   
  libSM.x86_64 0:1.1.0-7.1.el6                                                  
  libX11.x86_64 0:1.3-2.el6                                                     
  libX11-common.noarch 0:1.3-2.el6                                              
  libXau.x86_64 0:1.0.5-1.el6                                                   
  libXcomposite.x86_64 0:0.4.1-2.el6                                            
  libXcursor.x86_64 0:1.1.10-2.el6                                              
  libXdamage.x86_64 0:1.1.2-1.el6                                               
  libXext.x86_64 0:1.1-3.el6                                                    
  libXfixes.x86_64 0:4.0.4-1.el6                                                
  libXfont.x86_64 0:1.4.1-2.el6_1                                               
  libXft.x86_64 0:2.1.13-4.1.el6                                                
  libXi.x86_64 0:1.3-3.el6                                                      
  libXinerama.x86_64 0:1.1-1.el6                                                
  libXrandr.x86_64 0:1.3.0-4.el6                                                
  libXrender.x86_64 0:0.9.5-1.el6                                               
  libXt.x86_64 0:1.0.7-1.el6                                                    
  libXtst.x86_64 0:1.0.99.2-3.el6                                               
  libXv.x86_64 0:1.0.5-1.el6                                                    
  libXxf86vm.x86_64 0:1.1.0-1.el6                                               
  libart_lgpl.x86_64 0:2.3.20-5.1.el6                                           
  libasyncns.x86_64 0:0.8-1.1.el6                                               
  libcgroup.x86_64 0:0.37-3.el6                                                 
  libfontenc.x86_64 0:1.0.5-2.el6                                               
  libgcj.x86_64 0:4.4.6-3.el6                                                   
  libgomp.x86_64 0:4.4.6-3.el6                                                  
  libgudev1.x86_64 0:147-2.40.el6                                               
  libjpeg.x86_64 0:6b-46.el6                                                    
  libmng.x86_64 0:1.0.10-4.1.el6                                                
  libogg.x86_64 2:1.1.4-2.1.el6                                                 
  liboil.x86_64 0:0.3.16-4.1.el6                                                
  libpng.x86_64 2:1.2.49-1.el6_2                                                
  libselinux-python.x86_64 0:2.0.94-5.2.el6                                     
  libsemanage-python.x86_64 0:2.0.43-4.1.el6                                    
  libsndfile.x86_64 0:1.0.20-5.el6                                              
  libtasn1.x86_64 0:2.3-3.el6_2.1                                               
  libthai.x86_64 0:0.1.12-3.el6                                                 
  libtheora.x86_64 1:1.1.0-2.el6                                                
  libtiff.x86_64 0:3.9.4-5.el6_2                                                
  libtool-ltdl.x86_64 0:2.2.6-15.5.el6                                          
  libvisual.x86_64 0:0.4.0-9.1.el6                                              
  libvorbis.x86_64 1:1.2.3-4.el6_2.1                                            
  libxcb.x86_64 0:1.5-1.el6                                                     
  log4j.x86_64 0:1.2.14-6.4.el6                                                 
  mailcap.noarch 0:2.1.31-2.el6                                                 
  make.x86_64 1:3.81-19.el6                                                     
  man.x86_64 0:1.6f-29.el6                                                      
  mesa-dri-drivers.x86_64 0:7.11-3.el6                                          
  mesa-libGL.x86_64 0:7.11-3.el6                                                
  mesa-libGLU.x86_64 0:7.11-3.el6                                               
  mx4j.noarch 1:3.0.1-9.13.el6                                                  
  mysql.x86_64 0:5.1.61-1.el6_2.1                                               
  mysql-server.x86_64 0:5.1.61-1.el6_2.1                                        
  openjpeg-libs.x86_64 0:1.3-7.el6                                              
  openldap-clients.x86_64 0:2.4.23-20.el6                                       
  openldap-servers.x86_64 0:2.4.23-20.el6                                       
  pango.x86_64 0:1.28.1-3.el6_0.5                                               
  patch.x86_64 0:2.6-6.el6                                                      
  pax.x86_64 0:3.4-10.1.el6                                                     
  perl-CGI.x86_64 0:3.51-119.el6_1.1                                            
  perl-Compress-Raw-Zlib.x86_64 0:2.023-119.el6_1.1                             
  perl-Compress-Zlib.x86_64 0:2.020-119.el6_1.1                                 
  perl-DBD-MySQL.x86_64 0:4.013-3.el6                                           
  perl-DBI.x86_64 0:1.609-4.el6                                                 
  perl-ExtUtils-MakeMaker.x86_64 0:6.55-119.el6_1.1                             
  perl-ExtUtils-ParseXS.x86_64 1:2.2003.0-119.el6_1.1                           
  perl-HTML-Parser.x86_64 0:3.64-2.el6                                          
  perl-HTML-Tagset.noarch 0:3.20-4.el6                                          
  perl-IO-Compress-Base.x86_64 0:2.020-119.el6_1.1                              
  perl-IO-Compress-Zlib.x86_64 0:2.020-119.el6_1.1                              
  perl-Test-Harness.x86_64 0:3.17-119.el6_1.1                                   
  perl-Test-Simple.x86_64 0:0.92-119.el6_1.1                                    
  perl-URI.noarch 0:1.40-2.el6                                                  
  perl-devel.x86_64 4:5.10.1-119.el6_1.1                                        
  perl-libwww-perl.noarch 0:5.833-2.el6                                         
  phonon-backend-gstreamer.x86_64 1:4.6.2-20.el6                                
  pixman.x86_64 0:0.18.4-1.el6_0.1                                              
  pkgconfig.x86_64 1:0.23-9.1.el6                                               
  policycoreutils-python.x86_64 0:2.0.83-19.18.el6                              
  poppler.x86_64 0:0.12.4-3.el6_0.1                                             
  poppler-data.noarch 0:0.4.0-1.el6                                             
  poppler-utils.x86_64 0:0.12.4-3.el6_0.1                                       
  portreserve.x86_64 0:0.0.4-4.el6_1.1                                          
  pulseaudio-libs.x86_64 0:0.9.21-13.el6                                        
  python-ZSI.noarch 0:2.0-6.el6                                                 
  python-simplejson.x86_64 0:2.0.9-3.1.el6                                      
  qt.x86_64 1:4.6.2-20.el6                                                      
  qt-sqlite.x86_64 1:4.6.2-20.el6                                               
  qt-x11.x86_64 1:4.6.2-20.el6                                                  
  qt3.x86_64 0:3.3.8b-30.el6                                                    
  redhat-lsb.x86_64 0:4.0-3.el6                                                 
  redhat-lsb-graphics.x86_64 0:4.0-3.el6                                        
  redhat-lsb-printing.x86_64 0:4.0-3.el6                                        
  regexp.x86_64 0:1.5-4.4.el6                                                   
  rhino.noarch 0:1.7-0.7.r2.2.el6                                               
  setools-libs.x86_64 0:3.3.7-4.el6                                             
  setools-libs-python.x86_64 0:3.3.7-4.el6                                      
  sinjdoc.x86_64 0:0.5-9.1.el6                                                  
  tcl.x86_64 1:8.5.7-6.el6                                                      
  time.x86_64 0:1.7-37.1.el6                                                    
  tmpwatch.x86_64 0:2.9.16-4.el6                                                
  tomcat6.noarch 0:6.0.24-36.el6_2                                              
  tomcat6-el-2.1-api.noarch 0:6.0.24-36.el6_2                                   
  tomcat6-jsp-2.1-api.noarch 0:6.0.24-36.el6_2                                  
  tomcat6-lib.noarch 0:6.0.24-36.el6_2                                          
  tomcat6-servlet-2.5-api.noarch 0:6.0.24-36.el6_2                              
  tzdata-java.noarch 0:2012b-3.el6                                              
  urw-fonts.noarch 0:2.4-10.el6                                                 
  voms.x86_64 0:2.0.8-1.el6                                                     
  voms-admin-client.noarch 0:2.0.17-1.el6                                       
  voms-admin-server.noarch 0:2.7.0-1.el6                                        
  voms-mysql-plugin.x86_64 0:3.1.6-1.el6                                        
  voms-server.x86_64 0:2.0.8-1.el6                                              
  wsdl4j.noarch 0:1.5.2-7.8.el6                                                 
  xml-common.noarch 0:0.6.3-32.el6                                              
  xml-commons-apis.x86_64 0:1.3.04-3.6.el6                                      
  xml-commons-resolver.x86_64 0:1.1-4.18.el6                                    
  xorg-x11-font-utils.x86_64 1:7.2-11.el6                                       
  xz.x86_64 0:4.999.9-0.3.beta.20091007git.el6                                  
  xz-lzma-compat.x86_64 0:4.999.9-0.3.beta.20091007git.el6                      
  yaim-voms.noarch 0:1.1.1-1.el6                                                
  zip.x86_64 0:3.0-1.el6                                                        

Dependency Updated:
  mysql-libs.x86_64 0:5.1.61-1.el6_2.1                                          

Complete!

VOMS configuration

SL5/x86_64

VOMS MySQL

 [root@emitestbed18 siteinfo]#  grep -v "#"  site-info.def services/*
site-info.def:SITE_NAME="voms-certification.cnaf.infn.it"
site-info.def:MYSQL_PASSWORD="XXXXXXXXXXXXX"
site-info.def:VOMS_DB_TYPE="mysql"
site-info.def:BDII_DELETE_DELAY=0
site-info.def:VOS="cert_SL5.mysql"
site-info.def:SITE_EMAIL="root@localhost"
site-info.def:SITE_LAT=42.0 
site-info.def:SITE_LONG=11.0
services/glite-bdii_site:SITE_NAME="emi-testbed-cnaf"
services/glite-bdii_site:SITE_DESC="EMI Integration Testbed site INFN-CNAF"
services/glite-bdii_site:SITE_SUPPORT_EMAIL="root@localhost"
services/glite-bdii_site:SITE_SECURITY_EMAIL="root@localhost"
services/glite-bdii_site:SITE_LOC="Bologna, Italy"
services/glite-bdii_site:SITE_WEB="http://www.italiangrid.it/"
services/glite-voms:VOMS_HOST=`hostname -f`
services/glite-voms:VOMS_DB_HOST=localhost
services/glite-voms:VO_CERT_SL5_MYSQL_VOMS_PORT=15000
services/glite-voms:VO_CERT_SL5_MYSQL_VOMS_DB_USER=cert_mysql_user
services/glite-voms:VO_CERT_SL5_MYSQL_VOMS_DB_PASS="XXXXXXXXX"
services/glite-voms:VO_CERT_SL5_MYSQL_VOMS_DB_NAME=voms_cert_mysql_db
services/glite-voms:VOMS_ADMIN_SMTP_HOST=postino.cnaf.infn.it
services/glite-voms:VOMS_ADMIN_MAIL=daniele.andreotti@cnaf.infn.it

SL6/x86_64

VOMS MySQL

  • SITE INFO DEF VARIABLES USED:

[root@cert-30 siteinfo]# grep -v "#"  site-info.def services/*
site-info.def:MYSQL_PASSWORD=XXXXX
site-info.def:SITE_NAME="voms-certification.cnaf.infn.it"
site-info.def:VOS="cert.mysql"
site-info.def:BDII_DELETE_DELAY=0
services/glite-voms:VOMS_HOST=cert-30.cnaf.infn.it
services/glite-voms:VOMS_DB_HOST='localhost'
services/glite-voms:VO_CERT_MYSQL_VOMS_PORT=15000
services/glite-voms:VO_CERT_MYSQL_VOMS_DB_USER=cert_mysql_user
services/glite-voms:VO_CERT_MYSQL_VOMS_DB_PASS=XXXXX
services/glite-voms:VO_CERT_MYSQL_VOMS_DB_NAME=voms_cert_mysql_db
services/glite-voms:VOMS_ADMIN_SMTP_HOST=iris.cnaf.infn.it
services/glite-voms:VOMS_ADMIN_MAIL=daniele.andreotti@cnaf.infn.it



[root@cert-30 siteinfo]# source /etc/profile.d/grid-env.sh

[root@cert-30 siteinfo]# voms-db-deploy.py add-admin --vo cert.mysql --cert /home/andreotti-bbr/usercert.pem 
Admin '/C=IT/O=INFN/OU=Personal Certificate/L=CNAF/CN=Daniele Andreotti,/C=IT/O=INFN/CN=INFN CA' not found. It will be created...
Adding ALL permissions on '/cert.mysql' for admin '/C=IT/O=INFN/OU=Personal Certificate/L=CNAF/CN=Daniele Andreotti,/C=IT/O=INFN/CN=INFN CA'
Adding ALL permissions on role '/cert.mysql/Role=VO-Admin' for admin '/C=IT/O=INFN/OU=Personal Certificate/L=CNAF/CN=Daniele Andreotti,/C=IT/O=INFN/CN=INFN CA'


VOMS smoke testing

Check that the VOMS Admin web application is running

Point your browser to https://HOSTNAME:8443/vomses and check that the webapp responds for the configured VO, in this case the cert_SL5.mysql VO.

SL5/x86_64

VOMS MySQL

  • voms-admin UP and reachable from web

VOMS Oracle

  • voms-admin UP and reachable from web

SL6/x86_64

VOMS MySQL

  • voms-admin UP and reachable from web

VOMS Oracle

Run the VOMS Admin testsuite

The testsuites is run using a VOMS proxy, so make sure you have voms-clients rpm installed on the machine where your run it. The testsuite needs to run with administrator privileges on VOMS-Admin, so typically we use the same administrator credentials setup in the previous section.

SL5/x86_64

VOMS MySQL

Testsuite execution:

[ceccanti@emitestbed18 cli-testsuite]$ ./myCheck-VOMS -n emitestbed18.cnaf.infn.it -l test-sequence.lst.voms-admin
...
Short report:
Test VOMS-addMember   - OK
Test VOMS-assignRole   - OK
Test VOMS-crAttribute   - OK
Test VOMS-crGroup   - OK
Test VOMS-crRole   - OK
Test VOMS-crUser   - OK
Test VOMS-crUserNocert   - OK
Test VOMS-delAttribute   - OK
Test VOMS-delGroup   - OK
Test VOMS-delGroupAttribute   - OK
Test VOMS-delRole   - OK
Test VOMS-delRoleAttribute   - OK
Test VOMS-delUser   - OK
Test VOMS-delUserAttribute   - OK
Test VOMS-dismissRole   - OK
Test VOMS-listAttributes   - OK
Test VOMS-listGroupAttributes   - OK
Test VOMS-listGroups   - OK
Test VOMS-listMembers   - OK
Test VOMS-listRoleAttributes   - OK
Test VOMS-listRoles   - OK
Test VOMS-listSubGroups   - OK
Test VOMS-listUserAttributes   - OK
Test VOMS-listUserGroups   - OK
Test VOMS-listUserRoles   - OK
Test VOMS-listUsers   - OK
Test VOMS-listUsrWithRol   - OK
Test VOMS-removeMember   - OK
Test VOMS-setGroupAttribute   - OK
Test VOMS-setRoleAttribute   - OK
Test VOMS-setUserAttribute   - OK
Full test report exists in ./full_result

VOMS Oracle

[ceccanti@emitestbed18 cli-testsuite]$ ./myCheck-VOMS -n emitestbed18.cnaf.infn.it -l test-sequence.lst.voms-admin
...
Short report:
Test VOMS-addMember   - OK
Test VOMS-assignRole   - OK
Test VOMS-crAttribute   - OK
Test VOMS-crGroup   - OK
Test VOMS-crRole   - OK
Test VOMS-crUser   - OK
Test VOMS-crUserNocert   - OK
Test VOMS-delAttribute   - OK
Test VOMS-delGroup   - OK
Test VOMS-delGroupAttribute   - OK
Test VOMS-delRole   - OK
Test VOMS-delRoleAttribute   - OK
Test VOMS-delUser   - OK
Test VOMS-delUserAttribute   - OK
Test VOMS-dismissRole   - OK
Test VOMS-listAttributes   - OK
Test VOMS-listGroupAttributes   - OK
Test VOMS-listGroups   - OK
Test VOMS-listMembers   - OK
Test VOMS-listRoleAttributes   - OK
Test VOMS-listRoles   - OK
Test VOMS-listSubGroups   - OK
Test VOMS-listUserAttributes   - OK
Test VOMS-listUserGroups   - OK
Test VOMS-listUserRoles   - OK
Test VOMS-listUsers   - OK
Test VOMS-listUsrWithRol   - OK
Test VOMS-removeMember   - OK
Test VOMS-setGroupAttribute   - OK
Test VOMS-setRoleAttribute   - OK
Test VOMS-setUserAttribute   - OK
Full test report exists in ./full_result

SL6/x86_64

VOMS MySQL
Testsuite execution:
[ceccanti@cert-30 cli-testsuite]$ ./myCheck-VOMS -n `hostname -f` -l test-sequence.lst.voms-admin
...
Short report:
Test VOMS-addMember   - OK
Test VOMS-assignRole   - OK
Test VOMS-crAttribute   - OK
Test VOMS-crGroup   - OK
Test VOMS-crRole   - OK
Test VOMS-crUser   - OK
Test VOMS-crUserNocert   - OK
Test VOMS-delAttribute   - OK
Test VOMS-delGroup   - OK
Test VOMS-delGroupAttribute   - OK
Test VOMS-delRole   - OK
Test VOMS-delRoleAttribute   - OK
Test VOMS-delUser   - OK
Test VOMS-delUserAttribute   - OK
Test VOMS-dismissRole   - OK
Test VOMS-listAttributes   - OK
Test VOMS-listGroupAttributes   - OK
Test VOMS-listGroups   - OK
Test VOMS-listMembers   - OK
Test VOMS-listRoleAttributes   - OK
Test VOMS-listRoles   - OK
Test VOMS-listSubGroups   - OK
Test VOMS-listUserAttributes   - OK
Test VOMS-listUserGroups   - OK
Test VOMS-listUserRoles   - OK
Test VOMS-listUsers   - OK
Test VOMS-listUsrWithRol   - OK
Test VOMS-removeMember   - OK
Test VOMS-setGroupAttribute   - OK
Test VOMS-setRoleAttribute   - OK
Test VOMS-setUserAttribute   - OK
Full test report exists in ./full_result
VOMS Oracle

Testsuite execution:

[ceccanti@cert-30 cli-testsuite]$ ./myCheck-VOMS -n `hostname -f` -l test-sequence.lst.voms-admin
...
Short report:
Test VOMS-addMember   - OK
Test VOMS-assignRole   - OK
Test VOMS-crAttribute   - OK
Test VOMS-crGroup   - OK
Test VOMS-crRole   - OK
Test VOMS-crUser   - OK
Test VOMS-crUserNocert   - OK
Test VOMS-delAttribute   - OK
Test VOMS-delGroup   - OK
Test VOMS-delGroupAttribute   - OK
Test VOMS-delRole   - OK
Test VOMS-delRoleAttribute   - OK
Test VOMS-delUser   - OK
Test VOMS-delUserAttribute   - OK
Test VOMS-dismissRole   - OK
Test VOMS-listAttributes   - OK
Test VOMS-listGroupAttributes   - OK
Test VOMS-listGroups   - OK
Test VOMS-listMembers   - OK
Test VOMS-listRoleAttributes   - OK
Test VOMS-listRoles   - OK
Test VOMS-listSubGroups   - OK
Test VOMS-listUserAttributes   - OK
Test VOMS-listUserGroups   - OK
Test VOMS-listUserRoles   - OK
Test VOMS-listUsers   - OK
Test VOMS-listUsrWithRol   - OK
Test VOMS-removeMember   - OK
Test VOMS-setGroupAttribute   - OK
Test VOMS-setRoleAttribute   - OK
Test VOMS-setUserAttribute   - OK
Full test report exists in ./full_result

Run the VOMS core testsuite

SL5/x86_64

Test suite execution results can be browsed here.

SL6/x86_64

Test suite execution results can be browsed here.

Regression tests

SL5/x86_64

VOMS API Java

[VOMS API Java] VOMS Java APIs should provide sensible truststore refresh default (https://savannah.cern.ch/bugs/?93551)

Description of the test: Write a simple program that creates a PKIStore and show that the store is refreshed every 10 minutes by setting the log for PKIStore to DEBUG.

Execution: The following test program is executed on the certification machine:

import java.io.IOException;
import java.security.cert.CRLException;
import java.security.cert.CertificateException;

import org.glite.voms.PKIVerifier;


public class Test93551 {

   /**
    * @param args
    * @throws IOException 
    * @throws CRLException 
    * @throws CertificateException 
    */
   public static void main(String[] args) throws CertificateException, CRLException, IOException {
      
      
      PKIVerifier verifier = new PKIVerifier();

      while (true);
   }

}
With the following log4j configuration:

log4j.rootLogger=INFO, A1
log4j.appender.A1=org.apache.log4j.ConsoleAppender
log4j.appender.A1.layout=org.apache.log4j.PatternLayout

# Print the date in ISO 8601 format
log4j.appender.A1.layout.ConversionPattern=%d [%t] %-5p %c - %m%n

# Print only messages of level WARN or above in the package com.foo.
log4j.logger.org.glite.voms.PKIStore=DEBUG

The output of the execution is:

[ceccanti@emitestbed18 java-api-tests]$ echo $cp
/usr/share/java/voms-api-java.jar:/usr/share/java/bcprov.jar:/usr/share/java/commons-cli.jar:/usr/share/java/commons-lang.jar:/usr/share/java/log4j.jar
[ceccanti@emitestbed18 java-api-tests]$ javac -cp ".:$cp" Test93551.java
[ceccanti@emitestbed18 java-api-tests]$ java -cp ".:$cp" Test93551 | grep Initializing
2012-05-03 17:23:38,756 [main] DEBUG org.glite.voms.PKIStore - Initializing VOMS certificate store from directory: /etc/grid-security/vomsdir
2012-05-03 17:23:38,921 [main] DEBUG org.glite.voms.PKIStore - Initializing CA certificate store from directory: /etc/grid-security/certificates
2012-05-03 17:24:08,923 [Timer-0] DEBUG org.glite.voms.PKIStore - Initializing VOMS certificate store from directory: /etc/grid-security/vomsdir
2012-05-03 17:24:14,613 [Timer-1] DEBUG org.glite.voms.PKIStore - Initializing CA certificate store from directory: /etc/grid-security/certificates
2012-05-03 17:34:08,923 [Timer-0] DEBUG org.glite.voms.PKIStore - Initializing VOMS certificate store from directory: /etc/grid-security/vomsdir
2012-05-03 17:34:14,613 [Timer-1] DEBUG org.glite.voms.PKIStore - Initializing CA certificate store from directory: /etc/grid-security/certificates

The log shows that the store is initialized at 17:23:38,756, then refreshed for the first iteration after 30 seconds and then every 10 minutes as expected.

[VOMS API Java] VOMSTrustManager getAcceptedIssuers() returns 3 x all the trust anchors (https://savannah.cern.ch/bugs/?90112)

Description of the test: Write a simple program that creates a VOMSTrustManager and show that the number of accepted issuers returned by the program is equal to the number of CA certificates installed on the system.

Execution: The following test program is executed on the certification machine:

import java.io.IOException;
import java.security.cert.CRLException;
import java.security.cert.CertificateException;

import org.glite.voms.VOMSTrustManager;


public class Test90112 {

        /**
         * @param args
         * @throws IOException 
         * @throws CRLException 
         * @throws CertificateException 
         */
        public static void main(String[] args) throws CertificateException, CRLException, IOException {
                VOMSTrustManager tm = new VOMSTrustManager("/etc/grid-security/certificates");

                int caCount = tm.getAcceptedIssuers().length;
                System.out.println("Accepted issuers count: "+caCount);


        }

}

The output of the execution is:

[ceccanti@emitestbed18 java-api-tests]$ echo $cp
/usr/share/java/voms-api-java.jar:/usr/share/java/bcprov.jar:/usr/share/java/commons-cli.jar:/usr/share/java/commons-lang.jar:/usr/share/java/log4j.jar
[ceccanti@emitestbed18 java-api-tests]$ javac -cp ".:$cp" Test90112.java
[ceccanti@emitestbed18 java-api-tests]$ java -cp ".:$cp" Test90112
log4j:WARN No appenders could be found for logger (org.glite.voms.PKIStore).
log4j:WARN Please initialize the log4j system properly.
Accepted issuers count: 103
[ceccanti@emitestbed18 java-api-tests]$ ls /etc/grid-security/certificates/*.0 | wc -l
206
The output of wc -l shows 206 certificates, as with recent CA distributions there are two links for each CA certificate (one for each hash function used).

Result: Passed

VOMS MySQL

[VOMS Admin] VOMS Admin SIGN AUP default grace period is too short (https://savannah.cern.ch/bugs/?93370)

Description of the test:

Manually set expiration date for users membership into VOMS db. First attempt: set a date to invalidate membership but in order to don't exceed the grace period. Second attempt: set a date to exceed also the grace period.

Execution:

Into VOMS db:

update usr set end_time = "2012-04-18";
update usr set end_time = "2012-04-20";

-> User membership expired 6 days AGO -> still valid given 7 days of grace
-> User membership expired 8 days AGO -> ON SCREEN @ Suspended User membership has expired. Membership expired 8 days ago 

Result: Passed

[VOMS Admin] VOMS Admin does not send warning message before suspending users due to membership expiration (https://savannah.cern.ch/bugs/?93255)

Description of the test: Set the expiration date for users membership conveniently. Check if warning emails are sent as expected.

Execution:

MAIL RECEIVED

Dear VO Administrator,

this mail is to inform you that membership in VO cert_SL5.mysql for the following users has EXPIRED:

User 1 Test (1) membership has expired since 2 days.The user is still active can get VOMS attributes as usual.  

User 2 Test (2) membership has expired since 2 days.The user is still active can get VOMS attributes as usual.
  
Please evaluate whether each membership should be extended by pointing your browser to the following URL:

https://emitestbed18.cnaf.infn.it:8443/voms/cert_SL5.mysql/user/search.action

Your sincerely,
Voms-Admin registration service for VO cert_SL5.mysql

Result: Passed

[VOMS Admin] voms-admin-configure ignores dbhost and dbport parameters for voms core configuration (https://savannah.cern.ch/bugs/?91182)

Description of the test:

Create a test vo using voms-admin-configure specifying the --dbhost and --dbport options. Ensure that the value provided appear in /etc/voms//voms.conf

Execution:


[root@emitestbed18 ~]# voms-admin-configure install --vo cicciovo --dbtype mysql --dbusername sulu --dbpassword ***** --dbname foobartest --dbhost emitestbed18.cnaf.infn.it --dbport 3306 --port 15000 --mail-from "daniele.andreotti@cnaf.infn.it" --smtp-host "postino.cnaf.infn.it" --dbapwd *****
voms-admin-configure, version 2.7.0

Installing vo cicciovo
Deploying database for cicciovo vo
Creating mysql db...
Deploying database for cicciovo vo
Checking database connectivity...
Database contacted succesfully
Checking database existence...
No voms-admin database found.
Checking that the database is writable...
Database is writable.
create table acl2 (acl_id bigint not null auto_increment, group_id bigint not null, defaultACL bit not null, role_id bigint, primary key (acl_id), unique (group_id, defaultACL, role_id)) type=InnoDB
create table acl2_permissions (acl_id bigint not null, permissions integer, admin_id bigint not null, primary key (acl_id, admin_id)) type=InnoDB
create table admins (adminid bigint not null auto_increment, dn varchar(255) not null, email_address varchar(255), ca smallint not null, primary key (adminid), unique (dn, ca)) type=InnoDB
create table attributes (a_id bigint not null auto_increment, a_name varchar(255) not null unique, a_desc text, a_uniq bit default 0, primary key (a_id)) type=InnoDB
create table aup (id bigint not null auto_increment, name varchar(255) not null unique, description varchar(255), reacceptancePeriod integer not null, primary key (id)) type=InnoDB
create table aup_acc_record (id bigint not null auto_increment, aup_version_id bigint not null, usr_id bigint not null, last_acceptance_date datetime not null, valid bit, primary key (id), unique (aup_version_id, usr_id)) type=InnoDB
create table aup_version (id bigint not null auto_increment, aup_id bigint not null, version varchar(255) not null, url varchar(255), text varchar(255), creationTime datetime not null, lastForcedReacceptanceTime datetime, active bit not null, primary key (id), unique (aup_id, version)) type=InnoDB
create table ca (cid smallint not null auto_increment, subject_string varchar(255) not null unique, description varchar(255), creation_time datetime not null, primary key (cid)) type=InnoDB
create table capabilities (cid bigint not null auto_increment, capability varchar(255) not null, primary key (cid)) type=InnoDB
create table certificate (id bigint not null auto_increment, creation_time datetime not null, subject_string varchar(255) not null, suspended bit not null, suspended_reason varchar(255), suspension_reason_code varchar(255), ca_id smallint not null, usr_id bigint not null, primary key (id), unique (ca_id, subject_string)) type=InnoDB
create table certificate_request (certificate tinyblob, certificateIssuer varchar(255) not null, certificateSubject varchar(255) not null, request_id bigint not null, primary key (request_id)) type=InnoDB
create table group_attrs (a_id bigint not null, g_id bigint not null, a_value varchar(255), primary key (a_id, g_id)) type=InnoDB
create table group_membership_req (groupName varchar(255) not null, request_id bigint not null, primary key (request_id)) type=InnoDB
create table groups (gid bigint not null auto_increment, dn varchar(255) not null unique, description varchar(255), parent bigint, must bit not null, restricted bit, primary key (gid)) type=InnoDB
create table m (mapping_id bigint not null auto_increment, userid bigint not null, gid bigint not null, rid bigint, cid bigint, primary key (mapping_id), unique (userid, gid, rid)) type=InnoDB
create table memb_req (id bigint not null auto_increment, creation_date datetime not null, evaluation_date datetime, status integer not null, confirm_id varchar(255) not null, dn varchar(255) not null, ca varchar(255) not null, cn varchar(255), mail varchar(255) not null, primary key (id)) type=InnoDB
create table membership_rem_req (reason varchar(255) not null, request_id bigint not null, primary key (request_id)) type=InnoDB
create table personal_info (id bigint not null auto_increment, value varchar(255), visible bit, personal_info_type_id bigint not null, primary key (id)) type=InnoDB
create table personal_info_type (id bigint not null auto_increment, description varchar(255), type varchar(255) not null unique, primary key (id)) type=InnoDB
create table req (request_id bigint not null auto_increment, completionDate datetime, creationDate datetime, expirationDate datetime, status varchar(255) not null, requester_info_id bigint not null, primary key (request_id), unique (requester_info_id)) type=InnoDB
create table requester_info (id bigint not null auto_increment, address varchar(255), certificateIssuer varchar(255) not null, certificateSubject varchar(255) not null, emailAddress varchar(255) not null, institution varchar(255), name varchar(255), phoneNumber varchar(255), surname varchar(255), voMember bit, primary key (id)) type=InnoDB
create table requester_personal_info (requester_id bigint not null, pi_value varchar(255), pi_key varchar(255), primary key (requester_id, pi_key)) type=InnoDB
create table role_attrs (a_id bigint not null, g_id bigint not null, r_id bigint not null, a_value varchar(255), primary key (a_id, g_id, r_id)) type=InnoDB
create table role_membership_req (groupName varchar(255), roleName varchar(255), request_id bigint not null, primary key (request_id)) type=InnoDB
create table roles (rid bigint not null auto_increment, role varchar(255) not null unique, primary key (rid)) type=InnoDB
create table seqnumber (seq varchar(255) not null, primary key (seq)) type=InnoDB
create table sign_aup_task (task_id bigint not null, aup_id bigint not null, primary key (task_id)) type=InnoDB
create table tag_mapping (mapping_id bigint not null auto_increment, tag_id bigint not null, gid bigint not null, rid bigint, admin_id bigint not null, primary key (mapping_id), unique (tag_id, gid, rid, admin_id)) type=InnoDB
create table tags (id bigint not null auto_increment, name varchar(255) not null unique, implicit bit not null, permissions integer not null, permissionsOnPath integer, primary key (id)) type=InnoDB
create table task (task_id bigint not null auto_increment, completionDate datetime, creationDate datetime, expiryDate datetime, status varchar(255) not null, admin_id bigint, task_type_id bigint not null, usr_id bigint, primary key (task_id)) type=InnoDB
create table task_log_record (id bigint not null auto_increment, adminDn varchar(255), creation_time datetime not null, event varchar(255) not null, userDn varchar(255), task_id bigint not null, primary key (id)) type=InnoDB
create table task_type (id bigint not null auto_increment, description varchar(255), name varchar(255) not null unique, primary key (id)) type=InnoDB
create table user_request_task (task_id bigint not null, req_id bigint not null, primary key (task_id)) type=InnoDB
create table usr (userid bigint not null auto_increment, address varchar(255), creation_time datetime not null, dn varchar(255), email_address varchar(255) not null, end_time datetime not null, institution varchar(255), name varchar(255), phone_number varchar(255), surname varchar(255), suspended bit, suspension_reason varchar(255), suspension_reason_code varchar(255), ca smallint, primary key (userid)) type=InnoDB
create table usr_attrs (a_id bigint not null, u_id bigint not null, a_value varchar(255), primary key (a_id, u_id)) type=InnoDB
create table version (version integer not null, admin_version varchar(255), primary key (version)) type=InnoDB
create table vo_membership_req (confirmId varchar(255) not null, request_id bigint not null, primary key (request_id)) type=InnoDB
alter table acl2 add index FK2D98E8720C9B10 (role_id), add constraint FK2D98E8720C9B10 foreign key (role_id) references roles (rid) on delete cascade
alter table acl2 add index FK2D98E8FCFA8B04 (group_id), add constraint FK2D98E8FCFA8B04 foreign key (group_id) references groups (gid) on delete cascade
alter table acl2_permissions add index FK35C6CFADD91CE8A3 (acl_id), add constraint FK35C6CFADD91CE8A3 foreign key (acl_id) references acl2 (acl_id)
alter table acl2_permissions add index FK35C6CFADA4AD9904 (admin_id), add constraint FK35C6CFADA4AD9904 foreign key (admin_id) references admins (adminid)
alter table admins add index FKAB3A67047C6FEB32 (ca), add constraint FKAB3A67047C6FEB32 foreign key (ca) references ca (cid)
alter table aup_acc_record add index FKB1979B32EE2D4487 (usr_id), add constraint FKB1979B32EE2D4487 foreign key (usr_id) references usr (userid)
alter table aup_acc_record add index FKB1979B32815F1678 (aup_version_id), add constraint FKB1979B32815F1678 foreign key (aup_version_id) references aup_version (id)
alter table aup_version add index fk_aup_version_aup (aup_id), add constraint fk_aup_version_aup foreign key (aup_id) references aup (id) on delete cascade
alter table certificate add index FK745F4197EE2D4487 (usr_id), add constraint FK745F4197EE2D4487 foreign key (usr_id) references usr (userid)
alter table certificate add index FK745F419782107F70 (ca_id), add constraint FK745F419782107F70 foreign key (ca_id) references ca (cid)
alter table certificate_request add index FK47CA53E7D75D60A4 (request_id), add constraint FK47CA53E7D75D60A4 foreign key (request_id) references req (request_id)
alter table group_attrs add index FK40B1A2E2566C2A8F (a_id), add constraint FK40B1A2E2566C2A8F foreign key (a_id) references attributes (a_id)
alter table group_attrs add index FK40B1A2E2DEFC581C (g_id), add constraint FK40B1A2E2DEFC581C foreign key (g_id) references groups (gid) on delete cascade
alter table group_membership_req add index FKBD145E75D75D60A4 (request_id), add constraint FKBD145E75D75D60A4 foreign key (request_id) references req (request_id)
alter table groups add index FKB63DD9D4A3771CD3 (parent), add constraint FKB63DD9D4A3771CD3 foreign key (parent) references groups (gid)
alter table m add index fk_m_roles (rid), add constraint fk_m_roles foreign key (rid) references roles (rid) on delete cascade
alter table m add index fk_m_groups (gid), add constraint fk_m_groups foreign key (gid) references groups (gid) on delete cascade
alter table m add index fk_m_cap (cid), add constraint fk_m_cap foreign key (cid) references capabilities (cid)
alter table m add index fk_m_usr (userid), add constraint fk_m_usr foreign key (userid) references usr (userid)
alter table membership_rem_req add index FK1877BC10D75D60A4 (request_id), add constraint FK1877BC10D75D60A4 foreign key (request_id) references req (request_id)
alter table personal_info add index FK229FDF4DA8D3C6BC (personal_info_type_id), add constraint FK229FDF4DA8D3C6BC foreign key (personal_info_type_id) references personal_info_type (id)
alter table req add index FK1B89EC37E889D (requester_info_id), add constraint FK1B89EC37E889D foreign key (requester_info_id) references requester_info (id)
alter table requester_personal_info add index FK7E3D7FCAD500B8D2 (requester_id), add constraint FK7E3D7FCAD500B8D2 foreign key (requester_id) references requester_info (id)
alter table role_attrs add index FK6BDE9799566C2A8F (a_id), add constraint FK6BDE9799566C2A8F foreign key (a_id) references attributes (a_id)
alter table role_attrs add index FK6BDE979920304994 (r_id), add constraint FK6BDE979920304994 foreign key (r_id) references roles (rid) on delete cascade
alter table role_attrs add index FK6BDE9799DEFC581C (g_id), add constraint FK6BDE9799DEFC581C foreign key (g_id) references groups (gid)
alter table role_membership_req add index FK3B9C79ED75D60A4 (request_id), add constraint FK3B9C79ED75D60A4 foreign key (request_id) references req (request_id)
alter table sign_aup_task add index FK7FCB416A32B8C70C (task_id), add constraint FK7FCB416A32B8C70C foreign key (task_id) references task (task_id)
alter table sign_aup_task add index FK7FCB416ADA1C6363 (aup_id), add constraint FK7FCB416ADA1C6363 foreign key (aup_id) references aup (id)
alter table tag_mapping add index fk_tag_mapping_roles (rid), add constraint fk_tag_mapping_roles foreign key (rid) references roles (rid) on delete cascade
alter table tag_mapping add index fk_tag_mapping_admins (admin_id), add constraint fk_tag_mapping_admins foreign key (admin_id) references admins (adminid) on delete cascade
alter table tag_mapping add index fk_tag_mapping_groups (gid), add constraint fk_tag_mapping_groups foreign key (gid) references groups (gid) on delete cascade
alter table tag_mapping add index fk_tag_mapping_tag (tag_id), add constraint fk_tag_mapping_tag foreign key (tag_id) references tags (id) on delete cascade
alter table task add index FK3635859AD54C57 (task_type_id), add constraint FK3635859AD54C57 foreign key (task_type_id) references task_type (id)
alter table task add index FK363585EE2D4487 (usr_id), add constraint FK363585EE2D4487 foreign key (usr_id) references usr (userid)
alter table task add index FK363585A4AD9904 (admin_id), add constraint FK363585A4AD9904 foreign key (admin_id) references admins (adminid)
alter table task_log_record add index FK77673CA632B8C70C (task_id), add constraint FK77673CA632B8C70C foreign key (task_id) references task (task_id)
alter table user_request_task add index FKACB7D2932B8C70C (task_id), add constraint FKACB7D2932B8C70C foreign key (task_id) references task (task_id)
alter table user_request_task add index FKACB7D299D73AC35 (req_id), add constraint FKACB7D299D73AC35 foreign key (req_id) references req (request_id)
alter table usr add index FK1C5947C6FEB32 (ca), add constraint FK1C5947C6FEB32 foreign key (ca) references ca (cid)
alter table usr_attrs add index FKA39E0E37566C2A8F (a_id), add constraint FKA39E0E37566C2A8F foreign key (a_id) references attributes (a_id)
alter table usr_attrs add index FKA39E0E3720331206 (u_id), add constraint FKA39E0E3720331206 foreign key (u_id) references usr (userid)
alter table vo_membership_req add index FK28EE8AFBD75D60A4 (request_id), add constraint FK28EE8AFBD75D60A4 foreign key (request_id) references req (request_id)
Deploying voms database...
Database deployed correctly!



VO cicciovo installation finished.
 
You can start the voms services using the following commands:
    //etc/init.d/voms start cicciovo
    //etc/init.d/voms-admin start cicciovo




[root@emitestbed18 ~]# cat /etc/voms/cicciovo/voms.conf 
--code=15000
--dbname=foobartest
--logfile=/var/log/voms/voms.cicciovo 
--loglevel=4
--logtype=7
--passfile=//etc/voms/cicciovo/voms.pass
--port=15000
--sqlloc=/usr/lib64/libvomsmysql.so
--username=sulu
--vo=cicciovo
--uri=emitestbed18.cnaf.infn.it:15000
--timeout=86400
--dbhost=emitestbed18.cnaf.infn.it

Result: Passed

[VOMS Admin] Trim spaces from DN when entered in the web interface (https://savannah.cern.ch/bugs/?88019)

Description of the test:

Added fake user with spaces before and after DN

Execution:

Verified from the web interface spaces were removed properly

Result: Passed

[VOMS Admin] Use single separator in the output of voms-admin list-users command (https://savannah.cern.ch/bugs/?86771)

Description of the test:

Command voms-admin --vo list-users executed.

Execution:

root@emitestbed18 ~]# voms-admin  --vo cert_SL5.mysql list-users
Test1,/C=IT/O=INFN/CN=INFN CA,daniele.andreotti@daniele.andreotti
/C=IT/O=INFN/OU=Personal Certificate/L=CNAF/CN=Danilo Nicola Dongiovanni,/C=IT/O=INFN/CN=INFN CA,danilo.dongiovanni@cnaf.infn.it

Result: Passed

[VOMS Admin] Small improvements to VOMS Admin WEB UI (https://savannah.cern.ch/bugs/?86327)

Description of the test: Check that the add certificate page shows the "Certificate subject (DN)" label instead of "Subject". Check that the registration page displays the "Given name", "Family name" labels insted of "Name", "Surname".

Execution:

Verified from the web interface

Result: Passed

[VOMS Admin] voms-admin-ping looking in wrong place to determine list of VOs (https://savannah.cern.ch/bugs/?85657)

Description of the test:

Configure three different VOs with YAIM. After YAIM configuration is over, stop two of them with service voms-admin and check that one VO is shown as active, while the other two are reported as stopped.

Execution:

[root@emitestbed18 siteinfo]# /opt/glite/yaim/bin/yaim -c -s site-info.def -n VOMS
   WARNING: 
   WARNING: *****************************************************************************
   WARNING: Your siteinfo directory is world readable. This is generally a bad idea      
   WARNING: as configuration files may contain passwords and other sensitive information.
   WARNING: *****************************************************************************
   WARNING: 
   INFO: Configuring HOST: emitestbed18.cnaf.infn.it
   INFO: Using site configuration file: site-info.def
   INFO: Sourcing service specific configuration file: ./services/glite-voms
   INFO: 
         ###################################################################
         
         .             /'.-. ')
         .     yA,-"-,( ,m,:/ )   .oo.     oo    o      ooo  o.     .oo
         .    /      .-Y a  a Y-.     8. .8'    8'8.     8    8b   d'8
         .   /           ~ ~ /         8'    .8oo88.     8    8  8'  8
         . (_/         '===='          8    .8'     8.   8    8  Y   8
         .   Y,-''-,Yy,-.,/           o8o  o8o    o88o  o8o  o8o    o8o
         .    I_))_) I_))_)
         
         
         current working directory: /root/siteinfo
         site-info.def date: Apr 27 14:58 site-info.def
         yaim command: -c -s site-info.def -n VOMS
         log file: /opt/glite/yaim/bin/../log/yaimlog
         Fri Apr 27 15:09:33 CEST 2012 : /opt/glite/yaim/bin/yaim
         
         Installed YAIM versions:
         glite-yaim-bdii 4.3.9-1
         glite-yaim-core 5.0.3-4
         yaim-voms 1.1.1-1.el5
         
         ####################################################################
   INFO: The default location of the grid-env.(c)sh files will be: /usr/libexec
   INFO: Sourcing the utilities in /opt/glite/yaim/functions/utils
   INFO: Detecting environment
   INFO: Executing function: config_host_certs_check 
   INFO: Executing function: config_edgusers_check 
   INFO: Executing function: config_add_pool_env_check 
   INFO: Executing function: config_info_service_voms_check 
   INFO: Executing function: config_info_service_voms_admin_check 
   INFO: Executing function: config_glue2_info_service_voms_check 
   INFO: Executing function: config_voms_check 
   INFO: Detecting TOMCAT
   INFO: Executing function: config_voms_logrotate_check 
   INFO: Executing function: config_bdii_5.2_check 
   INFO: Executing function: config_host_certs 
   INFO: Executing function: config_edgusers 
   INFO: Executing function: config_add_pool_env_setenv 
   INFO: Executing function: config_add_pool_env 
   INFO: Executing function: config_crl 
   INFO: Now updating the CRLs - this may take a few minutes...
Enabling periodic fetch-crl:                               [  OK  ]
   INFO: Executing function: config_info_service_voms_setenv 
   INFO: Executing function: config_info_service_voms 
   INFO: Executing function: config_info_service_voms_admin_setenv 
   INFO: Executing function: config_info_service_voms_admin 
   INFO: Executing function: config_glue2_info_service_voms_setenv 
   INFO: Executing function: config_glue2_info_service_voms 
   INFO: Executing function: config_voms_setenv 
   INFO: Executing function: config_voms 
   INFO: MySQL configuration
   INFO: Detecting TOMCAT
   INFO: Stop tomcat in case it's running
Stopping tomcat5:                                          [  OK  ]
   INFO: Copying hostcert to /etc/grid-security/tomcat-cert.pem for tomcat:root......
   INFO: Copying hostkey to /etc/grid-security/tomcat-key.pem for tomcat:root...
   INFO: Configuring /etc/tomcat5/server.xml...
   INFO: Copying trustmanager log4j properties to tomcat configuration directory..
   INFO: Linking log4j and bouncycastle jars to tomcat server lib directory..
   INFO: Linking trustmanager jars to tomcat server lib directory...
   INFO: Linking jakarta-commons-logging to tomcat server lib directory...
   INFO: Defining JAVA_HOME in the Tomcat configuration file
   INFO: Starting Tomcat
Starting tomcat5:                                          [  OK  ]
   INFO: Ready to start VOMS configuration
voms-admin-configure, version 2.7.0

Checking installation...
Checking local installation...
Installation ok.
Setting up user credentials...
Using host credentials (/etc/grid-security/hostcert.pem) since running as root.
Setting defaults for the VOMS AA credentials
AA certificates settings:
cert:/etc/grid-security/tomcat-cert.pem
key:/etc/grid-security/tomcat-key.pem
Prefix: //usr
Configuration dir: /etc/voms-admin
Cheking input parameters
Installing vo cert_SL5.mysql
VO cert_SL5.mysql is already configured on this host, will overwrite the configuration...
Skipping voms core configuration creation
Will not set read-only access for authenticated clients as the --skip-database option is set
VO cert_SL5.mysql configured correctly.



VO cert_SL5.mysql installation finished.
 
You can start the voms services using the following commands:
    //etc/init.d/voms start cert_SL5.mysql
    //etc/init.d/voms-admin start cert_SL5.mysql
voms_cert_mysql_db
   INFO: Checking VOMS database schema existence and deploying one if missing...
Checking database connectivity...
Database contacted succesfully
Checking database existence...
Found existing voms-admin 2.5.x database...
Existing voms database found. Will not overwrite the database!
   INFO: Opening the VO to all authenticated clients.
Checking that the database is writable...
Database is writable.
Granting read-only access to any authenticated user on group '/cert_SL5.mysql'
Granting read-only access to any authenticated user on role '/cert_SL5.mysql/Role=VO-Admin'
   INFO: Adding default admin from /etc/grid-security/hostcert.pem
   INFO: Ignoring email from the administrator certificate: /etc/grid-security/hostcert.pem
Admin '/C=IT/O=INFN/OU=Host/L=CNAF/CN=emitestbed18.cnaf.infn.it,/C=IT/O=INFN/CN=INFN CA' already exists in database...
This admin will be granted full privileges on the VOMS database.
Adding ALL permissions on '/cert_SL5.mysql' for admin '/C=IT/O=INFN/OU=Host/L=CNAF/CN=emitestbed18.cnaf.infn.it,/C=IT/O=INFN/CN=INFN CA'
Adding ALL permissions on role '/cert_SL5.mysql/Role=VO-Admin' for admin '/C=IT/O=INFN/OU=Host/L=CNAF/CN=emitestbed18.cnaf.infn.it,/C=IT/O=INFN/CN=INFN CA'
Stopping vo cert_SL5.mysql
Starting vo cert_SL5.mysql
Stopping siblings webapp
Starting siblings webapp
   INFO: User and password for read-only database access for VOMS-CORE not specified.
   INFO: Using the credentials for read-write access (VOMS-ADMIN).
voms-admin-configure, version 2.7.0

Checking installation...
Checking local installation...
Installation ok.
Setting up user credentials...
Using host credentials (/etc/grid-security/hostcert.pem) since running as root.
Setting defaults for the VOMS AA credentials
AA certificates settings:
cert:/etc/grid-security/tomcat-cert.pem
key:/etc/grid-security/tomcat-key.pem
Prefix: //usr
Configuration dir: /etc/voms-admin
Cheking input parameters
Installing vo first.mysql
Skipping voms core configuration creation
Will not set read-only access for authenticated clients as the --skip-database option is set
VO first.mysql configured correctly.



VO first.mysql installation finished.
 
You can start the voms services using the following commands:
    //etc/init.d/voms start first.mysql
    //etc/init.d/voms-admin start first.mysql
   INFO: Checking VOMS database schema existence and deploying one if missing...
Checking database connectivity...
Database contacted succesfully
Checking database existence...
No voms-admin database found.
Checking that the database is writable...
Database is writable.
create table acl2 (acl_id bigint not null auto_increment, group_id bigint not null, defaultACL bit not null, role_id bigint, primary key (acl_id), unique (group_id, defaultACL, role_id)) type=InnoDB
create table acl2_permissions (acl_id bigint not null, permissions integer, admin_id bigint not null, primary key (acl_id, admin_id)) type=InnoDB
create table admins (adminid bigint not null auto_increment, dn varchar(255) not null, email_address varchar(255), ca smallint not null, primary key (adminid), unique (dn, ca)) type=InnoDB
create table attributes (a_id bigint not null auto_increment, a_name varchar(255) not null unique, a_desc text, a_uniq bit default 0, primary key (a_id)) type=InnoDB
create table aup (id bigint not null auto_increment, name varchar(255) not null unique, description varchar(255), reacceptancePeriod integer not null, primary key (id)) type=InnoDB
create table aup_acc_record (id bigint not null auto_increment, aup_version_id bigint not null, usr_id bigint not null, last_acceptance_date datetime not null, valid bit, primary key (id), unique (aup_version_id, usr_id)) type=InnoDB
create table aup_version (id bigint not null auto_increment, aup_id bigint not null, version varchar(255) not null, url varchar(255), text varchar(255), creationTime datetime not null, lastForcedReacceptanceTime datetime, active bit not null, primary key (id), unique (aup_id, version)) type=InnoDB
create table ca (cid smallint not null auto_increment, subject_string varchar(255) not null unique, description varchar(255), creation_time datetime not null, primary key (cid)) type=InnoDB
create table capabilities (cid bigint not null auto_increment, capability varchar(255) not null, primary key (cid)) type=InnoDB
create table certificate (id bigint not null auto_increment, creation_time datetime not null, subject_string varchar(255) not null, suspended bit not null, suspended_reason varchar(255), suspension_reason_code varchar(255), ca_id smallint not null, usr_id bigint not null, primary key (id), unique (ca_id, subject_string)) type=InnoDB
create table certificate_request (certificate tinyblob, certificateIssuer varchar(255) not null, certificateSubject varchar(255) not null, request_id bigint not null, primary key (request_id)) type=InnoDB
create table group_attrs (a_id bigint not null, g_id bigint not null, a_value varchar(255), primary key (a_id, g_id)) type=InnoDB
create table group_membership_req (groupName varchar(255) not null, request_id bigint not null, primary key (request_id)) type=InnoDB
create table groups (gid bigint not null auto_increment, dn varchar(255) not null unique, description varchar(255), parent bigint, must bit not null, restricted bit, primary key (gid)) type=InnoDB
create table m (mapping_id bigint not null auto_increment, userid bigint not null, gid bigint not null, rid bigint, cid bigint, primary key (mapping_id), unique (userid, gid, rid)) type=InnoDB
create table memb_req (id bigint not null auto_increment, creation_date datetime not null, evaluation_date datetime, status integer not null, confirm_id varchar(255) not null, dn varchar(255) not null, ca varchar(255) not null, cn varchar(255), mail varchar(255) not null, primary key (id)) type=InnoDB
create table membership_rem_req (reason varchar(255) not null, request_id bigint not null, primary key (request_id)) type=InnoDB
create table personal_info (id bigint not null auto_increment, value varchar(255), visible bit, personal_info_type_id bigint not null, primary key (id)) type=InnoDB
create table personal_info_type (id bigint not null auto_increment, description varchar(255), type varchar(255) not null unique, primary key (id)) type=InnoDB
create table req (request_id bigint not null auto_increment, completionDate datetime, creationDate datetime, expirationDate datetime, status varchar(255) not null, requester_info_id bigint not null, primary key (request_id), unique (requester_info_id)) type=InnoDB
create table requester_info (id bigint not null auto_increment, address varchar(255), certificateIssuer varchar(255) not null, certificateSubject varchar(255) not null, emailAddress varchar(255) not null, institution varchar(255), name varchar(255), phoneNumber varchar(255), surname varchar(255), voMember bit, primary key (id)) type=InnoDB
create table requester_personal_info (requester_id bigint not null, pi_value varchar(255), pi_key varchar(255), primary key (requester_id, pi_key)) type=InnoDB
create table role_attrs (a_id bigint not null, g_id bigint not null, r_id bigint not null, a_value varchar(255), primary key (a_id, g_id, r_id)) type=InnoDB
create table role_membership_req (groupName varchar(255), roleName varchar(255), request_id bigint not null, primary key (request_id)) type=InnoDB
create table roles (rid bigint not null auto_increment, role varchar(255) not null unique, primary key (rid)) type=InnoDB
create table seqnumber (seq varchar(255) not null, primary key (seq)) type=InnoDB
create table sign_aup_task (task_id bigint not null, aup_id bigint not null, primary key (task_id)) type=InnoDB
create table tag_mapping (mapping_id bigint not null auto_increment, tag_id bigint not null, gid bigint not null, rid bigint, admin_id bigint not null, primary key (mapping_id), unique (tag_id, gid, rid, admin_id)) type=InnoDB
create table tags (id bigint not null auto_increment, name varchar(255) not null unique, implicit bit not null, permissions integer not null, permissionsOnPath integer, primary key (id)) type=InnoDB
create table task (task_id bigint not null auto_increment, completionDate datetime, creationDate datetime, expiryDate datetime, status varchar(255) not null, admin_id bigint, task_type_id bigint not null, usr_id bigint, primary key (task_id)) type=InnoDB
create table task_log_record (id bigint not null auto_increment, adminDn varchar(255), creation_time datetime not null, event varchar(255) not null, userDn varchar(255), task_id bigint not null, primary key (id)) type=InnoDB
create table task_type (id bigint not null auto_increment, description varchar(255), name varchar(255) not null unique, primary key (id)) type=InnoDB
create table user_request_task (task_id bigint not null, req_id bigint not null, primary key (task_id)) type=InnoDB
create table usr (userid bigint not null auto_increment, address varchar(255), creation_time datetime not null, dn varchar(255), email_address varchar(255) not null, end_time datetime not null, institution varchar(255), name varchar(255), phone_number varchar(255), surname varchar(255), suspended bit, suspension_reason varchar(255), suspension_reason_code varchar(255), ca smallint, primary key (userid)) type=InnoDB
create table usr_attrs (a_id bigint not null, u_id bigint not null, a_value varchar(255), primary key (a_id, u_id)) type=InnoDB
create table version (version integer not null, admin_version varchar(255), primary key (version)) type=InnoDB
create table vo_membership_req (confirmId varchar(255) not null, request_id bigint not null, primary key (request_id)) type=InnoDB
alter table acl2 add index FK2D98E8720C9B10 (role_id), add constraint FK2D98E8720C9B10 foreign key (role_id) references roles (rid) on delete cascade
alter table acl2 add index FK2D98E8FCFA8B04 (group_id), add constraint FK2D98E8FCFA8B04 foreign key (group_id) references groups (gid) on delete cascade
alter table acl2_permissions add index FK35C6CFADD91CE8A3 (acl_id), add constraint FK35C6CFADD91CE8A3 foreign key (acl_id) references acl2 (acl_id)
alter table acl2_permissions add index FK35C6CFADA4AD9904 (admin_id), add constraint FK35C6CFADA4AD9904 foreign key (admin_id) references admins (adminid)
alter table admins add index FKAB3A67047C6FEB32 (ca), add constraint FKAB3A67047C6FEB32 foreign key (ca) references ca (cid)
alter table aup_acc_record add index FKB1979B32EE2D4487 (usr_id), add constraint FKB1979B32EE2D4487 foreign key (usr_id) references usr (userid)
alter table aup_acc_record add index FKB1979B32815F1678 (aup_version_id), add constraint FKB1979B32815F1678 foreign key (aup_version_id) references aup_version (id)
alter table aup_version add index fk_aup_version_aup (aup_id), add constraint fk_aup_version_aup foreign key (aup_id) references aup (id) on delete cascade
alter table certificate add index FK745F4197EE2D4487 (usr_id), add constraint FK745F4197EE2D4487 foreign key (usr_id) references usr (userid)
alter table certificate add index FK745F419782107F70 (ca_id), add constraint FK745F419782107F70 foreign key (ca_id) references ca (cid)
alter table certificate_request add index FK47CA53E7D75D60A4 (request_id), add constraint FK47CA53E7D75D60A4 foreign key (request_id) references req (request_id)
alter table group_attrs add index FK40B1A2E2566C2A8F (a_id), add constraint FK40B1A2E2566C2A8F foreign key (a_id) references attributes (a_id)
alter table group_attrs add index FK40B1A2E2DEFC581C (g_id), add constraint FK40B1A2E2DEFC581C foreign key (g_id) references groups (gid) on delete cascade
alter table group_membership_req add index FKBD145E75D75D60A4 (request_id), add constraint FKBD145E75D75D60A4 foreign key (request_id) references req (request_id)
alter table groups add index FKB63DD9D4A3771CD3 (parent), add constraint FKB63DD9D4A3771CD3 foreign key (parent) references groups (gid)
alter table m add index fk_m_roles (rid), add constraint fk_m_roles foreign key (rid) references roles (rid) on delete cascade
alter table m add index fk_m_groups (gid), add constraint fk_m_groups foreign key (gid) references groups (gid) on delete cascade
alter table m add index fk_m_cap (cid), add constraint fk_m_cap foreign key (cid) references capabilities (cid)
alter table m add index fk_m_usr (userid), add constraint fk_m_usr foreign key (userid) references usr (userid)
alter table membership_rem_req add index FK1877BC10D75D60A4 (request_id), add constraint FK1877BC10D75D60A4 foreign key (request_id) references req (request_id)
alter table personal_info add index FK229FDF4DA8D3C6BC (personal_info_type_id), add constraint FK229FDF4DA8D3C6BC foreign key (personal_info_type_id) references personal_info_type (id)
alter table req add index FK1B89EC37E889D (requester_info_id), add constraint FK1B89EC37E889D foreign key (requester_info_id) references requester_info (id)
alter table requester_personal_info add index FK7E3D7FCAD500B8D2 (requester_id), add constraint FK7E3D7FCAD500B8D2 foreign key (requester_id) references requester_info (id)
alter table role_attrs add index FK6BDE9799566C2A8F (a_id), add constraint FK6BDE9799566C2A8F foreign key (a_id) references attributes (a_id)
alter table role_attrs add index FK6BDE979920304994 (r_id), add constraint FK6BDE979920304994 foreign key (r_id) references roles (rid) on delete cascade
alter table role_attrs add index FK6BDE9799DEFC581C (g_id), add constraint FK6BDE9799DEFC581C foreign key (g_id) references groups (gid)
alter table role_membership_req add index FK3B9C79ED75D60A4 (request_id), add constraint FK3B9C79ED75D60A4 foreign key (request_id) references req (request_id)
alter table sign_aup_task add index FK7FCB416A32B8C70C (task_id), add constraint FK7FCB416A32B8C70C foreign key (task_id) references task (task_id)
alter table sign_aup_task add index FK7FCB416ADA1C6363 (aup_id), add constraint FK7FCB416ADA1C6363 foreign key (aup_id) references aup (id)
alter table tag_mapping add index fk_tag_mapping_roles (rid), add constraint fk_tag_mapping_roles foreign key (rid) references roles (rid) on delete cascade
alter table tag_mapping add index fk_tag_mapping_admins (admin_id), add constraint fk_tag_mapping_admins foreign key (admin_id) references admins (adminid) on delete cascade
alter table tag_mapping add index fk_tag_mapping_groups (gid), add constraint fk_tag_mapping_groups foreign key (gid) references groups (gid) on delete cascade
alter table tag_mapping add index fk_tag_mapping_tag (tag_id), add constraint fk_tag_mapping_tag foreign key (tag_id) references tags (id) on delete cascade
alter table task add index FK3635859AD54C57 (task_type_id), add constraint FK3635859AD54C57 foreign key (task_type_id) references task_type (id)
alter table task add index FK363585EE2D4487 (usr_id), add constraint FK363585EE2D4487 foreign key (usr_id) references usr (userid)
alter table task add index FK363585A4AD9904 (admin_id), add constraint FK363585A4AD9904 foreign key (admin_id) references admins (adminid)
alter table task_log_record add index FK77673CA632B8C70C (task_id), add constraint FK77673CA632B8C70C foreign key (task_id) references task (task_id)
alter table user_request_task add index FKACB7D2932B8C70C (task_id), add constraint FKACB7D2932B8C70C foreign key (task_id) references task (task_id)
alter table user_request_task add index FKACB7D299D73AC35 (req_id), add constraint FKACB7D299D73AC35 foreign key (req_id) references req (request_id)
alter table usr add index FK1C5947C6FEB32 (ca), add constraint FK1C5947C6FEB32 foreign key (ca) references ca (cid)
alter table usr_attrs add index FKA39E0E37566C2A8F (a_id), add constraint FKA39E0E37566C2A8F foreign key (a_id) references attributes (a_id)
alter table usr_attrs add index FKA39E0E3720331206 (u_id), add constraint FKA39E0E3720331206 foreign key (u_id) references usr (userid)
alter table vo_membership_req add index FK28EE8AFBD75D60A4 (request_id), add constraint FK28EE8AFBD75D60A4 foreign key (request_id) references req (request_id)
Deploying voms database...
Database deployed correctly!
   INFO: Opening the VO to all authenticated clients.
Checking that the database is writable...
Database is writable.
Granting read-only access to any authenticated user on group '/first.mysql'
Granting read-only access to any authenticated user on role '/first.mysql/Role=VO-Admin'
   INFO: Adding default admin from /etc/grid-security/hostcert.pem
   INFO: Ignoring email from the administrator certificate: /etc/grid-security/hostcert.pem
Admin '/C=IT/O=INFN/OU=Host/L=CNAF/CN=emitestbed18.cnaf.infn.it,/C=IT/O=INFN/CN=INFN CA' not found. It will be created...
Adding ALL permissions on '/first.mysql' for admin '/C=IT/O=INFN/OU=Host/L=CNAF/CN=emitestbed18.cnaf.infn.it,/C=IT/O=INFN/CN=INFN CA'
Adding ALL permissions on role '/first.mysql/Role=VO-Admin' for admin '/C=IT/O=INFN/OU=Host/L=CNAF/CN=emitestbed18.cnaf.infn.it,/C=IT/O=INFN/CN=INFN CA'
Stopping vo first.mysql
Starting vo first.mysql
Stopping siblings webapp
Starting siblings webapp
   INFO: User and password for read-only database access for VOMS-CORE not specified.
   INFO: Using the credentials for read-write access (VOMS-ADMIN).
ERROR 1470 (HY000) at line 1: String 'second_mysql_user' is too long for user name (should be no longer than 16)
voms-admin-configure, version 2.7.0

Checking installation...
Checking local installation...
Installation ok.
Setting up user credentials...
Using host credentials (/etc/grid-security/hostcert.pem) since running as root.
Setting defaults for the VOMS AA credentials
AA certificates settings:
cert:/etc/grid-security/tomcat-cert.pem
key:/etc/grid-security/tomcat-key.pem
Prefix: //usr
Configuration dir: /etc/voms-admin
Cheking input parameters
Installing vo second.mysql
Skipping voms core configuration creation
Will not set read-only access for authenticated clients as the --skip-database option is set
VO second.mysql configured correctly.



VO second.mysql installation finished.
 
You can start the voms services using the following commands:
    //etc/init.d/voms start second.mysql
    //etc/init.d/voms-admin start second.mysql

   INFO: YAIM terminated succesfully.


[root@emitestbed18 siteinfo]# /etc/init.d/voms-admin stop second.mysql
Stopping vo second.mysql
[root@emitestbed18 siteinfo]# /etc/init.d/voms-admin stop first.mysql
Stopping vo first.mysql


[root@emitestbed18 siteinfo]# voms-admin-ping
Testing cert_SL5.mysql:                [  OK  ]
Testing first.mysql:                   [  SOAP error: VO is not active.  ]
Testing second.mysql:                  [  SOAP error: VO is not active.  ]


Result: Passed

[VOMS Admin] AUP URL for active AUP should be editable from the Web interface (https://savannah.cern.ch/bugs/?83161)

Description of the test: Verified from the web interface.

Execution:

Aup URL changed to a wrong name. Error message prompted. URL edited to the original name.  

Result: Passed

[VOMS Admin] AUP URL wrong in VOMS database after upgrade to EMI 1 VOMS (https://savannah.cern.ch/bugs/?83159)

Description of the test:

Execution:

Verified https://savannah.cern.ch/bugs/?83161 which is a fix for this too. 

Result: Passed

[VOMS Admin] Provide access to membership statistics (https://savannah.cern.ch/bugs/?93968)

Description of the test: Executed voms-admin command tools for getting membership stats.

Execution:

[root@emitestbed18 ~]# voms-admin  --vo cert_SL5.mysql   count-users count-suspended-users count-expired-users list-suspended-users list-expired-users list-user-stats
User count: 5
Suspended user count: 2
Expired user count: 2
Test1,/C=IT/O=INFN/CN=INFN CA,Suspended: User membership has expired.,User 1 Test (1)
Test2,/C=IT/O=INFN/CN=INFN CA,Suspended: User membership has expired.,User 2 Test (2)
Test1,/C=IT/O=INFN/CN=INFN CA,Suspended: User membership has expired.,User 1 Test (1)
Test2,/C=IT/O=INFN/CN=INFN CA,Suspended: User membership has expired.,User 2 Test (2)
expiredUsersCount = 2 
suspendedUsersCount = 2 
usersCount = 5 

Result: Passed

[VOMS Admin] The voms-admin-configure --read-access-to-authenticated-clients options produces no effect (https://savannah.cern.ch/bugs/?93978)

Description of the test: Checked by the web interface

Execution:

Line Automatically added at configuration: 
CN=Any Authenticated User CN=Dummy Certificate Authority    r   r                       edit    delete

Result: Passed

[VOMS] VOMS fails in producing AC if certificate subject name contains an apostrophe (https://savannah.cern.ch/bugs/?93455)

Description of the test: Create a test certificate containing an apostrophe. Register this certificate in VOMS. Ensure that it's possible to obtain an AC out of VOMS with the just created certificate.

Execution:

[andreotti-bbr@emitestbed18 ~]$ voms-proxy-init --voms cert_SL5.mysql -cert apostrophe-daniele-cert.pem -key apostrophe-daniele-key.pem
Your identity: /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele
Creating temporary proxy .............................. Done
Contacting  emitestbed18.cnaf.infn.it:15001 [/C=IT/O=INFN/OU=Host/L=CNAF/CN=emitestbed18.cnaf.infn.it] "cert_SL5.mysql" Done
Creating proxy .............................................................................. Done

Your proxy is valid until Fri May  4 00:15:53 2012


[andreotti-bbr@emitestbed18 ~]$ voms-proxy-init --voms cert_SL5.mysql --noregen
Your identity: /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele/CN=proxy
Contacting  emitestbed18.cnaf.infn.it:15001 [/C=IT/O=INFN/OU=Host/L=CNAF/CN=emitestbed18.cnaf.infn.it] "cert_SL5.mysql" Done
Creating proxy ......................................................... Done

Warning: your certificate and proxy will expire Fri May  4 00:15:53 2012
which is within the requested lifetime of the proxy



[andreotti-bbr@emitestbed18 ~]$ voms-proxy-init --voms cert_SL5.mysql --noregen
Your identity: /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele/CN=proxy/CN=proxy
Contacting  emitestbed18.cnaf.infn.it:15001 [/C=IT/O=INFN/OU=Host/L=CNAF/CN=emitestbed18.cnaf.infn.it] "cert_SL5.mysql" Done
Creating proxy .............................................................................. Done

Warning: your certificate and proxy will expire Fri May  4 00:15:53 2012
which is within the requested lifetime of the proxy



[andreotti-bbr@emitestbed18 ~]$ voms-proxy-info -all
subject   : /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele/CN=proxy/CN=proxy/CN=proxy
issuer    : /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele/CN=proxy/CN=proxy
identity  : /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele/CN=proxy/CN=proxy
type      : proxy
strength  : 1024 bits
path      : /tmp/x509up_u519
timeleft  : 11:59:25
key usage : Digital Signature, Key Encipherment
=== VO cert_SL5.mysql extension information ===
VO        : cert_SL5.mysql
subject   : /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele
issuer    : /C=IT/O=INFN/OU=Host/L=CNAF/CN=emitestbed18.cnaf.infn.it
attribute : /cert_SL5.mysql/Role=NULL/Capability=NULL
timeleft  : 11:59:54
uri       : emitestbed18.cnaf.infn.it:15001

Result: Passed

[VOMS] VOMS MySQL plugin causes 'Aborted connection' warnings on MySQL (https://savannah.cern.ch/bugs/?93456)

Description of the test: Configure a MySQL based VO. Add a user to the VO. Run a large number of AC requests against the VOMS server for that user (e.g., 500 requests). Set the log-warnings=2 in the MySQL configuration, typically /etc/my.cnf. Ensure that the mysql log doesn't contain an "Aborted connection" warning for each request (some aborted connections are accetable).

Execution:

Warning: your certificate and proxy will expire Fri May  4 01:31:49 2012
which is within the requested lifetime of the proxy
1999

Your identity: /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele/CN=proxy
Contacting  emitestbed18.cnaf.infn.it:15001 [/C=IT/O=INFN/OU=Host/L=CNAF/CN=emitestbed18.cnaf.infn.it] "cert_SL5.mysql" Done
Creating proxy ......................................................................................... Done

Warning: your certificate and proxy will expire Fri May  4 01:31:49 2012
which is within the requested lifetime of the proxy

2000
Your identity: /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele/CN=proxy
Contacting  emitestbed18.cnaf.infn.it:15001 [/C=IT/O=INFN/OU=Host/L=CNAF/CN=emitestbed18.cnaf.infn.it] "cert_SL5.mysql" Done
Creating proxy ............................................................................................................... Done

Warning: your certificate and proxy will expire Fri May  4 01:31:49 2012
which is within the requested lifetime of the proxy




[mysql log]

120503 13:42:40  mysqld started
120503 13:42:40  InnoDB: Started; log sequence number 0 2594928
120503 13:42:41 [Note] /usr/libexec/mysqld: ready for connections.
Version: '5.0.95'  socket: '/var/lib/mysql/mysql.sock'  port: 3306  Source distribution


120503 13:54:31 [Note] /usr/libexec/mysqld: Normal shutdown

120503 13:54:31  InnoDB: Starting shutdown...
120503 13:54:32  InnoDB: Shutdown completed; log sequence number 0 2594958
120503 13:54:32 [Note] /usr/libexec/mysqld: Shutdown complete

120503 13:54:32  mysqld ended

Result: Passed

[VOMS] YAIM VOMS should provide a way to configure --skipcacheck voms configuration parameter (https://savannah.cern.ch/bugs/?89202)

Description of the test: Configure a VO with YAIM specifying the VOMS_SKIP_CA_CHECK variable. Ensure that the /etc//voms.conf configuration file contains the --skipcacheck after the configuration.

Execution:

[root@emitestbed18 siteinfo]# cat services/glite-voms

...
...
...

VO_CERT_SL5_MYSQL_VOMS_PORT=15001
VO_CERT_SL5_MYSQL_VOMS_DB_USER=cert_mysql_user
VO_CERT_SL5_MYSQL_VOMS_DB_PASS=XXXXX
VO_CERT_SL5_MYSQL_VOMS_DB_NAME=voms_cert_mysql_db

VOMS_SKIP_CA_CHECK=true


[root@emitestbed18 siteinfo]# cat /etc/voms/cert_SL5.mysql/voms.conf
--vo=cert_SL5.mysql
--port=15001
--code=15001
--uri=emitestbed18.cnaf.infn.it:15001
--loglevel=4
--logtype=7
--timeout=86400
--logfile=/var/log/voms/voms.cert_SL5.mysql
--passfile=//etc/voms/cert_SL5.mysql/voms.pass
--sqlloc=/usr/lib64/libvomsmysql.so
--dbname=voms_cert_mysql_db
--skipcacheck
--username=cert_mysql_user

Result: Passed

VOMS Oracle

[VOMS Admin] VOMS Admin SIGN AUP default grace period is too short (https://savannah.cern.ch/bugs/?93370)

Description of the test:

Manually set expiration date for users membership into VOMS db. First attempt: set a date to invalidate membership but in order to don't exceed the grace period. Second attempt: set a date to exceed also the grace period.

Execution:

Into VOMS db:

update usr set end_time = '25-APR-12' where name = 'ciccio';

-> User '[id=1,defaultCertficate=[subject_string=ciccio pass,ca=/C=AM/O=ArmeSFo/CN=ArmeSFo CA],name=ciccio,surname=pasticcio,emailAddress=ciccio@pasticcio.com,suspended=false,endTime=2012-04-25 00:00:00.0]' not suspended due to grace period.


update usr set end_time = '24-APR-12' where name = 'ciccio';

-> Suspending user '[id=1,defaultCertficate=[subject_string=ciccio pass,ca=/C=AM/O=ArmeSFo/CN=ArmeSFo CA],name=ciccio,surname=pasticcio,emailAddress=ciccio@pasticcio.com,suspended=false,endTime=2012-04-24 00:00:00.0]' since its membership has expired and grace period is over.

Result: Passed

[VOMS Admin] VOMS Admin does not send warning message before suspending users due to membership expiration (https://savannah.cern.ch/bugs/?93255)

Description of the test: Set the expiration date for users membership conveniently. Check if warning emails are sent as expected.

Execution:

MAIL RECEIVED

Dear VO Administrator,

this mail is to inform you that membership in VO cert_SL5.oracle for the following users has EXPIRED:


ciccio pasticcio (1) membership has expired since 6 days.The user is still active can get VOMS attributes as usual.
  


Please evaluate whether each membership should be extended by pointing your browser to the following URL:

https://emitestbed18.cnaf.infn.it:8443/voms/cert_SL5.oracle/user/search.action

Your sincerely,
Voms-Admin registration service for VO cert_SL5.oracle

Result: Passed

[VOMS Admin] Trim spaces from DN when entered in the web interface (https://savannah.cern.ch/bugs/?88019)

Description of the test:

Added fake user with spaces before and after DN

Execution:

Verified from the web interface spaces were removed properly

Result: Passed

[VOMS Admin] Use single separator in the output of voms-admin list-users command (https://savannah.cern.ch/bugs/?86771)

Description of the test:

Command voms-admin --vo list-users executed.

Execution:

[root@emitestbed18 siteinfo]# voms-admin  --vo cert_SL5.oracle list-users
ciccio pass,/C=AM/O=ArmeSFo/CN=ArmeSFo CA,ciccio@pasticcio.com
kirk,/C=BM/O=QuoVadis Limited/OU=Issuing Certification Authority/CN=QuoVadis Grid ICA,kirk@pasticcio.com

Result: Passed

[VOMS Admin] Small improvements to VOMS Admin WEB UI (https://savannah.cern.ch/bugs/?86327)

Description of the test: Check that the add certificate page shows the "Certificate subject (DN)" label instead of "Subject". Check that the registration page displays the "Given name", "Family name" labels insted of "Name", "Surname".

Execution:

Verified from the web interface

Result: Passed

[VOMS Admin] voms-admin-ping looking in wrong place to determine list of VOs (https://savannah.cern.ch/bugs/?85657)

Description of the test:

Configure three different VOs with YAIM. After YAIM configuration is over, stop two of them with service voms-admin and check that one VO is shown as active, while the other two are reported as stopped.

Execution:

[root@emitestbed18 siteinfo]# /etc/init.d/voms-admin stop fakevo
Stopping vo fakevo
[root@emitestbed18 siteinfo]# /etc/init.d/voms-admin stop cicciovo
Stopping vo cicciovo

Testing cert_SL5.oracle:               [  OK  ]
Testing cicciovo:                      [  SOAP error: VO is not active.  ]
Testing fakevo:                        [  SOAP error: VO is not active.  ]

Result: Passed

[VOMS Admin] AUP URL for active AUP should be editable from the Web interface (https://savannah.cern.ch/bugs/?83161)

Description of the test: Verified from the web interface.

Execution:

Aup URL changed to a wrong name. Error message prompted. URL edited to the original name.  

Result: Passed

[VOMS Admin] AUP URL wrong in VOMS database after upgrade to EMI 1 VOMS (https://savannah.cern.ch/bugs/?83159)

Description of the test:

Execution:

Verified https://savannah.cern.ch/bugs/?83161 which is a fix for this too. 

Result: Passed

[VOMS Admin] Provide access to membership statistics (https://savannah.cern.ch/bugs/?93968)

Description of the test: Executed voms-admin command tools for getting membership stats.

Execution:

[root@emitestbed18 siteinfo]# voms-admin  --vo cert_SL5.oracle   count-users count-suspended-users count-expired-users list-suspended-users list-expired-users list-user-stats
User count: 2
Suspended user count: 1
Expired user count: 1
ciccio pass,/C=AM/O=ArmeSFo/CN=ArmeSFo CA,Suspended: User membership has expired.,ciccio pasticcio (1)
ciccio pass,/C=AM/O=ArmeSFo/CN=ArmeSFo CA,Suspended: User membership has expired.,ciccio pasticcio (1)
expiredUsersCount = 1 
suspendedUsersCount = 1 
usersCount = 2 

Result: Passed

[VOMS Admin] The voms-admin-configure --read-access-to-authenticated-clients options produces no effect (https://savannah.cern.ch/bugs/?93978)

Description of the test: Checked by the web interface

Execution:

Line Automatically added at configuration: 
CN=Any Authenticated User CN=Dummy Certificate Authority    r   r                       edit    delete

Result: Passed

[VOMS Admin] VOMS Admin should use independent Oracle sequences for the main VOMS tables (https://savannah.cern.ch/bugs/?93976)

Description of the test:

After the database has been upgraded, ensure that individual Oracle sequences are used for the main VOMS tables.

Execution:

[oracle@voms-db-02 voms_db_dumps]$ sqlplus admin_25/***

SQL*Plus: Release 10.2.0.3.0 - Production on Mon May 7 11:54:07 2012

Copyright (c) 1982, 2006, Oracle.  All Rights Reserved.


Connected to:
Oracle Database 10g Enterprise Edition Release 10.2.0.3.0 - Production
With the Partitioning, OLAP and Data Mining options

SQL> select sequence_name from user_sequences;

SEQUENCE_NAME
------------------------------
VOMS_ACL_SEQ
VOMS_ADMIN_SEQ
VOMS_ATTR_DESC_SEQ
VOMS_AUP_ACC_REC_SEQ
VOMS_AUP_SEQ
VOMS_AUP_VER_SEQ
VOMS_CA_SEQ
VOMS_CERT_SEQ
VOMS_GROUP_SEQ
VOMS_M_SEQ
VOMS_PI_SEQ
VOMS_PI_TYPE_SEQ
VOMS_REQ_INFO_SEQ
VOMS_REQ_SEQ
VOMS_ROLE_SEQ
VOMS_TAG_MAP_SEQ
VOMS_TAG_SEQ
VOMS_TASK_LR_SEQ
VOMS_TASK_SEQ
VOMS_TASK_TYPE_SEQ
HIBERNATE_SEQUENCE

21 rows selected.

SQL>

Result: Passed

[VOMS] Middleman process crashes (Oracle backend) (https://savannah.cern.ch/bugs/?86273)

Description of the test: run a script which executes the voms-proxy-init --noregen command 2000 times.

Execution:


...
...

Warning: your certificate and proxy will expire Thu May  3 05:02:04 2012
which is within the requested lifetime of the proxy
1999
Your identity: /C=IT/O=INFN/OU=Personal Certificate/L=CNAF/CN=Daniele Andreotti/CN=proxy
Contacting  emitestbed18.cnaf.infn.it:15000 [/C=IT/O=INFN/OU=Host/L=CNAF/CN=emitestbed18.cnaf.infn.it] "cert_SL5.oracle" Done
Creating proxy .............................................. Done


Warning: your certificate and proxy will expire Thu May  3 05:02:04 2012
which is within the requested lifetime of the proxy
2000
Your identity: /C=IT/O=INFN/OU=Personal Certificate/L=CNAF/CN=Daniele Andreotti/CN=proxy
Contacting  emitestbed18.cnaf.infn.it:15000 [/C=IT/O=INFN/OU=Host/L=CNAF/CN=emitestbed18.cnaf.infn.it] "cert_SL5.oracle" Done
Creating proxy .................................... Done


Warning: your certificate and proxy will expire Thu May  3 05:02:04 2012
which is within the requested lifetime of the proxy

Result: Passed

[VOMS] VOMS fails in producing AC if certificate subject name contains an apostrophe (https://savannah.cern.ch/bugs/?93455)

Description of the test: Create a test certificate containing an apostrophe. Register this certificate in VOMS. Ensure that it's possible to obtain an AC out of VOMS with the just created certificate.

Execution:

[andreotti-bbr@emitestbed18 ~]$ voms-proxy-init --voms cert_SL5.oracle -cert apostrophe-daniele-cert.pem -key apostrophe-daniele-key.pem
Your identity: /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele
Creating temporary proxy ................................ Done
Contacting  emitestbed18.cnaf.infn.it:15000 [/C=IT/O=INFN/OU=Host/L=CNAF/CN=emitestbed18.cnaf.infn.it] "cert_SL5.oracle" Done
Creating proxy .................................................................................. Done

Your proxy is valid until Thu May  3 23:56:47 2012


[andreotti-bbr@emitestbed18 ~]$ voms-proxy-init --voms cert_SL5.oracle --noregen
Your identity: /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele/CN=proxy
Contacting  emitestbed18.cnaf.infn.it:15000 [/C=IT/O=INFN/OU=Host/L=CNAF/CN=emitestbed18.cnaf.infn.it] "cert_SL5.oracle" Done
Creating proxy ............................................................................................................... Done

Warning: your certificate and proxy will expire Thu May  3 23:56:47 2012
which is within the requested lifetime of the proxy


[andreotti-bbr@emitestbed18 ~]$ voms-proxy-init --voms cert_SL5.oracle --noregen
Your identity: /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele/CN=proxy/CN=proxy
Contacting  emitestbed18.cnaf.infn.it:15000 [/C=IT/O=INFN/OU=Host/L=CNAF/CN=emitestbed18.cnaf.infn.it] "cert_SL5.oracle" Done
Creating proxy ....................................................... Done


Warning: your certificate and proxy will expire Thu May  3 23:56:47 2012
which is within the requested lifetime of the proxy


[andreotti-bbr@emitestbed18 ~]$ voms-proxy-info -all
subject   : /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele/CN=proxy/CN=proxy/CN=proxy
issuer    : /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele/CN=proxy/CN=proxy
identity  : /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele/CN=proxy/CN=proxy
type      : proxy
strength  : 1024 bits
path      : /tmp/x509up_u519
timeleft  : 11:57:51
key usage : Digital Signature, Key Encipherment
=== VO cert_SL5.oracle extension information ===
VO        : cert_SL5.oracle
subject   : /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele
issuer    : /C=IT/O=INFN/OU=Host/L=CNAF/CN=emitestbed18.cnaf.infn.it
attribute : /cert_SL5.oracle/Role=NULL/Capability=NULL
timeleft  : 11:59:18
uri       : emitestbed18.cnaf.infn.it:15000

Result: Passed

[VOMS] YAIM VOMS should provide a way to configure --skipcacheck voms configuration parameter (https://savannah.cern.ch/bugs/?89202)

Description of the test: Configure a VO with YAIM specifying the VOMS_SKIP_CA_CHECK variable. Ensure that the /etc//voms.conf configuration file contains the --skipcacheck after the configuration.

Execution:


[root@emitestbed18 siteinfo]# cat services/glite-voms

...
...
...

VO_CERT_SL5_ORACLE_VOMS_PORT=15000
VO_CERT_SL5_ORACLE_VOMS_DB_USER=admin_25
VO_CERT_SL5_ORACLE_VOMS_DB_PASS=XXXXX
VO_CERT_SL5_ORACLE_VOMS_DB_TYPE=oracle

VOMS_SKIP_CA_CHECK=true



[root@emitestbed18 siteinfo]# cat /etc/voms/cert_SL5.oracle/voms.conf
--vo=cert_SL5.oracle
--port=15000
--code=15000
--uri=emitestbed18.cnaf.infn.it:15000
--loglevel=4
--logtype=7
--timeout=86400
--logfile=/var/log/voms/voms.cert_SL5.oracle
--passfile=//etc/voms/cert_SL5.oracle/voms.pass
--sqlloc=/usr/lib64/libvomsoracle.so
--dbname=DB_VOMS
--skipcacheck
--username=admin_25

Result: Passed

SL6/x86_64

VOMS API Java

[VOMS API Java] VOMS Java APIs should provide sensible truststore refresh default (https://savannah.cern.ch/bugs/?93551)

Description of the test: Write a simple program that creates a PKIStore and show that the store is refreshed every 10 minutes by setting the log for PKIStore to DEBUG.

Execution: The following test program is executed on the certification machine:

import java.io.IOException;
import java.security.cert.CRLException;
import java.security.cert.CertificateException;

import org.glite.voms.PKIVerifier;


public class Test93551 {

   /**
    * @param args
    * @throws IOException 
    * @throws CRLException 
    * @throws CertificateException 
    */
   public static void main(String[] args) throws CertificateException, CRLException, IOException {
      
      
      PKIVerifier verifier = new PKIVerifier();

      while (true);
   }

}
With the following log4j configuration:

log4j.rootLogger=INFO, A1
log4j.appender.A1=org.apache.log4j.ConsoleAppender
log4j.appender.A1.layout=org.apache.log4j.PatternLayout

# Print the date in ISO 8601 format
log4j.appender.A1.layout.ConversionPattern=%d [%t] %-5p %c - %m%n

# Print only messages of level WARN or above in the package com.foo.
log4j.logger.org.glite.voms.PKIStore=DEBUG

The output of the execution is:


[root@cert-30 test]# javac -cp .:/usr/share/java/voms-api-java.jar:/usr/share/java/bcprov.jar:/usr/share/java/commons-cli.jar:/usr/share/java/commons-lang.jar:/usr/share/java/log4j.jar Test93551.java 

[root@cert-30 test]# java -cp .:/usr/share/java/voms-api-java.jar:/usr/share/java/bcprov.jar:/usr/share/java/commons-cli.jar:/usr/share/java/commons-lang.jar:/usr/share/java/log4j.j Test93551 | grep Initializing
2012-05-07 12:18:49,959 [main] DEBUG org.glite.voms.PKIStore - Initializing VOMS certificate store from directory: /etc/grid-security/vomsdir
2012-05-07 12:18:50,045 [main] DEBUG org.glite.voms.PKIStore - Initializing CA certificate store from directory: /etc/grid-security/certificates
2012-05-07 12:19:20,045 [Timer-0] DEBUG org.glite.voms.PKIStore - Initializing VOMS certificate store from directory: /etc/grid-security/vomsdir
2012-05-07 12:19:23,772 [Timer-1] DEBUG org.glite.voms.PKIStore - Initializing CA certificate store from directory: /etc/grid-security/certificates
2012-05-07 12:29:20,046 [Timer-0] DEBUG org.glite.voms.PKIStore - Initializing VOMS certificate store from directory: /etc/grid-security/vomsdir
2012-05-07 12:29:23,772 [Timer-1] DEBUG org.glite.voms.PKIStore - Initializing CA certificate store from directory: /etc/grid-security/certificates

The log shows that the store is initialized at 12:18:49,959, then refreshed for the first iteration after 30 seconds and then every 10 minutes as expected.

Result: Passed

[VOMS API Java] VOMSTrustManager getAcceptedIssuers() returns 3 x all the trust anchors (https://savannah.cern.ch/bugs/?90112)

Description of the test: Write a simple program that creates a VOMSTrustManager and show that the number of accepted issuers returned by the program is equal to the number of CA certificates installed on the system.

Execution: The following test program is executed on the certification machine:

import java.io.IOException;
import java.security.cert.CRLException;
import java.security.cert.CertificateException;

import org.glite.voms.VOMSTrustManager;


public class Test90112 {

        /**
         * @param args
         * @throws IOException 
         * @throws CRLException 
         * @throws CertificateException 
         */
        public static void main(String[] args) throws CertificateException, CRLException, IOException {
                VOMSTrustManager tm = new VOMSTrustManager("/etc/grid-security/certificates");

                int caCount = tm.getAcceptedIssuers().length;
                System.out.println("Accepted issuers count: "+caCount);


        }

}

The output of the execution is:


[root@cert-30 test]# javac -cp .:/usr/share/java/voms-api-java.jar:/usr/share/java/bcprov.jar:/usr/share/java/commons-cli.jar:/usr/share/java/commons-lang.jar:/usr/share/java/log4j.jar Test90112.java 

[root@cert-30 test]# java -cp .:/usr/share/java/voms-api-java.jar:/usr/share/java/bcprov.jar:/usr/share/java/commons-cli.jar:/usr/share/java/commons-lang.jar:/usr/share/java/log4j.jar Test90112
log4j:WARN No appenders could be found for logger (org.glite.voms.PKIStore).
log4j:WARN Please initialize the log4j system properly.
Accepted issuers count: 103

[root@cert-30 test]# ls /etc/grid-security/certificates/*.0 | wc -l
206

The output of wc -l shows 206 certificates, as with recent CA distributions there are two links for each CA certificate (one for each hash function used).

Result: Passed

VOMS MySQL

[VOMS Admin] VOMS Admin SIGN AUP default grace period is too short (https://savannah.cern.ch/bugs/?93370)

Description of the test:

Manually set expiration date for users membership into VOMS db. First attempt: set a date to invalidate membership but in order to don't exceed the grace period. Second attempt: set a date to exceed also the grace period.

Execution:

Into VOMS db:

update usr set end_time='2012-04-27' where name='ciccio';

[log]
2012-05-04 13:24:50.922Z - DEBUG [GracePeriodExpiredMembersStrategy] - User '[id=3,defaultCertficate=[subject_string=ciccio pass,ca=/C=AM/O=ArmeSFo/CN=ArmeSFo CA],name=ciccio,surname=pasticcio,emailAddress=ciccio@pasticcio.com,suspended=false,endTime=2012-04-27 00:00:00.0]' not suspended due to grace period.



update usr set end_time='2012-04-26' where name='ciccio';

[log]
2012-05-04 13:25:20.920Z - INFO [GracePeriodExpiredMembersStrategy] - Suspending user '[id=3,defaultCertficate=[subject_string=ciccio pass,ca=/C=AM/O=ArmeSFo/CN=ArmeSFo CA],name=ciccio,surname=pasticcio,emailAddress=ciccio@pasticcio.com,suspended=false,endTime=2012-04-26 00:00:00.0]' since its membership has expired and grace period is over.
 

2012-05-04 13:25:20.954Z - DEBUG [GracePeriodExpiredMembersStrategy] - Now: Fri May 04 15:25:20 CEST 2012, User end time: 2012-04-26 00:00:00.0, Grace period (in days): 7

Result: Passed

[VOMS Admin] VOMS Admin does not send warning message before suspending users due to membership expiration (https://savannah.cern.ch/bugs/?93255)

Description of the test: Set the expiration date for users membership conveniently. Check if warning emails are sent as expected.

Execution:

MAIL RECEIVED

Dear VO Administrator,

this mail is to inform you that membership in VO cert.mysql for the following users has EXPIRED:

ciccio pasticcio (3) membership has expired since 7 days.The user is still active can get VOMS attributes as usual.

Please evaluate whether each membership should be extended by pointing your browser to the following URL:

https://cert-30.cnaf.infn.it:8443/voms/cert.mysql/user/search.action

Your sincerely,
Voms-Admin registration service for VO cert.mysql

Result: Passed

[VOMS Admin] voms-admin-configure ignores dbhost and dbport parameters for voms core configuration (https://savannah.cern.ch/bugs/?91182)

Description of the test:

Create a test vo using voms-admin-configure specifying the --dbhost and --dbport options. Ensure that the value provided appear in /etc/voms//voms.conf

Execution:


[root@cert-30 ~]# voms-admin-configure install --vo fakevo --dbtype mysql --dbusername sulu --dbpassword XXXXX --dbname voms_fakevo_db --dbhost cert-30.cnaf.infn.it --dbport 3306 --port 15000 --mail-from "daniele.andreotti@cnaf.infn.it" --smtp-host "postino.cnaf.infn.it" --dbapwd XXXXX

voms-admin-configure, version 2.7.0

Installing vo fakevo
Deploying database for fakevo vo
Creating mysql db...
Deploying database for fakevo vo
Checking database connectivity...
Database contacted succesfully
Checking database existence...
No voms-admin database found.
Checking that the database is writable...
Database is writable.
create table acl2 (acl_id bigint not null auto_increment, group_id bigint not null, defaultACL bit not null, role_id bigint, primary key (acl_id), unique (group_id, defaultACL, role_id)) type=InnoDB
create table acl2_permissions (acl_id bigint not null, permissions integer, admin_id bigint not null, primary key (acl_id, admin_id)) type=InnoDB
create table admins (adminid bigint not null auto_increment, dn varchar(255) not null, email_address varchar(255), ca smallint not null, primary key (adminid), unique (dn, ca)) type=InnoDB
create table attributes (a_id bigint not null auto_increment, a_name varchar(255) not null unique, a_desc text, a_uniq bit default 0, primary key (a_id)) type=InnoDB
create table aup (id bigint not null auto_increment, name varchar(255) not null unique, description varchar(255), reacceptancePeriod integer not null, primary key (id)) type=InnoDB
create table aup_acc_record (id bigint not null auto_increment, aup_version_id bigint not null, usr_id bigint not null, last_acceptance_date datetime not null, valid bit, primary key (id), unique (aup_version_id, usr_id)) type=InnoDB
create table aup_version (id bigint not null auto_increment, aup_id bigint not null, version varchar(255) not null, url varchar(255), text varchar(255), creationTime datetime not null, lastForcedReacceptanceTime datetime, active bit not null, primary key (id), unique (aup_id, version)) type=InnoDB
create table ca (cid smallint not null auto_increment, subject_string varchar(255) not null unique, description varchar(255), creation_time datetime not null, primary key (cid)) type=InnoDB
create table capabilities (cid bigint not null auto_increment, capability varchar(255) not null, primary key (cid)) type=InnoDB
create table certificate (id bigint not null auto_increment, creation_time datetime not null, subject_string varchar(255) not null, suspended bit not null, suspended_reason varchar(255), suspension_reason_code varchar(255), ca_id smallint not null, usr_id bigint not null, primary key (id), unique (ca_id, subject_string)) type=InnoDB
create table certificate_request (certificate tinyblob, certificateIssuer varchar(255) not null, certificateSubject varchar(255) not null, request_id bigint not null, primary key (request_id)) type=InnoDB
create table group_attrs (a_id bigint not null, g_id bigint not null, a_value varchar(255), primary key (a_id, g_id)) type=InnoDB
create table group_membership_req (groupName varchar(255) not null, request_id bigint not null, primary key (request_id)) type=InnoDB
create table groups (gid bigint not null auto_increment, dn varchar(255) not null unique, description varchar(255), parent bigint, must bit not null, restricted bit, primary key (gid)) type=InnoDB
create table m (mapping_id bigint not null auto_increment, userid bigint not null, gid bigint not null, rid bigint, cid bigint, primary key (mapping_id), unique (userid, gid, rid)) type=InnoDB
create table memb_req (id bigint not null auto_increment, creation_date datetime not null, evaluation_date datetime, status integer not null, confirm_id varchar(255) not null, dn varchar(255) not null, ca varchar(255) not null, cn varchar(255), mail varchar(255) not null, primary key (id)) type=InnoDB
create table membership_rem_req (reason varchar(255) not null, request_id bigint not null, primary key (request_id)) type=InnoDB
create table personal_info (id bigint not null auto_increment, value varchar(255), visible bit, personal_info_type_id bigint not null, primary key (id)) type=InnoDB
create table personal_info_type (id bigint not null auto_increment, description varchar(255), type varchar(255) not null unique, primary key (id)) type=InnoDB
create table req (request_id bigint not null auto_increment, completionDate datetime, creationDate datetime, expirationDate datetime, status varchar(255) not null, requester_info_id bigint not null, primary key (request_id), unique (requester_info_id)) type=InnoDB
create table requester_info (id bigint not null auto_increment, address varchar(255), certificateIssuer varchar(255) not null, certificateSubject varchar(255) not null, emailAddress varchar(255) not null, institution varchar(255), name varchar(255), phoneNumber varchar(255), surname varchar(255), voMember bit, primary key (id)) type=InnoDB
create table requester_personal_info (requester_id bigint not null, pi_value varchar(255), pi_key varchar(255), primary key (requester_id, pi_key)) type=InnoDB
create table role_attrs (a_id bigint not null, g_id bigint not null, r_id bigint not null, a_value varchar(255), primary key (a_id, g_id, r_id)) type=InnoDB
create table role_membership_req (groupName varchar(255), roleName varchar(255), request_id bigint not null, primary key (request_id)) type=InnoDB
create table roles (rid bigint not null auto_increment, role varchar(255) not null unique, primary key (rid)) type=InnoDB
create table seqnumber (seq varchar(255) not null, primary key (seq)) type=InnoDB
create table sign_aup_task (task_id bigint not null, aup_id bigint not null, primary key (task_id)) type=InnoDB
create table tag_mapping (mapping_id bigint not null auto_increment, tag_id bigint not null, gid bigint not null, rid bigint, admin_id bigint not null, primary key (mapping_id), unique (tag_id, gid, rid, admin_id)) type=InnoDB
create table tags (id bigint not null auto_increment, name varchar(255) not null unique, implicit bit not null, permissions integer not null, permissionsOnPath integer, primary key (id)) type=InnoDB
create table task (task_id bigint not null auto_increment, completionDate datetime, creationDate datetime, expiryDate datetime, status varchar(255) not null, admin_id bigint, task_type_id bigint not null, usr_id bigint, primary key (task_id)) type=InnoDB
create table task_log_record (id bigint not null auto_increment, adminDn varchar(255), creation_time datetime not null, event varchar(255) not null, userDn varchar(255), task_id bigint not null, primary key (id)) type=InnoDB
create table task_type (id bigint not null auto_increment, description varchar(255), name varchar(255) not null unique, primary key (id)) type=InnoDB
create table user_request_task (task_id bigint not null, req_id bigint not null, primary key (task_id)) type=InnoDB
create table usr (userid bigint not null auto_increment, address varchar(255), creation_time datetime not null, dn varchar(255), email_address varchar(255) not null, end_time datetime not null, institution varchar(255), name varchar(255), phone_number varchar(255), surname varchar(255), suspended bit, suspension_reason varchar(255), suspension_reason_code varchar(255), ca smallint, primary key (userid)) type=InnoDB
create table usr_attrs (a_id bigint not null, u_id bigint not null, a_value varchar(255), primary key (a_id, u_id)) type=InnoDB
create table version (version integer not null, admin_version varchar(255), primary key (version)) type=InnoDB
create table vo_membership_req (confirmId varchar(255) not null, request_id bigint not null, primary key (request_id)) type=InnoDB
alter table acl2 add index FK2D98E8720C9B10 (role_id), add constraint FK2D98E8720C9B10 foreign key (role_id) references roles (rid) on delete cascade
alter table acl2 add index FK2D98E8FCFA8B04 (group_id), add constraint FK2D98E8FCFA8B04 foreign key (group_id) references groups (gid) on delete cascade
alter table acl2_permissions add index FK35C6CFADD91CE8A3 (acl_id), add constraint FK35C6CFADD91CE8A3 foreign key (acl_id) references acl2 (acl_id)
alter table acl2_permissions add index FK35C6CFADA4AD9904 (admin_id), add constraint FK35C6CFADA4AD9904 foreign key (admin_id) references admins (adminid)
alter table admins add index FKAB3A67047C6FEB32 (ca), add constraint FKAB3A67047C6FEB32 foreign key (ca) references ca (cid)
alter table aup_acc_record add index FKB1979B32EE2D4487 (usr_id), add constraint FKB1979B32EE2D4487 foreign key (usr_id) references usr (userid)
alter table aup_acc_record add index FKB1979B32815F1678 (aup_version_id), add constraint FKB1979B32815F1678 foreign key (aup_version_id) references aup_version (id)
alter table aup_version add index fk_aup_version_aup (aup_id), add constraint fk_aup_version_aup foreign key (aup_id) references aup (id) on delete cascade
alter table certificate add index FK745F4197EE2D4487 (usr_id), add constraint FK745F4197EE2D4487 foreign key (usr_id) references usr (userid)
alter table certificate add index FK745F419782107F70 (ca_id), add constraint FK745F419782107F70 foreign key (ca_id) references ca (cid)
alter table certificate_request add index FK47CA53E7D75D60A4 (request_id), add constraint FK47CA53E7D75D60A4 foreign key (request_id) references req (request_id)
alter table group_attrs add index FK40B1A2E2566C2A8F (a_id), add constraint FK40B1A2E2566C2A8F foreign key (a_id) references attributes (a_id)
alter table group_attrs add index FK40B1A2E2DEFC581C (g_id), add constraint FK40B1A2E2DEFC581C foreign key (g_id) references groups (gid) on delete cascade
alter table group_membership_req add index FKBD145E75D75D60A4 (request_id), add constraint FKBD145E75D75D60A4 foreign key (request_id) references req (request_id)
alter table groups add index FKB63DD9D4A3771CD3 (parent), add constraint FKB63DD9D4A3771CD3 foreign key (parent) references groups (gid)
alter table m add index fk_m_roles (rid), add constraint fk_m_roles foreign key (rid) references roles (rid) on delete cascade
alter table m add index fk_m_groups (gid), add constraint fk_m_groups foreign key (gid) references groups (gid) on delete cascade
alter table m add index fk_m_cap (cid), add constraint fk_m_cap foreign key (cid) references capabilities (cid)
alter table m add index fk_m_usr (userid), add constraint fk_m_usr foreign key (userid) references usr (userid)
alter table membership_rem_req add index FK1877BC10D75D60A4 (request_id), add constraint FK1877BC10D75D60A4 foreign key (request_id) references req (request_id)
alter table personal_info add index FK229FDF4DA8D3C6BC (personal_info_type_id), add constraint FK229FDF4DA8D3C6BC foreign key (personal_info_type_id) references personal_info_type (id)
alter table req add index FK1B89EC37E889D (requester_info_id), add constraint FK1B89EC37E889D foreign key (requester_info_id) references requester_info (id)
alter table requester_personal_info add index FK7E3D7FCAD500B8D2 (requester_id), add constraint FK7E3D7FCAD500B8D2 foreign key (requester_id) references requester_info (id)
alter table role_attrs add index FK6BDE9799566C2A8F (a_id), add constraint FK6BDE9799566C2A8F foreign key (a_id) references attributes (a_id)
alter table role_attrs add index FK6BDE979920304994 (r_id), add constraint FK6BDE979920304994 foreign key (r_id) references roles (rid) on delete cascade
alter table role_attrs add index FK6BDE9799DEFC581C (g_id), add constraint FK6BDE9799DEFC581C foreign key (g_id) references groups (gid)
alter table role_membership_req add index FK3B9C79ED75D60A4 (request_id), add constraint FK3B9C79ED75D60A4 foreign key (request_id) references req (request_id)
alter table sign_aup_task add index FK7FCB416A32B8C70C (task_id), add constraint FK7FCB416A32B8C70C foreign key (task_id) references task (task_id)
alter table sign_aup_task add index FK7FCB416ADA1C6363 (aup_id), add constraint FK7FCB416ADA1C6363 foreign key (aup_id) references aup (id)
alter table tag_mapping add index fk_tag_mapping_roles (rid), add constraint fk_tag_mapping_roles foreign key (rid) references roles (rid) on delete cascade
alter table tag_mapping add index fk_tag_mapping_admins (admin_id), add constraint fk_tag_mapping_admins foreign key (admin_id) references admins (adminid) on delete cascade
alter table tag_mapping add index fk_tag_mapping_groups (gid), add constraint fk_tag_mapping_groups foreign key (gid) references groups (gid) on delete cascade
alter table tag_mapping add index fk_tag_mapping_tag (tag_id), add constraint fk_tag_mapping_tag foreign key (tag_id) references tags (id) on delete cascade
alter table task add index FK3635859AD54C57 (task_type_id), add constraint FK3635859AD54C57 foreign key (task_type_id) references task_type (id)
alter table task add index FK363585EE2D4487 (usr_id), add constraint FK363585EE2D4487 foreign key (usr_id) references usr (userid)
alter table task add index FK363585A4AD9904 (admin_id), add constraint FK363585A4AD9904 foreign key (admin_id) references admins (adminid)
alter table task_log_record add index FK77673CA632B8C70C (task_id), add constraint FK77673CA632B8C70C foreign key (task_id) references task (task_id)
alter table user_request_task add index FKACB7D2932B8C70C (task_id), add constraint FKACB7D2932B8C70C foreign key (task_id) references task (task_id)
alter table user_request_task add index FKACB7D299D73AC35 (req_id), add constraint FKACB7D299D73AC35 foreign key (req_id) references req (request_id)
alter table usr add index FK1C5947C6FEB32 (ca), add constraint FK1C5947C6FEB32 foreign key (ca) references ca (cid)
alter table usr_attrs add index FKA39E0E37566C2A8F (a_id), add constraint FKA39E0E37566C2A8F foreign key (a_id) references attributes (a_id)
alter table usr_attrs add index FKA39E0E3720331206 (u_id), add constraint FKA39E0E3720331206 foreign key (u_id) references usr (userid)
alter table vo_membership_req add index FK28EE8AFBD75D60A4 (request_id), add constraint FK28EE8AFBD75D60A4 foreign key (request_id) references req (request_id)
Deploying voms database...
Database deployed correctly!



VO fakevo installation finished.
 
You can start the voms services using the following commands:
    //etc/init.d/voms start fakevo
    //etc/init.d/voms-admin start fakevo




[root@cert-30 ~]# cat /etc/voms/fakevo/voms.conf 
--code=15000
--dbname=voms_fakevo_db
--logfile=/var/log/voms/voms.fakevo 
--loglevel=4
--logtype=7
--passfile=//etc/voms/fakevo/voms.pass
--port=15000
--sqlloc=/usr/lib64/libvomsmysql.so
--username=sulu
--vo=fakevo
--uri=cert-30.cnaf.infn.it:15000
--timeout=86400
--dbhost=cert-30.cnaf.infn.it

Result: Passed

[VOMS Admin] Trim spaces from DN when entered in the web interface (https://savannah.cern.ch/bugs/?88019)

Description of the test:

Added fake user with spaces before and after DN

Execution:

Verified from the web interface spaces were removed properly

Result: Passed

[VOMS Admin] Use single separator in the output of voms-admin list-users command (https://savannah.cern.ch/bugs/?86771)

Description of the test:

Command voms-admin --vo list-users executed.

Execution:


[root@cert-30 ~]# voms-admin --vo cert.mysql list-users
/C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele,/C=IT/ST=Emilia Romagna/L=Bologna/O=IGI/OU=VOMS/CN=Test CA,daniele.andreotti@cnaf.infn.it
ciccio pass,/C=AM/O=ArmeSFo/CN=ArmeSFo CA,ciccio@pasticcio.com

Result: Passed

[VOMS Admin] Small improvements to VOMS Admin WEB UI (https://savannah.cern.ch/bugs/?86327)

Description of the test: Check that the add certificate page shows the "Certificate subject (DN)" label instead of "Subject". Check that the registration page displays the "Given name", "Family name" labels insted of "Name", "Surname".

Execution:

Verified from the web interface

Result: Passed

[VOMS Admin] voms-admin-ping looking in wrong place to determine list of VOs (https://savannah.cern.ch/bugs/?85657)

Description of the test:

Configure three different VOs with YAIM. After YAIM configuration is over, stop two of them with service voms-admin and check that one VO is shown as active, while the other two are reported as stopped.

Execution:


[root@cert-30 siteinfo]# voms-admin-ping 
Testing cert.1:                        [  OK  ]
Testing cert.2:                        [  OK  ]
Testing cert.mysql:                    [  OK  ]

[root@cert-30 siteinfo]# /etc/init.d/voms-admin stop cert.1
Stopping vo cert.1
[root@cert-30 siteinfo]# /etc/init.d/voms-admin stop cert.2
Stopping vo cert.2

[root@cert-30 siteinfo]# voms-admin-ping 
Testing cert.1:                        [  SOAP error: VO is not active.  ]
Testing cert.2:                        [  SOAP error: VO is not active.  ]
Testing cert.mysql:                    [  OK  ]


Result: Passed

[VOMS Admin] AUP URL for active AUP should be editable from the Web interface (https://savannah.cern.ch/bugs/?83161)

Description of the test: Verified from the web interface.

Execution:

Aup URL changed to a wrong name. Error message prompted. URL edited to the original name.  

Result: Passed

[VOMS Admin] AUP URL wrong in VOMS database after upgrade to EMI 1 VOMS (https://savannah.cern.ch/bugs/?83159)

Description of the test:

Execution:

Verified https://savannah.cern.ch/bugs/?83161 which is a fix for this too. 

Result: Passed

[VOMS Admin] Provide access to membership statistics (https://savannah.cern.ch/bugs/?93968)

Description of the test: Executed voms-admin command tools for getting membership stats.

Execution:



[root@cert-30 siteinfo]# voms-admin  --vo cert.mysql   count-users count-suspended-users count-expired-users list-suspended-users list-expired-users list-user-stats
User count: 2
Suspended user count: 1
Expired user count: 1
ciccio pass,/C=AM/O=ArmeSFo/CN=ArmeSFo CA,Suspended: User membership has expired.,ciccio pasticcio (3)
ciccio pass,/C=AM/O=ArmeSFo/CN=ArmeSFo CA,Suspended: User membership has expired.,ciccio pasticcio (3)
expiredUsersCount = 1 
suspendedUsersCount = 1 
usersCount = 2 


Result: Passed

[VOMS Admin] The voms-admin-configure --read-access-to-authenticated-clients options produces no effect (https://savannah.cern.ch/bugs/?93978)

Description of the test: Checked by the web interface

Execution:

Line Automatically added at configuration: 
CN=Any Authenticated User CN=Dummy Certificate Authority    r   r                       edit    delete

Result: Passed

[VOMS] VOMS fails in producing AC if certificate subject name contains an apostrophe (https://savannah.cern.ch/bugs/?93455)

Description of the test: Create a test certificate containing an apostrophe. Register this certificate in VOMS. Ensure that it's possible to obtain an AC out of VOMS with the just created certificate.

Execution:


[andreotti-bbr@cert-30 ~]$ voms-proxy-init -voms cert.1 -cert apostrophe-daniele-cert.pem -key apostrophe-daniele-key.pem 
Your identity: /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele
Creating temporary proxy ....................... Done
Contacting  cert-30.cnaf.infn.it:15001 [/C=IT/O=INFN/OU=Host/L=CNAF/CN=cert-30.cnaf.infn.it] "cert.1" Done
Creating proxy .............................................................................................. Done

Your proxy is valid until Mon May  7 23:25:52 2012

[andreotti-bbr@cert-30 ~]$ voms-proxy-init -voms cert.1 --noregen
Your identity: /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele/CN=proxy
Contacting  cert-30.cnaf.infn.it:15001 [/C=IT/O=INFN/OU=Host/L=CNAF/CN=cert-30.cnaf.infn.it] "cert.1" Done
Creating proxy ........................................................................ Done


Warning: your certificate and proxy will expire Mon May  7 23:25:52 2012
which is within the requested lifetime of the proxy


[andreotti-bbr@cert-30 ~]$ voms-proxy-init -voms cert.1 --noregen
Your identity: /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele/CN=proxy/CN=proxy
Contacting  cert-30.cnaf.infn.it:15001 [/C=IT/O=INFN/OU=Host/L=CNAF/CN=cert-30.cnaf.infn.it] "cert.1" Done
Creating proxy ....................................................................................... Done


Warning: your certificate and proxy will expire Mon May  7 23:25:52 2012
which is within the requested lifetime of the proxy

[andreotti-bbr@cert-30 ~]$ voms-proxy-init -voms cert.1 --noregen
Your identity: /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele/CN=proxy/CN=proxy/CN=proxy
Contacting  cert-30.cnaf.infn.it:15001 [/C=IT/O=INFN/OU=Host/L=CNAF/CN=cert-30.cnaf.infn.it] "cert.1" Done
Creating proxy ............................................................ Done


Warning: your certificate and proxy will expire Mon May  7 23:25:52 2012
which is within the requested lifetime of the proxy


[andreotti-bbr@cert-30 ~]$ voms-proxy-info --all 
subject   : /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele/CN=proxy/CN=proxy/CN=proxy/CN=proxy
issuer    : /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele/CN=proxy/CN=proxy/CN=proxy
identity  : /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele/CN=proxy/CN=proxy/CN=proxy
type      : proxy
strength  : 1024 bits
path      : /tmp/x509up_u519
timeleft  : 11:59:45
key usage : Digital Signature, Key Encipherment
=== VO cert.1 extension information ===
VO        : cert.1
subject   : /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele
issuer    : /C=IT/O=INFN/OU=Host/L=CNAF/CN=cert-30.cnaf.infn.it
attribute : /cert.1/Role=NULL/Capability=NULL
timeleft  : 11:59:55
uri       : cert-30.cnaf.infn.it:15001


Result: Passed

[VOMS] VOMS MySQL plugin causes 'Aborted connection' warnings on MySQL (https://savannah.cern.ch/bugs/?93456)

Description of the test: Configure a MySQL based VO. Add a user to the VO. Run a large number of AC requests against the VOMS server for that user (e.g., 500 requests). Set the log-warnings=2 in the MySQL configuration, typically /etc/my.cnf. Ensure that the mysql log doesn't contain an "Aborted connection" warning for each request (some aborted connections are accetable).

Execution:


998
Your identity: /C=IT/O=INFN/OU=Personal Certificate/L=CNAF/CN=Daniele Andreotti/CN=proxy
Contacting  cert-30.cnaf.infn.it:15001 [/C=IT/O=INFN/OU=Host/L=CNAF/CN=cert-30.cnaf.infn.it] "cert.1" Done
Creating proxy .......................................... Done

Warning: your certificate and proxy will expire Sun May  6 00:48:59 2012
which is within the requested lifetime of the proxy


999
Your identity: /C=IT/O=INFN/OU=Personal Certificate/L=CNAF/CN=Daniele Andreotti/CN=proxy
Contacting  cert-30.cnaf.infn.it:15001 [/C=IT/O=INFN/OU=Host/L=CNAF/CN=cert-30.cnaf.infn.it] "cert.1" Done
Creating proxy .............................. Done

Warning: your certificate and proxy will expire Sun May  6 00:48:59 2012
which is within the requested lifetime of the proxy


1000
Your identity: /C=IT/O=INFN/OU=Personal Certificate/L=CNAF/CN=Daniele Andreotti/CN=proxy
Contacting  cert-30.cnaf.infn.it:15001 [/C=IT/O=INFN/OU=Host/L=CNAF/CN=cert-30.cnaf.infn.it] "cert.1" Done
Creating proxy ............................................................................ Done

Warning: your certificate and proxy will expire Sun May  6 00:48:59 2012
which is within the requested lifetime of the proxy


[mysql log]
120505 12:41:44 [Note] /usr/libexec/mysqld: ready for connections.
Version: '5.1.61'  socket: '/var/lib/mysql/mysql.sock'  port: 3306  Source distribution

120505 13:00:56 [Note] /usr/libexec/mysqld: Normal shutdown

120505 13:00:56 [Note] Event Scheduler: Purging the queue. 0 events
120505 13:00:58  InnoDB: Starting shutdown...
120505 13:01:03  InnoDB: Shutdown completed; log sequence number 0 3341851
120505 13:01:03 [Note] /usr/libexec/mysqld: Shutdown complete


Result: Passed

[VOMS] YAIM VOMS should provide a way to configure --skipcacheck voms configuration parameter (https://savannah.cern.ch/bugs/?89202)

Description of the test: Configure a VO with YAIM specifying the VOMS_SKIP_CA_CHECK variable. Ensure that the /etc//voms.conf configuration file contains the --skipcacheck after the configuration.

Execution:


VO_CERT_1_VOMS_PORT=15001
VO_CERT_1_VOMS_DB_USER=u1
VO_CERT_1_VOMS_DB_PASS="pwd"
VO_CERT_1_VOMS_DB_NAME=voms_cert_1

## Additional settings
VOMS_SKIP_CA_CHECK=true


[root@cert-30 siteinfo]# cat /etc/voms/cert.1/voms.conf 
--vo=cert.1
--port=15001
--code=15001
--uri=cert-30.cnaf.infn.it:15001
--loglevel=4
--logtype=7
--timeout=86400
--logfile=/var/log/voms/voms.cert.1
--passfile=//etc/voms/cert.1/voms.pass
--sqlloc=/usr/lib64/libvomsmysql.so
--dbname=voms_cert_1
--skipcacheck
--username=u1

Result: Passed

VOMS Oracle

[VOMS Admin] VOMS Admin SIGN AUP default grace period is too short (https://savannah.cern.ch/bugs/?93370)

Description of the test:

Manually set expiration date for users membership into VOMS db. First attempt: set a date to invalidate membership but in order to don't exceed the grace period. Second attempt: set a date to exceed also the grace period.

Execution:

Into VOMS db:

update usr set end_time='28-APR-12' where name='ciccio';

2012-05-05 09:17:54.021Z - DEBUG [MembershipCheckerTask] - Expired members: [[id=4,defaultCertficate=[subject_string=ciccio pass,ca=/C=AM/O=ArmeSFo/CN=ArmeSFo CA],name=ciccio,surname=pasticcio,emailAddress=ciccio@pasticcio.com,suspended=false,endTime=2012-04-28 00:00:00.0]]
2012-05-05 09:17:54.024Z - DEBUG [GracePeriodExpiredMembersStrategy] - Handling expired members: [[id=4,defaultCertficate=[subject_string=ciccio pass,ca=/C=AM/O=ArmeSFo/CN=ArmeSFo CA],name=ciccio,surname=pasticcio,emailAddress=ciccio@pasticcio.com,suspended=false,endTime=2012-04-28 00:00:00.0]]
2012-05-05 09:17:54.024Z - DEBUG [GracePeriodExpiredMembersStrategy] - User '[id=4,defaultCertficate=[subject_string=ciccio pass,ca=/C=AM/O=ArmeSFo/CN=ArmeSFo CA],name=ciccio,surname=pasticcio,emailAddress=ciccio@pasticcio.com,suspended=false,endTime=2012-04-28 00:00:00.0]' not suspended due to grace period.
2012-05-05 09:17:54.024Z - DEBUG [GracePeriodExpiredMembersStrategy] - Now: Sat May 05 11:17:54 CEST 2012, User end time: 2012-04-28 00:00:00.0, Grace period (in days): 7
2012-05-05 09:17:54.025Z - INFO [GracePeriodExpiredMembersStrategy] - Sending out notification about EXPIRED VO members.


update usr set end_time='27-APR-12' where name='ciccio';


2012-05-05 09:19:54.024Z - INFO [GracePeriodExpiredMembersStrategy] - Suspending user '[id=4,defaultCertficate=[subject_string=ciccio pass,ca=/C=AM/O=ArmeSFo/CN=ArmeSFo CA],name=ciccio,surname=pasticcio,emailAddress=ciccio@pasticcio.com,suspended=false,endTime=2012-04-27 00:00:00.0]' since its membership has expired and grace period is over.
2012-05-05 09:19:54.073Z - DEBUG [GracePeriodExpiredMembersStrategy] - Now: Sat May 05 11:19:54 CEST 2012, User end time: 2012-04-27 00:00:00.0, Grace period (in days): 7

Result: Passed

[VOMS Admin] VOMS Admin does not send warning message before suspending users due to membership expiration (https://savannah.cern.ch/bugs/?93255)

Description of the test: Set the expiration date for users membership conveniently. Check if warning emails are sent as expected.

Execution:

MAIL RECEIVED

Dear VO Administrator,

this mail is to inform you that membership in VO cert.oracle for the following users has EXPIRED:


ciccio pasticcio (4) membership has expired since 7 days.The user is still active can get VOMS attributes as usual.
  


Please evaluate whether each membership should be extended by pointing your browser to the following URL:

https://cert-30.cnaf.infn.it:8443/voms/cert.oracle/user/search.action

Your sincerely,
Voms-Admin registration service for VO cert.oracle

Result: Passed

[VOMS Admin] Trim spaces from DN when entered in the web interface (https://savannah.cern.ch/bugs/?88019)

Description of the test:

Added fake user with spaces before and after DN

Execution:

Verified from the web interface spaces were removed properly

Result: Passed

[VOMS Admin] Use single separator in the output of voms-admin list-users command (https://savannah.cern.ch/bugs/?86771)

Description of the test:

Command voms-admin --vo list-users executed.

Execution:


[root@cert-30 ~]# voms-admin  --vo cert.oracle list-users
/C=IT/O=INFN/OU=Personal Certificate/L=CNAF/CN=Andrea Ceccanti,/C=IT/O=INFN/CN=INFN CA,andrea.ceccanti@cnaf.infn.it
/C=IT/O=INFN/OU=Personal Certificate/L=CNAF/CN=Daniele Andreotti,/C=IT/O=INFN/CN=INFN CA,daniele.andreotti@cnaf.infn.it
ciccio pass,/C=AM/O=ArmeSFo/CN=ArmeSFo CA,ciccio@pasticcio.com

Result: Passed

[VOMS Admin] Small improvements to VOMS Admin WEB UI (https://savannah.cern.ch/bugs/?86327)

Description of the test: Check that the add certificate page shows the "Certificate subject (DN)" label instead of "Subject". Check that the registration page displays the "Given name", "Family name" labels insted of "Name", "Surname".

Execution:

Verified from the web interface

Result: Passed

[VOMS Admin] voms-admin-ping looking in wrong place to determine list of VOs (https://savannah.cern.ch/bugs/?85657)

Description of the test:

Configure two different VOs with YAIM. After YAIM configuration is over, stop one of them with service voms-admin and check that one VO is shown as active, while the other is reported as stopped.

Execution:


[root@cert-30 ~]# voms-admin-ping 
Testing cert.1:                        [  OK  ]
Testing cert.oracle:                   [  OK  ]

[root@cert-30 ~]# /etc/init.d/voms-admin stop cert.1
Stopping vo cert.1

[root@cert-30 ~]# voms-admin-ping 
Testing cert.1:                        [  SOAP error: VO is not active.  ]
Testing cert.oracle:                   [  OK  ]

Result: Passed

[VOMS Admin] AUP URL for active AUP should be editable from the Web interface (https://savannah.cern.ch/bugs/?83161)

Description of the test: Verified from the web interface.

Execution:

Aup URL changed to a wrong name. Error message prompted. URL edited to the original name.  

Result: Passed

[VOMS Admin] AUP URL wrong in VOMS database after upgrade to EMI 1 VOMS (https://savannah.cern.ch/bugs/?83159)

Description of the test:

Execution:

Verified https://savannah.cern.ch/bugs/?83161 which is a fix for this too. 

Result: Passed

[VOMS Admin] Provide access to membership statistics (https://savannah.cern.ch/bugs/?93968)

Description of the test: Executed voms-admin command tools for getting membership stats.

Execution:


[root@cert-30 ~]#  voms-admin  --vo cert.oracle   count-users count-suspended-users count-expired-users list-suspended-users list-expired-users list-user-stats

User count: 3
Suspended user count: 0
Expired user count: 0
No suspended users found.
No expired users found.
expiredUsersCount = 0 
suspendedUsersCount = 0 
usersCount = 3 

Result: Passed

[VOMS Admin] The voms-admin-configure --read-access-to-authenticated-clients options produces no effect (https://savannah.cern.ch/bugs/?93978)

Description of the test: Checked by the web interface

Execution:

Line Automatically added at configuration: 
CN=Any Authenticated User CN=Dummy Certificate Authority    r   r                       edit    delete

Result: Passed

[VOMS Admin] VOMS Admin should use independent Oracle sequences for the main VOMS tables (https://savannah.cern.ch/bugs/?93976)

Description of the test:

Execution:


Result:

[VOMS] Middleman process crashes (Oracle backend) (https://savannah.cern.ch/bugs/?86273)

Description of the test: run a script which executes the voms-proxy-init --noregen command 2000 times.

Execution:


1998
Your identity: /C=IT/O=INFN/OU=Personal Certificate/L=CNAF/CN=Daniele Andreotti/CN=proxy
Contacting  cert-30.cnaf.infn.it:15000 [/C=IT/O=INFN/OU=Host/L=CNAF/CN=cert-30.cnaf.infn.it] "cert.oracle" Done
Creating proxy ........................................................ Done


Warning: your certificate and proxy will expire Sat May  5 23:49:45 2012
which is within the requested lifetime of the proxy
1999
Your identity: /C=IT/O=INFN/OU=Personal Certificate/L=CNAF/CN=Daniele Andreotti/CN=proxy
Contacting  cert-30.cnaf.infn.it:15000 [/C=IT/O=INFN/OU=Host/L=CNAF/CN=cert-30.cnaf.infn.it] "cert.oracle" Done
Creating proxy .............................................. Done


Warning: your certificate and proxy will expire Sat May  5 23:49:45 2012
which is within the requested lifetime of the proxy
2000
Your identity: /C=IT/O=INFN/OU=Personal Certificate/L=CNAF/CN=Daniele Andreotti/CN=proxy
Contacting  cert-30.cnaf.infn.it:15000 [/C=IT/O=INFN/OU=Host/L=CNAF/CN=cert-30.cnaf.infn.it] "cert.oracle" Done
Creating proxy ..................................... Done


Warning: your certificate and proxy will expire Sat May  5 23:49:45 2012
which is within the requested lifetime of the proxy


Result: Passed

[VOMS] VOMS fails in producing AC if certificate subject name contains an apostrophe (https://savannah.cern.ch/bugs/?93455)

Description of the test: Create a test certificate containing an apostrophe. Register this certificate in VOMS. Ensure that it's possible to obtain an AC out of VOMS with the just created certificate.

Execution:


[andreotti-bbr@cert-30 ~]$ voms-proxy-init -voms cert.oracle -cert apostrophe-daniele-cert.pem -key apostrophe-daniele-key.pem 
Your identity: /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele
Creating temporary proxy ..................... Done
Contacting  cert-30.cnaf.infn.it:15000 [/C=IT/O=INFN/OU=Host/L=CNAF/CN=cert-30.cnaf.infn.it] "cert.oracle" Done
Creating proxy ................................. Done

Your proxy is valid until Mon May  7 23:34:37 2012

[andreotti-bbr@cert-30 ~]$ voms-proxy-init -voms cert.oracle --noregen
Your identity: /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele/CN=proxy
Contacting  cert-30.cnaf.infn.it:15000 [/C=IT/O=INFN/OU=Host/L=CNAF/CN=cert-30.cnaf.infn.it] "cert.oracle" Done
Creating proxy .............................................................................. Done


Warning: your certificate and proxy will expire Mon May  7 23:34:37 2012
which is within the requested lifetime of the proxy


[andreotti-bbr@cert-30 ~]$ voms-proxy-init -voms cert.oracle --noregen
Your identity: /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele/CN=proxy/CN=proxy
Contacting  cert-30.cnaf.infn.it:15000 [/C=IT/O=INFN/OU=Host/L=CNAF/CN=cert-30.cnaf.infn.it] "cert.oracle" Done
Creating proxy ...................................... Done


Warning: your certificate and proxy will expire Mon May  7 23:34:37 2012
which is within the requested lifetime of the proxy


[andreotti-bbr@cert-30 ~]$ voms-proxy-init -voms cert.oracle --noregen
Your identity: /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele/CN=proxy/CN=proxy/CN=proxy
Contacting  cert-30.cnaf.infn.it:15000 [/C=IT/O=INFN/OU=Host/L=CNAF/CN=cert-30.cnaf.infn.it] "cert.oracle" Done
Creating proxy ................................................. Done


Warning: your certificate and proxy will expire Mon May  7 23:34:37 2012
which is within the requested lifetime of the proxy



[andreotti-bbr@cert-30 ~]$ voms-proxy-info --all 
subject   : /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele/CN=proxy/CN=proxy/CN=proxy/CN=proxy
issuer    : /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele/CN=proxy/CN=proxy/CN=proxy
identity  : /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele/CN=proxy/CN=proxy/CN=proxy
type      : proxy
strength  : 1024 bits
path      : /tmp/x509up_u519
timeleft  : 11:59:35
key usage : Digital Signature, Key Encipherment
=== VO cert.oracle extension information ===
VO        : cert.oracle
subject   : /C=IT/ST=Emilia Romagna/O=IGI/OU=VOMS/CN=d'aniele
issuer    : /C=IT/O=INFN/OU=Host/L=CNAF/CN=cert-30.cnaf.infn.it
attribute : /cert.oracle/Role=NULL/Capability=NULL
timeleft  : 11:59:56
uri       : cert-30.cnaf.infn.it:15000


Result: Passed

[VOMS] YAIM VOMS should provide a way to configure --skipcacheck voms configuration parameter (https://savannah.cern.ch/bugs/?89202)

Description of the test: Configure a VO with YAIM specifying the VOMS_SKIP_CA_CHECK variable. Ensure that the /etc//voms.conf configuration file contains the --skipcacheck after the configuration.

Execution:


VO_CERT_ORACLE_VOMS_PORT=15000
VO_CERT_ORACLE_VOMS_DB_USER=admin_25
VO_CERT_ORACLE_VOMS_DB_PASS=pwd
VO_CERT_ORACLE_VOMS_DB_TYPE=oracle

## Additional settings
VOMS_SKIP_CA_CHECK=true


[root@cert-30 siteinfo]# cat /etc/voms/cert.oracle/voms.conf 
--vo=cert.oracle
--port=15000
--code=15000
--uri=cert-30.cnaf.infn.it:15000
--loglevel=4
--logtype=7
--timeout=86400
--logfile=/var/log/voms/voms.cert.oracle
--passfile=//etc/voms/cert.oracle/voms.pass
--sqlloc=/usr/lib64/libvomsoracle.so
--dbname=DB_VOMS
--skipcacheck
--username=admin_25

Result: Passed

Upgrade deployment test

Starting from an EMI 1 machine, the emi-release package is removed with the following command:

rpm -e emi-release

And the EMI_2_RC repositories and the VOMS last build repository are installed in /etc/yum.repos.d instead.

SL5/x86_64

VOMS MySQL

After reconfiguration tomcat is stopped, the work directory is cleaned up with:

cd $CATALINA_HOME; rm -rf work

Tomcat is then restarted. Smoke testing proves that VOs are up and running and that commands behave as expected.

VOMS Oracle

After stopping the services (voms and tomcat), yum update is run (yum update log).

After the yum update and before reconfiguration, the Oracle database is upgraded (due to https://savannah.cern.ch/bugs/?93976) with the following command:

[root@emitestbed18 yum.repos.d]# voms-db-deploy.py upgrade --vo cert.oracle
Checking database connectivity...
Database contacted succesfully
Checking database existence...
Found existing voms-admin 2.5.x database...
Upgrading voms-admin 2.5.x database to the latest schema.
Creating oracle sequences starting from VOMS Admin 2.6.x database.
Sequences migration complete. 

Then the service is reconfigured with YAIM (yaim reconfiguration log). After reconfiguration tomcat is stopped, the work directory is cleaned up with:

cd $CATALINA_HOME; rm -rf work

Tomcat is then restarted. Smoke testing proves that VOs are up and running and that commands behave as expected.

-- AndreaCeccanti - 2012-04-11

Topic attachments
I Attachment Action Size Date Who Comment
Unknown file formatlog 20120426_135719_VOMS_EMI2_SL6-64-CERTIFICATION_TASK_24846-24847.log manage 162.1 K 2012-04-26 - 13:21 DaniloDongiovanni  
Unknown file formatlog 20120426_140233_VOMS_EMI2_SL5_64-CERTIFICATION_TASK_24846-24847.log manage 83.3 K 2012-04-26 - 13:45 DanieleAndreotti  
Unknown file formatlog oracle-db-upgrade.log manage 0.4 K 2012-05-04 - 18:48 AndreaCeccanti  
Unknown file formatEXT voms-admin-testsuite-result-SL5_x86-64_mysql manage 14.9 K 2012-05-04 - 08:32 AndreaCeccanti VOMS Admin testsuite results for SL5 x86-64 (MySQL backend)
Unknown file formatEXT voms-admin-testsuite-result-SL5_x86-64_oracle manage 14.9 K 2012-05-04 - 09:19 AndreaCeccanti VOMS Admin testsuite results for SL5 x86-64 (Oracle backend)
Unknown file formatEXT voms-admin-testsuite-result-SL6_x86-64-mysql manage 14.9 K 2012-05-07 - 10:39 AndreaCeccanti VOMS Admin testsuite results for SL6 x86-64 (MySQL backend)
Unknown file formatEXT voms-admin-testsuite-result-SL6_x86-64-oracle manage 15.1 K 2012-05-07 - 10:40 AndreaCeccanti VOMS Admin testsuite results for SL6 x86-64 (Oracle backend)
Unknown file formatlog yaim-update-sl5-oracle.log manage 8.0 K 2012-05-04 - 18:48 AndreaCeccanti YAIM reconfiguratino log for SL5 upgrade deployment test (Oracle)
Unknown file formatlog yaim-update-sl5.log manage 74.9 K 2012-05-04 - 16:19 AndreaCeccanti YAIM reconfiguratino log for SL5 upgrade deployment test
Unknown file formatgz yum-sl5-repos.tar.gz manage 2.3 K 2012-05-07 - 10:21 AndreaCeccanti YUM repo files (SL5)
Unknown file formatgz yum-sl6-repos.tar.gz manage 3.0 K 2012-05-07 - 10:21 AndreaCeccanti YUM repo files (SL6)
Unknown file formatlog yum-update-sl5-oracle.log manage 25.4 K 2012-05-04 - 18:49 AndreaCeccanti Yum update log for SL5 upgrade deployment test (Oracle)
Unknown file formatlog yum-update-sl5.log manage 25.8 K 2012-05-04 - 16:18 AndreaCeccanti Yum update log for SL5 upgrade deployment test
Topic revision: r32 - 2012-05-07 - AndreaCeccanti
 
TWIKI.NET
This site is powered by the TWiki collaboration platformCopyright © 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback